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1 Getting Started

1.1 NDI DataView

NDI DataView software allows you to view, edit, and print the data stored in NDI 
floating point data files. With NDI DataView, you can create tables and graphs of 
data to observe characteristic features of data.

1.2 How to Use this Guide

This guide is divided into four sections:

• Getting Started: explains the basic concepts of NDI DataView and the layout 
of its main window, as well as how to install the software.

• Common Procedures: shows how to accomplish specific tasks using NDI 
DataView. These tasks include opening data files, viewing data as a graph or a 
table, and editing data.

• File Breakdown: describes the different file formats that NDI DataView can 
open.

• Glossary: defines terms often used with NDI DataView.

If you are new to NDI DataView, begin with the Getting Started section to become 
familiar with the basic concepts. The Common Procedures section provides examples 
to help you accomplish specific tasks.

Additional information about NDI DataView is available in the online help.

1.3 Installing NDI DataView

1. Place the NDI DataView CD in the CD-ROM drive.

The NDI DataView install wizard starts.

2. Follow the on screen instructions to install NDI DataView.

The install wizard will ask you to specify the location at which to install NDI 
DataView. By default, this location is c:\Program Files\Northern Digital Inc\NDI 

DataView.

The examples in this guide use the location c:\My Experiments to store data files.
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1.4 The NDI DataView Main Window

The NDI DataView main window allows you to open, display, edit, and print data 
files as tables and graphs. Windows containing individual table and graph views of 
opened data files appear within this window. The main window itself contains four 
sections:

Figure 1-1:  The NDI DataView main window

NDI DataView Window Sections

• Menu Bar: manages data files and the table and graph view windows within 
the main window.

• Toolbar: provides many of the same functions as the menu bar. Each toolbar 
icon corresponds to a function which is often also available through the 
menu bar. Holding the mouse pointer over a toolbar icon will display a tool 
tip showing the function of that icon.

• Explorer Bar: browses and searches for data files. It appears at the left side of 
the main window by default.

• Status Bar: displays the meanings of menu items and toolbar icons as they 
are selected. It appears by default as a grey area at the bottom of the main 
window.

Explorer Bar

Menu Bar

Toolbar

Status Bar
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1.4.1 The Table View

In a table view, the data in a particular data file is sorted and displayed in a table. 
This table appears in a separate window within the NDI DataView main window. A 
table view appears when a data file is opened:

Figure 1-2:  A table view of 3D data

The table displays either the values of a particular item for all frames in the data file 
(e.g. the x, y, and z positions of a given marker for all frames) or the values of all 
items for a specific frame (e.g. the x, y, and z positions of all markers for a specific 
frame).

For more information on working with the table view, see “Viewing Data in a Table” 
on page 23. For more information on the items found in each type of NDI data file, 
see “File Breakdown” on page 73.
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1.4.2 The Graph View

In a graph view, the data in a particular data file is displayed as a line graph that 
appears in a separate window within the NDI DataView main window. To create a 
graph view of a particular set of data, select Graph>Display Graph in the NDI 
DataView main window:

Figure 1-3:  A graph view of 3D data

The values of items and subitems in the data file are plotted versus frame number. 
The set of values plotted for a given subitem is called a dataset. Items and subitems 
that appear in the graph can be changed after the graph is created. For more 
information on working with the graph view, see “Viewing Data in a Graph” on 
page 36.
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1.4.3 Working with Views

Table and graph views appear in individual windows within the NDI DataView main 
window. A table view is created when a data file is opened, and a graph view is 
initially created from a table view by selecting Graph>Display Graph. The graph 
view and table view windows for the same data can exist simulataneously and closing 
one window will not close the other. The two windows can be worked with separately.

Multiple graph views can be created for the same data file, allowing graph views of a 
variety of datasets with a variety of appearances and zoom levels at the same time. 
Multiple table views can be created by selecting Window>New Window.

If a graph view of a data file is open within NDI DataView but the table view of that 
data file has been closed, opening the file again will not create a new table view. 
Instead, NDI DataView will make the existing graph view active. To create a new table 
view of a data file, select Window>New Window while any graph view of that data 
file is active.

Table and/or graph views of different data files can be open at the same time. The 
name of the data file that the particular view corresponds to appears in the title bar 
of the view window. The data file type appears as an icon in the upper left corner of 
the window. For more information on file type icons, see “Appendix B: Icon Guide” 
on page 96.
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2 Common Procedures

This section describes how to accomplish tasks for which NDI DataView is often 
used. These tasks are described as procedures, and each step of each procedure is 
explained in detail. The following tasks are included:

• Opening Data Files

• Viewing Data in a Table

• Viewing Data in a Graph

Install NDI DataView before beginning any of these procedures. For more 
information on installing NDI DataView, see “Installing NDI DataView” on page 1.

2.1 Opening Data Files

NDI DataView can open five types of NDI data files. Four ways of opening data files 
are available:

• Using the Open Window

• Browsing for a Data File

• Searching for a Data File

• Dragging and Dropping a Data File

To obtain information about a data file, view the file header after opening the file. 
For more information on the file header, see “Editing File Header Information” on 
page 21.

For more information on the types of data files NDI DataView can open, see “File 
Breakdown” on page 73.
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2.1.1 Starting NDI DataView

1. Double click the NDI DataView icon  on your Microsoft Windows 
desktop.

The NDI DataView main window opens:

Figure 2-1:  The NDI DataView main window
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2.1.2 Using the Open Window

Use the Open window to open an NDI data file of a specific name and type.

1. Select File>Open in the NDI DataView main window.

The Open window opens:

Figure 2-2:  The Open window

2. Browse to the location of the data file you want to open:

Figure 2-3:  A sample location of NDI data files
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3. Select the type of data file you want to open from the Files of type list:

Figure 2-4:  A list of file types NDI DataView can open

4. Select the data file to open:

Figure 2-5:  A 3D data file selected in the Open window
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5. Click Open.

A table view of the data file opens in the main window:

Figure 2-6:  A table view of 3D data

For more information on working with the table view, see “Viewing Data in a 
Table” on page 23.
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2.1.3 Browsing for a Data File

Use the Explorer Bar to browse among NDI data files in a particular location.

1. Select the Browse tab in the Explorer Bar:

Figure 2-7:  The Explorer Bar Browse and Search tabs

The Browse Bar opens in the main window:

Figure 2-8:  The Browse Bar

Note To open the Explorer Bar, select View>Explorer Bar in the NDI DataView main window.
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2. Expand the list in the Browse Bar and select the location you want to browse for 
NDI data files:

Figure 2-9:  A location selected in the Browse Bar

The Browse Bar displays a list of all the NDI data files in that location:

Figure 2-10:  A list of NDI data files in the Browse Bar
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3. Select the type of file you want to open from the list in the Browse Bar:

Figure 2-11:  The Browse Bar list of file types

The Browse Bar only displays files of the selected type:

Figure 2-12:  A list of 3D data files in the Browse Bar

The Custom file type refers to a non-standard file mask. This mask can only be 
specified in the Search Bar. The default mask is “*#*”.
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4. Double click the name of the file to open.

A table view of the data file opens in the main window:

Figure 2-13:  A table view of 3D data

For more information on working with the table view, see “Viewing Data in a 
Table” on page 23.
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2.1.4 Searching for a Data File

Use the Explorer Bar to search for NDI data files in a particular location.

1. Select the Search tab in the Explorer Bar:

Figure 2-14:  The Explorer Bar Browse and Search tabs

The Search Bar opens in the main window:

Figure 2-15:  The Search Bar

Note To open the Explorer Bar, select View>Explorer Bar in the NDI DataView main window.



Common Procedures

16 NDI DataView User Guide - Revision 2

2. Select the type of file you want to search for from the list in the Search Bar:

Figure 2-16:  The Search Bar list of file types

The Search for files named box displays the general name for the selected file 
type:

Figure 2-17:  The file mask for 3D data files in the Search Bar

The Custom file type refers to a non-standard file mask. This mask can only be 
specified in the Search Bar. The default mask is “*#*”.
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3. Further refine the file name you want to search for in the Search for files 
named box:

Figure 2-18:  A modified 3D data file mask in the Search Bar

The file name is not case-sensitive. The wildcards “*” and “?”, referring to any 
number of any characters and any single character, respectively, can be used to 
search for partial file names. For example, searching for “rig*.?at” would find any 
file with a file name beginning with “rig” and having a three-letter file name 
extension ending in “at”.

When the file name is changed, the selected file type changes to Custom to reflect 
that the entered file name no longer matches the general name for any NDI data 
file type.

File names previously searched for can be selected from the Search for files 
named list.

4. Enter the location to search for files in the Look in box:

Figure 2-19:  The Search Bar search location

Previously searched locations can be selected from the Look in list.

Click Browse to select a search location by browsing. For more information, see 
“Browsing for a Search Location” on page 19.

Note NDI DataView also searches all sub-locations within the location you specify.
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5. Click Search.

The names of files that match the search criteria begin to appear in the Search 
Bar:

Figure 2-20:  A list of 3D data files in the Search Bar

To stop the search before it is finished, click Stop.

6. Double click the name of the file to open.

A table view of the data file opens in the main window:

Figure 2-21:  A table view of 3D data

For more information on working with the table view, see “Viewing Data in a 
Table” on page 23.
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Browsing for a Search Location

The search location in the Search Bar can be selected by browsing instead of being 
entered manually.

1. Click Browse in the Search Bar.

The Select Folder window opens:

Figure 2-22:  The Select Folder window

2. Browse to the location you want to search.

3. Select the location:

Figure 2-23:  Locations displayed in the Select Folder window
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4. Click Select.

The Select Folder window closes and the Look in box of the Search Bar displays 
the selected location:

Figure 2-24:  A selected search location in the Search Bar

Note If no location is highlighted in the Select Folder window when the Select button is clicked, 
NDI DataView will select the last location opened in that window by default.
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2.1.5 Editing File Header Information

NDI DataView can display the header information of an NDI data file after it is 
opened.

1. Select Edit>File Header in the NDI DataView main window.

The File Header Information window opens:

Figure 2-25:  The File Header Information window

The File Header Information window displays the following information about 
the data file:

• Collection Time: the time of day, in 24 hour format, at which the data in 
the file was collected.

• Collection Date: the date on which the data in the file was collected.

• Frames: the total number of frames in the file.

• Items: the total number of items in the file.

• Floating Point Subitems: the number of floating point subitems per item.
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• Character Subitems: the number of character subitems per item.

• Integer Subitems: the number of integer subitems per item.

• Double Subitems: the number of double subitems per item.

• Item Size: the size of each item of data, in bytes.

• Sample Frequency: the number of frames of data that were recorded to the 
file per second.

• Cutoff Frequency: the cutoff frequency used if 3D data was filtered.

• User Comments: often a description of the data the file contains. User 
comments can be edited using NDI DataView.

• System Comments: may contain a short description of the data file type or 
other file information.

For a complete description of the composition of NDI floating point data files, 
refer to “Appendix B: File Formats” in the “Optotrak Certus User Guide”.

2. Enter any new comment information in the User Comments box:

Figure 2-26:  A new user comment in the File Header Information window

3. Click OK.

The File Header Information windows closes.

Note The data file must be saved for any changes to the file header to be preserved. For more 
information on saving data files, see “Saving a Data File” on page 34.
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2.2 Viewing Data in a Table

The table view displays the contents of a data file in a table and allows you to edit 
individual values. Values in the table are sorted by frame or item.

To create a table view, open an NDI data file. The table window for that file opens 
within the NDI DataView main window, with the data for the first item in the file 
listed by frame number:

Figure 2-27:  A table view of 3D data

For more information on opening data files, see “Opening Data Files” on page 6.
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2.2.1 Viewing Data by Item

When viewing data by item a table view displays the values of all the subitems of one 
item, for all frames. The item for which values are displayed can be selected within 
the table window.

In 3D data files, the items are markers and the subitems are the x, y, and z positions 
of those markers. For more information on the types of items and subitems found in 
data files, see “File Breakdown” on page 73.

1. Select View>View By Item in the NDI DataView main window.

The values of the subitems, for all frames, of the first item in the data file are 
displayed in the table window:

Figure 2-28:  3D data viewed by item
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2. In the Marker box of the table window, enter the item number that the table 
should display values for:

Figure 2-29:  The item selected for the table view

The table updates to display values for the new item number as it is entered:

Figure 2-30:  A table view of 3D data for item 25

The name of the box used to select the displayed item corresponds to the type of 
items in the data file. The box is alternately named Marker, Data, Voltage, or 
Item, corresponding to 3D and raw data files, ODAU raw data files, ODAU 
voltage data files, and transformation data files, respectively.

Note You can switch directly from a table sorted by frame to a specific item in a table sorted by 
item. In the table sorted by frame, select the line containing values for the item you want to 
switch to, right click, and select View <Item> n (where <Item> is the item name and n is the 
number of the selected item).
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3. Select Edit>Go To in the NDI DataView main window.

The Go To window opens:

Figure 2-31:  The Go To window for data viewed by item

4. Enter the number of the frame you want to view in the Choose Frame box:

Figure 2-32:  A selected frame in the Go To window

5. Click OK.

The table window highlights the specified frame and displays the time at which it 
was collected in milliseconds (offset from the start of the data collection) in the 
lower right corner:

Figure 2-33:  Frame 700 selected in a table view
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Displaying Frame Time

When displaying data by item, the table view can display both the frame number and 
frame time corresponding to each subitem.

6. Click the Frame Time icon  on the NDI DataView toolbar.

The table displays the Time [ms] column:

Figure 2-34:  A table view of 3D data including frame time

The Time [ms] column displays the time, in milliseconds from the beginning of 
the data collection, at which each row of data values was collected. Use the Frame 
Time icon  on the NDI DataView toolbar to toggle the inclusion of this 
column in the table.

Use the Frame Number icon  on the NDI DataView toolbar to similarly 
toggle the inclusion of the Frame column.
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2.2.2 Viewing Data by Frame

When viewing data by frame a table view displays the values of all items and 
subitems for one frame at a time. The frame for which values are displayed can be 
selected within the table window.

In 3D data files, the items are markers and the subitems are the x, y, and z positions 
of those markers. For more information on the types of items and subitems found in 
data files, see “File Breakdown” on page 73.

1. Select View>View By Frame in the NDI DataView main window.

The values of all items and subitems in the first frame of the data file are 
displayed in the table window:

Figure 2-35:  3D data viewed by frame
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2. Enter the number of the frame the table should display values for in the Frame 
box of the table window:

Figure 2-36:  The frame selected for the table view

The table updates to display values for the new frame number as it is entered:

Figure 2-37:  A table view of 3D data for frame 500

The table windows display the time at which the specified frame was collected 
(offset from the start of the data collection) in the lower right corner.

Note You can switch directly from a table sorted by item to a specific frame in a table sorted by 
frame. In the table sorted by item, select the line containing values for the frame you want 
to switch to, right click, and select View Frame n (where n is the number of the selected 
frame).
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3. Select Edit>Go To in the NDI DataView main window.

The Go To window opens:

Figure 2-38:  The Go To window for data viewed by frame

4. Enter the number of the item you want to view in the Choose Item box:

Figure 2-39:  A selected item in the Go To window

5. Click OK.

The table window highlights the specified item:

Figure 2-40:  Item 40 selected in a table view
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2.2.3 Changing Precision

The table view can display data values rounded to as few as zero or as many as fifteen 
decimal places.

Note Changing precision in a table view only affects the precision with which data values are 
displayed. It does not affect the precision of the data stored in the file.

1. Enter the number of decimal places to which values should be rounded in the 
Precision box of the table window:

Figure 2-41:  The table view Precision box

The table displays all values to the specified number of decimal places:

Figure 2-42:  3D data displayed to six decimal places

The only valid values for precision are integer values between zero and fifteen, 
inclusive. If an invalid value is entered, an error message will appear and the 
precision will not be changed.
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2.2.4 Editing Data

Data values can be edited one at a time using the table view.

A data file must be saved after changes are made to it or those changes will be lost 
when the file is closed. If you close a data file that has not been saved since it was last 
edited, NDI DataView will prompt you to save the file before it is closed.

1. Select the row of the table containing the cell you want to edit:

Figure 2-43:  Item 34 selected in a table view

2. Double click the cell you want to edit.

The cell becomes editable:

Figure 2-44:  An editable cell

3. Type the new data value in the cell:

Figure 2-45:  A new cell value being entered
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To change the value of a cell to MISSING, enter the text “missing”. This text is 
not case sensitive. You can enter the beginning of “missing” instead of the full 
text.

4. Press Enter to confirm the change:

Figure 2-46:  A confirmed new cell value

If an invalid value is entered, an error message will appear and the cell value will 
not be changed.
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2.2.5 Saving a Data File

Save a data file to preserve any changes made to the data or the file header.

1. Select File>Save As in the NDI DataView main window.

The Save As window opens:

Figure 2-47:  The Save As window

2. Browse to the location in which you want to save the data:

Figure 2-48:  A sample save location
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3. Enter a new name for the data file in the File name box:

Figure 2-49:  A new 3D file name

For more information on NDI data file naming conventions, see “File Naming 
Conventions” on page 76.

4. Click Save.

The Save As window closes and a new data file with the specified name is saved.
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2.3 Viewing Data in a Graph

The graph view displays the contents of a data file as a line graph. In this graph, the 
values of the items and subitems in the data file are plotted versus frame number. 
Which items and subitems appear in a graph can be selected after the graph is 
created.

After a graph has been created, subsequent graphs can be created regardless of 
whether the table window or graph window is active by selecting Graph>Display 
Graph.

To create a table view for an NDI data file, open the file. A table window for that file 
opens within the NDI DataView main window, with the data for the first item in the 
file listed by frame number:

Figure 2-50:  A table view of 3D data

In 3D data files, the items are markers and the subitems are the x, y, and z positions 
of those markers. For more information on the types of items and subitems found in 
data files, see “File Breakdown” on page 73.

For more information on opening data files, see “Opening Data Files” on page 6.
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2.3.1 Creating a Graph

Graphs are created using existing table views. A graph initially displays a dataset for 
each item that is selected in the table view when the graph is created. The datasets 
displayed in the graph can be changed after the graph is created.

For more information on working with table views, see “Viewing Data in a Table” on 
page 23.

Creating a Graph Using Data Viewed by Item

When creating a graph from a table view that is sorted by item, select the item 
initially included in the graph by changing the item displayed in the table.

1. Select View>View By Item in the NDI DataView main window.

The table view displays the values of all subitems, for all frames, of the first item 
in the data file:

Figure 2-51:  3D data viewed by item
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2. Enter the number of the item the graph should initially display values for in the 
Marker box of the table window:

Figure 2-52:  The item selected for the table view

The table updates to display values for the new item number as it is entered:

Figure 2-53:  A table view of data for the selected item

The name of the box used to select the displayed item corresponds to the type of 
items in the data file. The box is alternately named Marker, Data, Voltage, or 
Item, corresponding to 3D and raw data files, ODAU raw data files, ODAU 
voltage data files, and transformation data files, respectively.



Chapter 2

NDI DataView User Guide - Revision 2 39

3. Select Graph>Display Graph.

A graph view of the data opens in the main window:

Figure 2-54:  A graph view of data for the selected item

The graph displays datasets for all subitems of the selected item.

The graph title displays the numbers of the items included in the graph. A legend 
below the title displays the names of the datasets shown in the graph and the line 
and point styles with which they are displayed.

Graphs can be created at any time by clicking the Display Graph icon  on the 
toolbar. Use this icon to create multiple graphs and zoom in on different sections 
of the graphs at the same time. If a graph view is active in the main window 
when this icon is clicked, NDI DataView creates the new graph based on the table 
associated with the active graph view.

For more information on zooming the graph view, see “Zooming with Tabs” on 
page 68.
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Creating a Graph Using Data Viewed by Frame

When creating a graph from a table view that is sorted by frame, select items in the 
table to include in the graph.

1. Select View>View By Frame in the NDI DataView main window.

The table view displays the values of all items in the first frame of data:

Figure 2-55:  3D data viewed by frame

2. Select the item you want to appear in the graph:

Figure 2-56:  Selected items in a table view

Hold down the left or right Shift key to select a range of items.
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3. Select Graph>Display Graph.

A graph view of the data opens in the main window:

Figure 2-57:  A graph view of data for the selected items

The graph displays datasets for all the subitems of the selected items.

The graph title displays the numbers of the items included in the graph. A legend 
below the title displays the names of the datasets shown in the graph and the line 
and point styles with which they are displayed.

Graphs can be created at any time by clicking the Display Graph icon  on the 
toolbar. Use this icon to create multiple graphs and zoom in on different sections 
of the graphs at the same time. If a graph view is active in the main window 
when this icon is clicked, NDI DataView creates the new graph based on the table 
associated with the active graph view.

For more information on zooming the graph view, see “Zooming with Tabs” on 
page 68.
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2.3.2 Selecting Datasets

The Select Datasets window is used to change which items and subitems are displayed 
in a graph after that graph has been created.

4. Select Graph>Select Datasets in the NDI DataView main window.

The Select Datasets window opens:

Figure 2-58:  The Select Datasets window
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5. Select the items and subitems you want to appear in the graph in the list at the 
left of the window:

Figure 2-59:  A list of selected datasets in the Select Datasets window

Checked items in the list appear in the graph. Checking  or unchecking  an 
item name (e.g. a marker) checks or unchecks all of the subitems belonging to 
that item (e.g. the x, y, and z positions belonging to a given marker). Expand an 
item to check or uncheck the subitems belonging to it individually.

Click Select All in the Select Datasets window to check all of the items and 
subitems in the list.

Click Clear All in the Select Datasets window to uncheck all of the items and 
subitems in the list.

Note Use the Select Range section of the Select Datasets window to specify which items and 
subitems to display in the graph without having to select them in the list. For more 
information on how to use the Select Range section, see “Selecting Datasets Using the 
Select Range Section” on page 45.
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6. Click OK.

The graph view displays only those items and subitems that were checked in the 
list:

Figure 2-60:  A graph view of three datasets

The vertical scale of the graph changes to better accommodate the values now 
included in the graph.

For information on how to specify the range of the graph, see “Changing Axis 
Properties” on page 48.
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Selecting Datasets Using the Select Range Section

The Select Range section of the Select Datasets window can be used to quickly specify 
a range of data to include in a graph. Specify which items to select in the upper box 
and which subitems to select in the lower box:

Figure 2-61:  The Select Range section of the Select Datasets window

In the Select Range section, the upper box is named Marker because that is the name 
of each item in a 3D data file. When working with another NDI data file type, the 
name of this box may change to match the name of the items in that file type. For 
more information on the items found in each file type, see “File Breakdown” on 
page 73.

The lower box is always named Subitems.

1. Enter the numbers of the items you want to select in the Marker box:

Figure 2-62:  Selected items in the Select Range section

Enter item ranges by using a hyphen between two item numbers, and separate all 
items and item ranges using commas. The text above selects items 1, 3, 4, and 5.

2. Enter the numbers of the subitems you want to select in the Subitems box:

Figure 2-63:  Selected subitems in the Select Range section

Enter subitem ranges by using a hyphen between two subitem numbers, and 
separate all subitems and subitem ranges using commas. The specified subitems 
will be selected for every item specified in the Marker box. The text above selects 
subitems 2 and 3.

Note You can quickly apply your subitem selection to all items by leaving the Marker box empty.
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3. Click Apply.

The list displays the items and subitems selected:

Figure 2-64:  A new list of selected datasets in the Select Dataset window
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2.3.3 Changing Graph Settings

Options affecting the appearance of a graph can be changed using the Graph Settings 
window. Select the graph you want to change the appearance of within the NDI 
DataView main window before using the Graph Settings window.

Graph settings are stored separately from data in graph settings files. Any changes 
made to graph settings must be saved in a graph settings file or they will be lost when 
the graph window is closed. For more information on saving a graph settings file, see 
“Saving Graph Settings” on page 55.

1. Select Graph>Graph Settings in the NDI DataView main window.

The Graph Settings window opens:

Figure 2-65:  The Graph Settings window
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Changing Axis Properties

The Axis Properties section controls the names of the x and y axes of the graph, as 
well as the ranges of values they display. It contains separate sections for each axis:

Figure 2-66:  The Axis Properties section of the Graph Settings window

2. Enter a name to display on the x axis in the Label box of the X-Axis section:

Figure 2-67:  X-Axis properties of the selected graph view

3. Enter the first frame for which to display a value in the Min box.

4. Enter the last frame for which to display a value in the Max box.

5. Enter a name to display on the y axis in the Label box of the Y-Axis section:

Figure 2-68:  Y-Axis properties of the selected graph view

6. Enter the minimum value to display on the y axis in the Min box.

7. Enter the maximum value to display on the y axis in the Max box.
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Changing Line Properties

The Line Properties section controls the colours and styles of the lines and points 
used to represent each dataset. A preview window at the right side of the section 
displays how the selected dataset will look as the line properties are changed:

Figure 2-69:  The Line Properties section of the Graph Settings window

8. Select the dataset you want to change the display of in the Line box:

Figure 2-70:  A list of datasets available in the Graph Settings window

The Line Properties section displays the current settings for the dataset:

Figure 2-71:  Line properties of the selected dataset

Preview 
Window
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9. Select the style of line for the dataset from the Style box:

Figure 2-72:  The line styles available for the selected dataset

10. Enter the width of the line for the dataset in the Width box:

Figure 2-73:  The line width for the selected dataset

Note Only lines drawn using the Solid line style can have a width greater than one. NDI 
DataView automatically selects the Solid line style if a width greater than one is entered.

11. Click the Line Color box.

The Color window opens:

Figure 2-74:  The Color window
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12. Select the colour in which to display the line:

Figure 2-75:  The new line colour for the selected dataset

13. Click OK.

14. Click the Point Color box.

The Color window opens:

Figure 2-76:  The Color window



Common Procedures

52 NDI DataView User Guide - Revision 2

15. Select the colour in which to display the data points:

Figure 2-77:  The point colour for the selected dataset

16. Click OK.

17. Enter the size at which the data points should appear in the Size box:

Figure 2-78:  The point size for the selected dataset

The preview window shows how the dataset will be displayed in the graph:

Figure 2-79:  The Graph Settings window preview

Note These changes affect only the selected dataset. Change the line properties for other 
datasets as desired.
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Changing Miscellaneous Options

18. Use the Miscellaneous section of the Graph Settings window to adjust the 
following settings:

Figure 2-80:  Miscellaneous Graph Settings

• Show Grid: selects whether a grid of dashed, light grey lines appears on the 
graph.

• Show Stat Tabs: selects whether tabs, used to set the range for statistics and 
zoom, appear on the graph. For more information on using tabs, see “Using 
Tabs to Limit Statistics Ranges” on page 65 and “Zooming with Tabs” on 
page 68.

• Auto Scale: selects whether the y axis of the graph is automatically scaled to 
fit the data between the tabs whenever the tabs are moved.

• Display Legend: selects whether the legend appears above the graph. The 
legend displays the names of the subitems shown in the graph and the line 
and point styles with which they are displayed.

• Show Stats: selects whether the statistics panel appears below the graph. For 
more information on using statistics, see “Working with Graph Statistics” on 
page 59.

• Select Lines To Be Displayed: selects which datasets appear in the graph. 
Use this setting to temporarily hide particular datasets in the graph instead of 
removing them from the graph completely.
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19. Click OK.

NDI DataView applies the new settings to the graph:

Figure 2-81:  A graph view of three datasets with different graph settings

Save any changes to graph settings in a graph settings file or they will be lost 
when the graph window is closed.
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2.3.4 Saving Graph Settings

Save a graph settings file to preserve any changes made to the graph settings for 
future use. NDI DataView graph settings files have the file name extension “.dgs”.

1. Select Graph>Save Graph Settings in the NDI DataView main window.

The Save As window opens:

Figure 2-82:  The Save As window

2. Browse to the location in which you want to save the graph settings:

Figure 2-83:  A sample save location
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3. Enter a new name for the graph settings file in the File name box:

Figure 2-84:  A new graph settings file name

4. Click Save.

The Save As window closes and a new graph settings file with the specified name 
is saved.
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2.3.5 Loading Graph Settings

Load a graph settings file to apply the settings in that file to the graph window 
currently active in NDI DataView.

1. Select Graph>Load Graph Settings in the NDI DataView main window.

The Open window opens:

Figure 2-85:  The Open window

2. Browse to the location of the graph settings file you want to open:

Figure 2-86:  A sample location of graph settings files
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3. Select the graph settings file you want to open:

Figure 2-87:  A graph settings file selected in the Open window

4. Click Open.

NDI DataView applies the graph settings contained in the selected file to the 
active graph view:

Figure 2-88:  A graph view using the selected graph settings file
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2.3.6 Working with Graph Statistics

NDI DataView can display statistics about the datasets shown in a graph. These 
statistics all appear in the statistics panel at the bottom of the graph window:

Figure 2-89:  The statistics panel

The statistics panel can display the following, based on the data between the graph 
tabs:

• the maximum and minimum values of all displayed data

• the coordinates of a selected data point, with the maximum and minimum 
values of the dataset it is part of

• the range of a selected dataset, shown as an absolute value

• the coordinates of a reference point, with the coordinates of a selected data 
point relative to it

The statistics panel initially displays two numbers in the Total section:

Figure 2-90:  The Total section of the statistics panel

The High box displays the maximum value of all the data between the graph tabs, 
and the Low box displays the minimum value of all the data between the graph tabs.

For more information on how tabs are used to limit the data used for statistics in a 
graph, see “Using Tabs to Limit Statistics Ranges” on page 65.
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Displaying Statistics About a Dataset

1. Click on any data point of the dataset in the graph.

A black marker and the text “S” appears at the data point:

Figure 2-91:  A data point selected in a dataset

This marker and text indicates that the data point is selected. The legend displays 
the name of the dataset the point is part of in bold:

Figure 2-92:  The selected dataset in the graph view legend

The statistics panel displays a section called Selected Set:

Figure 2-93:  The Selected Set section of the statistics panel

The Selected Set section displays the maximum and minimum values, between 
the graph tabs, of the dataset that contains the selected point. These values 
appear in the Max Y and Min Y boxes, respectively. The absolute difference 
between these two values appears in the Y Range box.

For more information on tabs and how they affect statistics, see “Using Tabs to 
Limit Statistics Ranges” on page 65.
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2. Select other datasets by clicking on data points contained in them.

The size of the selected point marker varies with the size at which the data point 
is displayed:

Figure 2-94:  A large selected point marker

Note You can use the up and down arrow keys to switch between datasets.

3. Deselect a dataset by clicking on the graph at a location that is not occupied by a 
data point.
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Displaying Statistics About a Data Point

1. Click on the data point in the graph that you want to observe.

A black marker and the text “S” appears at the data point:

Figure 2-95:  A data point selected in a dataset

This marker and text indicates that the data point is selected. The legend displays 
the name of the dataset the point is part of in bold:

Figure 2-96:  The selected dataset in the graph view legend

The statistics panel displays a section called Selected Point:

Figure 2-97:  The Selected Point section of the statistics panel

The Selected Point section displays the number of the frame that contains the 
selected data point and the value of the point. These values appear in the Selected 
Point and x boxes, respectively.

If the graph displays many data points, it may be difficult to select exactly the 
data point that you want to observe. If this occurs, use the graph tabs to zoom in 
on the area of the graph that you want to select from. For more information on 
zooming, see “Zooming with Tabs” on page 68.

2. Select other data points by clicking on them.

Note You can use the left and right arrow keys to switch between data points in the same 
dataset.

3. Deselect a data point by clicking on the graph at a location that is not occupied 
by a data point.
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Setting Reference Points

Reference points can be used to determine the difference between the selected data 
point and another on the graph.

4. Hold down the Ctrl key and select a data point to use as a reference point.

A black marker and the text “R” appears at the data point:

Figure 2-98:  A reference point selected in a dataset

This marker and text indicates that the data point is the reference point. The 
statistics panel displays a section called Reference Point:

Figure 2-99:  The Reference Point section of the statistics panel

The Reference Point section displays the number of the frame that contains the 
reference data point and the value of the point. These values appear in the 
Reference Point and x boxes, respectively.

Note Hold down the Ctrl key to use the left and right arrow keys to switch between data points in 
the same dataset.
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5. Click on the data point in the graph that you want to compare to the reference 
point.

A black marker and the text “S” appears at the data point:

Figure 2-100:  A selected point and a reference point in a graph view

This marker and text indicates that the data point is selected. The selected point 
can be from any dataset, not just the dataset that contains the reference point.

The statistics panel displays new boxes named X Diff and Y Diff:

Figure 2-101:  The X Diff and Y Diff boxes of the statistics panel

The X Diff box displays the difference in frame number between the selected and 
reference data points. The Y Diff box displays the difference in value between the 
points.

6. Remove the reference point by holding the Ctrl key and clicking on the graph at 
a location that is not occupied by a data point.



Chapter 2

NDI DataView User Guide - Revision 2 65

Using Tabs to Limit Statistics Ranges

Tabs are small black markers that appear at the bottom of the graph. They are used to 
set limits on the range of data used for statistics, zooming, and data export.

Two tabs appear on each graph, one initially at each of the far edges:

Figure 2-102:  Default locations of tabs in a graph view

Note Tabs only appear if the option Show Stat Tabs is selected in the Graph Settings window. For 
more information on the Show Stat Tabs option, see “Changing Miscellaneous Options” on 
page 53.

Click and drag the black area of a tab to move it left or right:

Figure 2-103:  Moving a tab

Left Tab Right Tab
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A dashed black vertical line moves with each tab to show the exact position it marks 
on the graph. The left tab cannot move farther right than the right tab, and the right 
tab cannot move farther left than the left tab.

1. Select a dataset to observe:

Figure 2-104:  A selected dataset in the graph view

The statistics panel displays information about the minimum and maximum 
values of all datasets and the selected dataset:

Figure 2-105:  The statistics panel for a selected dataset

For more information about dataset statistics, see “Displaying Statistics About a 
Dataset” on page 60.
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2. Move the left and right tabs in to mark the edges of the data range upon which 
statistics should be calculated:

Figure 2-106:  Tabs define new statistics limits in the graph view

The statistics panel displays the minimum and maximum values of the data 
within the range marked by the tabs only:

Figure 2-107:  The statistics panel based on new tab positions
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Zooming with Tabs

The tabs can also be used to zoom in and out of the graph view. Zooming in can 
make it easier to see and select individual data points and to select ranges of values 
for statistics or export.

For more information on tabs, see “Using Tabs to Limit Statistics Ranges” on 
page 65.

1. Move the tabs to the edges of the range you want to zoom in on:

Figure 2-108:  Tabs define a zoom range in the graph view
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2. Select Graph>Zoom In.

The range defined by the tabs expands to fill the graph:

Figure 2-109:  A zoomed graph view

Because the tabs define the range which is zoomed into, they again appear at the 
edges of the graph. Repeat the zoom in process as many times as necessary to 
display the desired range of values in the graph.

3. Select Graph>Zoom Out.

The graph returns to its previous size.
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2.3.7 Exporting Graph Data

NDI DataView can export the data displayed in a graph as an ASCII file that can be 
used by other applications, such as Microsoft Excel. You can control what range of 
data is exported by using the tabs.

1. Move the tabs to define the range of values you want to export:

Figure 2-110:  Tabs define a range of data to export in the graph view

NDI DataView will only export values that appear between the tabs. The values of 
all datasets displayed in the graph are exported, not just those in the currently 
selected dataset.
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2. Select Graph>Export As ASCII.

The Save As window opens:

Figure 2-111:  The Save As window

3. Browse to the location to which you want to export to the data:

Figure 2-112:  A sample save location
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4. Select the type of ASCII file in which to export the data:

Figure 2-113:  A list of file types NDI DataView can export

In every type of ASCII file, each line contains the values of all subitems in a 
single frame and the corresponding frame number. In files with tab separated 
values, space separated values, and comma separated values the data values on 
each line are separated by tab, space, and comma characters, respectively.

5. Enter a name for the ASCII file in the File name box:

Figure 2-114:  A new ASCII file name

6. Click Save.

The Save As window closes and a new ASCII file with the specified name is saved.
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3 File Breakdown

NDI data files are stored in the NDI floating point file format. Each data file 
consists of a header, which describes the file, followed by the data itself. For more 
information on working with the file header, see “Editing File Header Information” 
on page 21.

The data in a file is organized into frames, with each frame describing the data at a 
particular point in time. Each frame is then divided into a number of items, with 
each item describing a component in that frame (for example, each marker in a 3D 
data file is a separate item). Finally, every item is subdivided into a number of 
subitems, with each subitem describing a component in that item (for example, the x, 
y, and z coordinates of a marker in a 3D data file are separate subitems).

For a complete description of NDI file formats, refer to the user guide that 
accompanied your system.

3.1 Data File Types

NDI DataView can open five types of NDI data files:

• 3D Data Files: 3D data files contain the x, y, and z positions of markers as 
measured over a period of time. Each item in a 3D data file represents a 
marker and has three subitems: X, Y, and Z, each representing the position of 
the marker on the corresponding axis.

• Raw Data Files: raw data files contain the centroids of markers as measured 
over a period of time. Each item in a raw data file represents a marker and 
has multiple subitems named Centroid_nn corresponding to the marker’s 
centroid over the different sensors, where nn is a two digit number 
representing the sensor number starting at 01.

Raw data files may also include information about the quality of each 
centroid measured: signal strength, amplification, and error code. These 
quantities appear in the separate subitems Peak_nn, Amplification_nn, and 
Code_nn corresponding to a particular centroid, respectively, where nn is a 
two digit number identifying the sensor on which the centroid was measured,  
starting at 01. Raw data files that contain this extra information are called 
full raw data files.
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• ODAU Raw Data Files: Optotrak Data Acquisition Unit (ODAU) raw data 
files contain the raw readings of the input channels of a single ODAU unit 
over a period of time. ODAU raw data files contain only one item, named 
Data. This item has multiple subitems named Channel_nn, where nn is a two 
digit number, which correspond to the multiple analog channels of the 
ODAU.

If the data file also contains ODAU digital input, each bit of the digital input 
appears in a separate subitem named DigitalCh_nn. The least significant bit 
appears in DigitalCh_01.

• ODAU Voltage Data Files: ODAU voltage data files contain the readings of 
the input channels of a single ODAU unit over a period of time, converted 
into voltages. ODAU voltage data files contain only one item, named Voltage. 
This item has multiple subitems named Channel_nn, where nn is a two digit 
number, which correspond to the multiple analog channels of the ODAU.

If the data file also contains ODAU digital input, each bit of the digital input 
appears in a separate subitem named DigitalCh_nn. The least significant bit 
appears in DigitalCh_01.

• Transformation Data Files: transformation data files contain the x, y, and z 
positions and the orientations of rigid bodies as measured over a period of 
time. The orientation can be stored in any one of four formats: Euler angle 
rotation format (with angles stored in degrees or radians), quaternion 
rotation format, or rotation matrix format. Transformation data files also 
contain the root-mean-square error of the rigid body fit.

Items in transformation data files, corresponding to rigid bodies, have the 
generic name Item. Subitems named Tx, Ty, and Tz represent the translation 

elements of the origin of the rigid body in millimetres. Different subitems 
represent the orientation, depending on the format in which the orientation 
is stored: subitems named Rx, Ry, and Rz represent rotation elements in Euler 

format (in degrees or radians), subitems named Q0, Qx, Qy, and Qz represent 

rotation elements in quaternion format, and subitems named Rij, where 

0<=i<=2 and 0<=j<=2, represent rotation elements in 3x3 rotation matrix 
format (in which “i” is row number, “j” is column number, and data is stored 
by rows).

The subitem Error represents the root-mean-square error of the rigid body fit.
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3.2 Items and Subitems

Each type of data file contains different items and subitems:

Table 3-1:  Items and subitems in NDI data files

The suffix nn denotes a two digit number used to distinguish between multiple 
subitems of the same name.

Data File Type Item Subitems

3D Data Marker x, y, z

Raw Data Marker Centroid_nn, 
Peak_nn (Full Raw Data), 
Amplification_nn (Full Raw Data), 
Code_nn (Full Raw Data)

ODAU Raw Data Data Channel_nn, 
DigitalCh_nn (optional)

ODAU Voltage Data Voltage Channel_nn, 
DigitalCh_nn (optional)

Transformation Data Item Tx, Ty, Tz (translation elements),
Rx, Ry, Rz (Euler rotation),
Q0, Qx, Qy, Qz (quaternion rota-
tion),
Rij where 0<=i,j<=2 (rotation matrix),
Error
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3.3 File Naming Conventions

The naming convention for NDI floating point data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. The naming convention for NDI 
floating point data files is unusual in that you can use any extension that is 
appropriate. The trial number and the extension are each typically three characters 
long.

The naming convention in NDI First Principles is:

<session name>_<date>_<time>_<collection number>.<extension>

Standard file names for the data file types that NDI DataView can open are as 
follows:

Table 3-2:  File naming conventions for NDI data files

The wildcards “*” and “?” refer to any number of any characters and any single 
character, respectively.

In the case of ODAU raw data and ODAU voltage data files, the first “?” wildcard 
denotes a single digit number used to distinguish between multiple ODAUs in a 
chain. When multiple ODAUs are chained together, separate data files are collected 
for each ODAU.

Note If NDI DataView opens a file and successfully recognizes data in the file, but the name of 
the file does not conform to these conventions, it will display the data in a generic format. 
In this generic format, items are named Item_nn and subitems are named Subitem_nn, 
where nn is a two digit number that distinguishes between multiple subitems.

Data File Type File Name (Previ-
ous Software) NDI First Principles

3D Data c#???.* .n3d

Raw Data r#???.* .nrw

ODAU Raw Data o?#???.* .nor

ODAU Voltage Data v?#???.* .nov

Transformation Data rig#???.* .n6d
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4 Glossary

3D Data

3D data refers to the x, y, and z positions of markers. If the position of a marker 
cannot be determined, that marker will be considered missing. The x, y, and z 
coordinate values for a missing marker are each set to the numeric constant 
BAD_FLOAT (-3.697314E28).

See also: 3D Data File, Missing Data.

3D Data File

A 3D data file is an NDI floating point data file containing the x, y, and z 
coordinates of markers as measured over a period of time. The naming convention 
for 3D data files is c#xxx.yyy, where “c” identifies the file as a 3D data file, “xxx” 
represents the trial number, and “yyy” represents the trial extension. The general 
naming convention for NDI floating point data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. You can use any extension that is 
appropriate for your experiment. Both the extension and the trial number can be 
changed.

For more information on the contents and organization of 3D data files, refer to 
“Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: 3D Data, NDI Floating Point File Format.

6D Data

See: Transformation.

See also: Transformation Data File.

6D Data File

See: Transformation Data File.

See also: Transformation.
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Active Marker

An active marker is an InfraRed light Emitting Diode (IRED) attached to a metallic 
base that can be tracked by the Optotrak System, either individually or as part of a 
group of markers comprising a rigid body. The Optotrak controls the activation 
sequence of markers through the System Control Unit.

Active markers are used to define the positions of objects to be measured by the 
Optotrak System.

See also: InfraRed light Emitting Diode (IRED).

Amplification

Amplification refers to a level of amplification applied to a marker signal in order to 
detect it. In NDI DataView, amplification is represented by a value between 0% and 
100%. A value of 0% indicates that a minimum amount of amplification was 
required to detect the marker in question, while a value of 100% means that a 
maximum amount of amplification was required to detect that marker.

If markers have amplification levels close to 100%, these markers may be too dim for 
the Position Sensors to determine their positions.

If markers have amplification levels close to 0%, these markers may be too bright for 
the Position Sensors to determine their positions.

See also: Active Marker, Full Raw Data.

ASCII File Format

In files of the ASCII file format, data values are stored using the ASCII character set. 
This allows the data within an ASCII file to be viewed using a text editor. The ASCII 
file format is machine independent, so it allows data to be transferred easily to other 
computer platforms for processing. ASCII files can be imported into spreadsheet 
programs such as Microsoft Excel.

ASCII format data files can be generated from NDI floating point format data files 
using an NDI DataView graph view: use the tabs to select a range of data, and then 
select Graph>Export As ASCII. Data can be written to ASCII files in comma 
separated values format (with the .csv file name extension), space separated values 
format (with the .ssv file name extension), or tab separated values format (with the 
.tsv file name extension).

For more information on the contents and organization of ASCII data files, refer to 
“Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: Comma Separated Values, File Types, Space Separated Values, Tab Separated 
Values.
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ASCII File Header

ASCII file headers are sections of text that precede the data within an ASCII file. To 
determine whether an ASCII file contains a header, open the file using a text editor.

ASCII data files created by converting NDI floating point data files can contain 
headers with trial information. Trial information identifies the trial the data was 
recorded for and the options it was recorded with.

For more information on the contents and organization of ASCII data files, refer to 
“Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: ASCII File Format.

ASCII File Separator

Separators mark the boundaries between groups of data within an ASCII file. Some 
common separators are commas, spaces, and tabs. To determine whether an ASCII 
file contains a header, and if so what type of separator is used in the file, open the 
file using a text editor.

When importing an ASCII file into another program, you may need to know the 
type of separator used in the file. To determine the type of separator, examine the file 
name extension or, if it is present, examine the ASCII file header.

See also: ASCII File Format, ASCII File Header, Comma Separated Values, File Types, 
Space Separated Values, Tab Separated Values.

Browse Bar

The Browse Bar is a specialized window used to browse for NDI data files. It is part 
of the Explorer Bar in the NDI DataView main window.

See also: Explorer Bar.

Centroid

A centroid is the mean position of a marker’s infrared emission over a sensor.

See also: Full Raw Data, Raw Data.
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Comma Separated Values

Comma separated values are data values in an ASCII file separated by the ASCII 
character “,“. An ASCII data file with comma separated values is generally used as an 
intermediary transfer format for programs that store data in different formats.

For example, Microsoft Excel cannot open files in the NDI floating point file 
format. To open an NDI floating point data file in Microsoft Excel, convert the file 
into a comma separated values ASCII file that Excel can then load.

See also: ASCII File Format, ASCII File Separator, File Types, NDI Floating Point File 
Format, Space Separated Values, Tab Separated Values.

Docking Bar

A docking bar  can be used to move a section of a window. By clicking 
and dragging the docking bar attached to a section of a window, that section can be 
floated or fixed to any one of the four borders of the window.

In NDI DataView, a docking bar can be used to adjust the position of the Explorer 
Bar.

See also: Explorer Bar.

Error Code

An error code indicates the status of the signal being received from a marker. If a 
marker is missing, the error code for that marker will indicate the reason that the 
Optotrak Position Sensors cannot determine the position of the marker.

Here is a list of possible error codes:

Table 4-1:  List of error codes.

Error Error 
Code Explanation

Centroid acceptable 0 The sensor succesfully calculated the marker centroid.

Waveform too wide 1 The amount of light visible is above the noise threshold 
for the system to determine the marker centroid. The 
marker is too close to the Position Sensor. Move the 
marker farther away from the Position Sensor to correct 
this problem.

Peak too small 2 The marker signal is too weak. This may be due to the 
marker being obscured or the marker having 
insufficient power. Increase the strober voltage and/or 
duty cycle to strengthen the marker signal.
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See also: Full Raw Data, Missing Data.

Euler Rotation

An Euler rotation is a mathematical method of describing rotations in three 
dimensions. The rotations around each of the axes are described as Rx, Ry and Rz. 
Euler rotations can be expressed in both degrees and radians.

See also: Quaternion Rotation, Transformation.

Peak too large 3 The marker signal is too strong. Decrease the strober 
voltage and/or duty cycle to weaken the marker signal.

Waveform out of 
volume

4 The marker waveform is partially out of the field of 
view of the sensor.  Check the measurement volume of 
the Position Sensor on the name plate located at the 
back. (See the Optotrak Certus User Guide for details.) 
Relocate the marker so that the marker waveform is 
within the measurement volume.

Fell behind 5 The sensor fails to process the current marker's signal 
before required to process the next marker's signals.  
Lower the marker frequency to correct this problem.

Bad last centroid 6 Interpolation cannot be carried out because a marker 
was not visible in the previous frame.  This would only 
occur if the collection was configured to perform 
interpolation on the raw sensor values.

Buffer full 7 The internal centroid data buffer on the sensor is full 
and the sensor fails to store the current marker data.  
Lower the frame rate to correct this condition.  

Missed sensor 8 The sensor has determined that it has missed a time 
control signal from the Optotrak System Control Unit, 
probably because of a communication error.

Corrupted data 9 The sensor failed to process the marker data due to an 
internal communication error.

Table 4-1:  List of error codes.

Error Error 
Code Explanation
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Explorer Bar

The Explorer Bar is a window used to browse and search for NDI data files. By 
default, it appears at the left side of the NDI DataView main window.

See also: Browse Bar, Search Bar.

File Header

The first 256 bytes of the NDI floating point file format is known as the file header. 
The file header describes the organization of the data within each NDI floating 
point file. For a complete description of file headers, refer to “Appendix B: File 
Formats” in the “Optotrak Certus User Guide”.

Files in the NDI floating point file format are not the same as those in the ASCII 
file format. NDI floating point files cannot be viewed with a text editor.

See also: ASCII File Format, NDI Floating Point File Format.

File Types

Floating Point File Format

See: NDI Floating Point File Format.

Full Raw Data

Full raw data refers to the centroid, amplification, error code, and signal strength of 
a marker. Full raw data includes the same centroid information for each marker as 
raw data, as well as information about the quality of the signal measured for each 
marker by each Optotrak Position Sensor.

Full raw data is typically used for troubleshooting purposes.

See also: Amplification, Error Code, Raw Data, Signal Strength.

File Name Extension File Type

.csv Comma Separated Values File

.dgs NDI DataView Graph Settings File

.ssv Space Separated Values File

.tsv Tab Separated Values File
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Full Raw Data File

A full raw data file is an NDI floating point data file containing the centroid, 
amplification, error code, and signal strength values of markers as measured over 
time. The naming convention for full raw data files is r#xxx.yyy, where “r” identifies 
the file as a raw or full raw data file, “xxx” represents the trial number, and “yyy” 
represents the trial extension.

Full raw data files are typically recorded to determine why certain markers cannot be 
detected by an Optotrak Position Sensor. Because full raw data files are much larger 
than raw data files, they should only be used when you suspect there is a problem 
with either the marker signals or a Position Sensor.

The general naming convention for NDI floating point data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. You can use any extension that is 
appropriate for your experiment. Both the extension and the trial number can be 
changed.

For more information on the contents and organization of 3D data files, refer to 
“Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: Full Raw Data, NDI Floating Point File Format, Raw Data File.

Graph View

A graph view is a window that displays the contents of a data file as a line graph. The 
values of the items and subitems selected to appear in the graph are plotted versus 
frame number.

Graph windows appear separately within the NDI DataView main window.

See also: Table View.

InfraRed light Emitting Diode (IRED)

An InfraRed light Emitting Diode (IRED) is an electronic device that emits infrared 
light when a voltage is applied to it. When attached to a cable and a connector, 
IREDs are called markers. Markers are used to define the points measured by the 
Optotrak System.

See also: Active Marker.
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Item

An item is a division of data in an NDI floating point data file. Each frame of data 
is divided into a number of items, each of which describes a component in that 
frame (such as the 3D position of one marker). Every item is subdivided into a 
number of subitems, each of which describes a component in that item (such as the 
x value in a 3D position).

See also: NDI Floating Point File Format, Subitem.

Link

A link is a hyperlink used to navigate within the NDI DataView online help system. 
Links appear on each page of online help.

Links within each page direct you to related and/or supplemental information for 
particular topics and terms. These links are not organized sequentially. After 
following these links, use the Back button of your browser to return to previous 
pages.

Links at the bottoms of pages direct you through specific topics and procedures. 
Follow these links to find information on complete topics and how to perform 
particular steps of procedures.

Marker

See: Active Marker.

Missing Data

If the Optotrak System cannot determine the 3D position of a marker or a rigid 
body, that marker or rigid body is considered missing. A marker might be missing if 
it is not in the measurement volume of the Optotrak Position Sensors, or if it is 
obscured by being covered or rotated out of view. A rigid body might be missing if 
the maximum error settings are exceeded when calculating its position. The x, y, and 
z coordinate values for missing markers are each set to the numeric constant 
BAD_FLOAT (-3.697314E28).

NDI DataView reports missing data by using the text “MISSING” in place of the 
missing values.

See also: 3D Data, Active Marker, Rigid Body, Transformation Data File.
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NDI Floating Point File Format

The NDI floating point file format is the file format used by NDI to store data. 
Each floating point data file consists of a header, which describes the file, followed 
by the data, which is organized into frames. The naming convention for floating 
point data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. You can use any extension that is 
appropriate for your experiment. Both the extension and the trial number can be 
changed.

For more information on the contents and organization of 3D data files, refer to 
“Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: 3D Data File, Full Raw Data File, ODAU Raw Data File, ODAU Voltage 
Data File, Raw Data File, Transformation Data File.

ODAU Raw Data

ODAU raw data refers to unconverted analog and digital input values measured using 
an ODAU II.

See also: ODAU Raw Data File, Optotrak Data Acquisition Unit (ODAU II).

ODAU Raw Data File

An ODAU raw data file is an NDI floating point data file containing the 
unconverted analog and digital input values of an ODAU II, as measured over a 
period of time. The naming convention for ODAU raw data files is o?#xxx.yyy, 
where “o” identifies the file as an ODAU raw data file and “?” is a number 
corresponding to the position of the ODAU II unit in the system setup (multiple 
ODAUs can be chained together). The “xxx” represents the trial number, and “yyy” 
represents the trial extension. The general naming convention for NDI floating point 
data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. You can use any extension that is 
appropriate for your experiment. Both the extension and the trial number can be 
changed.

For more information on the contents and organization of ODAU raw data files, 
refer to “Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: NDI Floating Point File Format, ODAU Raw Data.
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ODAU Voltage Data

ODAU voltage data refers to analog and digital input values that have been measured 
and converted into voltage values by an ODAU II.

See also: ODAU Voltage Data File, Optotrak Data Acquisition Unit (ODAU II).

ODAU Voltage Data File

An ODAU voltage data file is an NDI floating point data file containing the analog 
and digital input values, converted into voltages, of an ODAU II as measured over a 
period of time. The naming convention for ODAU voltage data files is v?#xxx.yyy, 
where “v” identifies the file as an ODAU voltage data file and “?” is a number 
corresponding to the position of the ODAU II unit in the system setup (multiple 
ODAUs can be chained together). The “xxx” represents the trial number, and “yyy” 
represents the trial extension. The general naming convention for NDI floating point 
data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. You can use any extension that is 
appropriate for your experiment. Both the extension and the trial number can be 
changed.

For more information on the contents and organization of ODAU voltage data files, 
refer to “Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: NDI Floating Point File Format, ODAU Voltage Data.

Optotrak Data Acquisition Unit (ODAU II)

The ODAU II is an optional hardware component that provides analog signal 
acquisition and digital input/output capability in synchronization with Optotrak 
data (3D or raw).

See also: ODAU Raw Data, ODAU Voltage Data.

Peak

See: Signal Strength.
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Quaternion Rotation

Quaternion rotation is a mathematical method of describing rotations in three-
dimensional space in terms of four-dimensional objects that are represented as 
ordered quadruples [q0, qx, qy, qz]. The components represent a rotation about an 
axis (related to the vector [qx, qy, qz]) by an angle (determined by the scalar q0). For 
normalized (or unit) quaternions, the rotation of a vector v by the quaternion q is 
given by v’ = qvq-1.

Quaternion rotation has several advantages over other representations such as Euler 
angles, including robustness, faster computation, and greater numerical stability.

See also: Euler Rotation, Transformation.

Raw Data

Raw data refers to the centroid of a marker (the mean position of the infrared light 
emitted by a marker across an Optotrak sensor).

See also: Centroid, Raw Data File.

Raw Data File

A raw data file is an NDI floating point data file containing the numeric values of 
the centroids of markers as measured over a period of time. The naming convention 
for raw data files is r#xxx.yyy, where “r” identifies the file as a raw or full raw data 
file, “xxx” represents the trial number, and “yyy” represents the trial extension. The 
general naming convention for NDI floating point data files is:

<prefix>#<trial number>.<extension>

The “#” sign must be included in the file name. You can use any extension that is 
appropriate for your experiment. Both the extension and the trial number can be 
changed.

For more information on the contents and organization of raw data files, refer to 
“Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: Full Raw Data File, NDI Floating Point File Format, Raw Data.

Rigid Body

A rigid body is an object on which three or more markers are fixed so that no 
relative movement between the markers is possible. The Optotrak System can track 
the 3D position and orientation of rigid bodies.

See also: Active Marker, Transformation.
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Root-Mean-Square (RMS) Error

RMS error is calculated as the square root of the mean of the squares of the 
individual distance errors along the x, y, and z axes. The RMS error for n measured 
3D positions, with distance errors of xe, ye, and ze along each of the x, y, and z axes, 
respectively, is:

See also: Full Raw Data.

Rotation Matrix

The rotation matrix can be expressed as:

RRPY(f,q,y)=Rz(f)*Ry(q)*Rx(y).

The order in which the rotations are applied is: (1) x, (2) y, (3) z.

The single axis rotations are as follows:

Figure 4-1:  Rotation Matrices

With this form of Euler angles, care must be taken to avoid y angles of 90 degrees 
and -90 degrees because the rotation matrix, RRPY(f,q,y), will become unstable.

See also: Transformation, Quaternion Rotation.
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Search Bar

The Search Bar is a specialized window used to search for NDI data files. It is part of 
the Explorer Bar in the NDI DataView main window.

See also: Explorer Bar.

Signal Strength

Signal strength refers to the strength of a signal received from a marker. It is 
represented by a value between 0% and 100%.

If markers have signal strengths close to 0%, these markers may be too dim for the 
Position Sensors to determine their positions.

Similarly, if markers have signal strengths close to 100%, these markers may be too 
bright for the Position Sensors to determine their positions.

In a full raw data file, signal strength is split between two fields: signal strength high 
and signal strength low.  The signal strength is derived from the combination of the 
two fields.

See also: Full Raw Data.

Space Separated Values

Space separated values are data values in an ASCII file separated by the ASCII 
character “ “. An ASCII data file with space separated values is generally used as an 
intermediary transfer format for programs that store data in different formats.

For example, Microsoft Excel cannot open files in the NDI floating point file 
format. To open an NDI floating point data file in Microsoft Excel, convert the file 
into a space separated values ASCII file that Excel can then load.

See also: ASCII File Format, ASCII File Separator, Comma Separated Values, File 
Types, NDI Floating Point File Format, Tab Separated Values.

Status Bar

A status bar is a grey area at the bottom of a window that displays information about 
the selections and tasks being performed within that window.

The NDI DataView main window status bar displays the meanings of menu items 
and toolbar icons as they are selected.

See also: Toolbar.
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Status Code

See: Error Code.

Subitem

A subitem is a division of data in an NDI floating point data file. Every item in a 
data file is subdivided into a number of subitems, each of which describes a 
component in that item. For example, the 3D position of one marker (which is itself 
a single item) is divided into three subitems: one for each of the x, y, and z values in 
the 3D position.

See also: Item, NDI Floating Point File Format.

Tab Separated Values

Tab separated values are data values in an ASCII file separated by the ASCII character 
for Tab. An ASCII data file with tab separated values is generally used as an 
intermediary transfer format for programs that store data in different formats.

For example, Microsoft Excel cannot open files in the NDI floating point file 
format. To open an NDI floating point data file in Microsoft Excel, convert the file 
into a tab separated values ASCII file that Excel can then load.

See also: ASCII File Format, ASCII File Separator, Comma Separated Values, File 
Types, NDI Floating Point File Format, Space Separated Values.

Table View

A table view is a window that displays the contents of a data file in a table. The data 
is either viewed by item, in which case the table displays the values of a particular 
item for all frames in the data file, or viewed by frame, in which case the table 
displays the values of all items and subitems for a particular frame.

Table windows appear separately within the NDI DataView main window.

See also: Graph View.

Toolbar

A toolbar is a group of icons displayed in a window, typically in a row below the 
menu bar. Generally, each icon in a toolbar provides access to a commonly used 
function.

NDI DataView provides a single toolbar in the main window.

See also: Status Bar.
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Transformation

A transformation refers to a combination of a translation and a rotation that 
describes a position and orientation in space. In NDI DataView the translation data 
is stored as Tx, Ty, and Tz positions, measured in millimetres, and the rotation data 
can be stored in any one of four formats: Euler rotation format (with angles stored in 
degrees or in radians), quaternion rotation format, or rotation matrix format.

See also: Euler Rotation, Quaternion Rotation, Transformation Data File.

Transformation Data File

A transformation data file is an NDI floating point data file containing translations 
and rotations that describe the positions and orientations of rigid bodies as 
measured over a period of time. The translation data is stored as Tx, Ty, and Tz 
positions, measured in millimetres, and the rotation data can be stored in any one of 
four formats: Euler rotation format (with angles stored in degrees or in radians), 
quaternion rotation format, or rotation matrix format. A transformation data file 
also includes the rigid body error, which is a 3D root-mean-square error value in 
millimeters between the 3D measured position and the 3D calculated positions based 
on the rigid bodies movement.

For more information on the contents and organization of transformation data files, 
refer to “Appendix B: File Formats” in the “Optotrak Certus User Guide”.

See also: NDI Floating Point File Format, Transformation.
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5 Appendix A: Menu Guide

This section lists the menu commands available in NDI DataView, as well as their 
hotkeys and their icons. Certain menu commands are available only when working 
with a table or a graph view.

File Menu

Menu Command Hotkey Icon

Open Ctrl + O

Close - -

Save Ctrl + S -

Save As - -

Print Ctrl + P

Print Preview - -

Print Setup - -

Exit - -
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Edit Menu

When working with a table view:

When working with a graph view:

Menu Command Hotkey Icon

Undo Ctrl + Z -

Redo Ctrl + Y -

Copy Ctrl + C -

Select All Ctrl + A -

Go To Ctrl + G

File Header Ctrl + H -

Menu Command Hotkey Icon

Undo Ctrl + Z -

Redo Ctrl + Y -

File Header Ctrl + H -
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View Menu

When working with a table view:

When working with a graph view:

Menu Command Hotkey Icon

Toolbar - -

Status Bar - -

Explorer Bar - -

View By Frame Ctrl + F -

View By Item Ctrl + I -

Menu Command Hotkey Icon

Toolbar - -

Status Bar - -

Explorer Bar - -
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Graph Menu

When working with a table view:

When working with a graph view:

Window Menu

Help Menu

Menu Command Hotkey Icon

Display Graph -

Menu Command Hotkey Icon

Display Graph -

Graph Settings F9 -

Select Datasets - -

Save Graph Settings - -

Load Graph Settings F8 -

Zoom In Ctrl + ‘+’

Zoom Out Ctrl + ‘-’

Export As ASCII - -

Menu Command Hotkey Icon

New Window - -

Cascade - -

Tile - -

Menu Command Hotkey Icon

NDI DataView Help F1 -

About NDI DataView - -
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6 Appendix B: Icon Guide

6.1 Main Window Toolbar Icons

These icons appear on the toolbar of the NDI DataView main window:

Open Opens a data file.

Print Prints a data file.

Go To Line Jumps to a specific line in a table view.

Frame Number Toggles display of the frame number in a table 
view.

Frame Time Toggles display of the frame time in a table view 
sorted by item.

Display Graph Creates a graph from an existing table.

Vertical Auto Range Automatically sets the vertical range of a graph 
based on the data between the tabs.

Show/Hide Lines Selects the datasets to be displayed in a graph.

Line Properties Changes the appearance of datasets in a graph.

Statistics Panel Toggles display of the statistics panel in a graph.

Graph Grid Toggles display of the grid in a graph.

Zoom In Zooms display of a graph in to the range defined 
by the tabs.

Zoom Out Zooms display of a graph out to its previous size.
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6.2 File Type Icons

These icons appear in the title bars of table and graph windows:

3D Data Identifies a 3D data file.

Generic Data Identifies a generic floating point data file.

Raw Data Identifies a raw or full raw data file.

ODAU Raw Data Identifies an ODAU raw data file.

ODAU Voltage Data Identifies an ODAU voltage data file.

Transformation Data Identifies a transformation data file.
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Index

Index

Numerics

3D Data, 77
3D Data File, 73, 77
6D Data, 77
6D Data File, 77

A

Active Marker, 78
Amplification, 73, 78
Appearance

Changing Axis, 48
Changing Graph, 47
Changing Line, 49
Changing Point, 49

ASCII File Format, 78
ASCII File Header, 79
ASCII File Separator, 79
Auto Scale, 53
Axis Properties, 48

B

Browse Bar, 79
Browsing

for a Data File, 6
for a Search Location, 19

C

Centroid, 73, 79
Changing

Axis Names, 48
Axis Ranges, 48
Data Values, 32
File Header, 21
Graph Settings, 47
Line Properties, 49
Miscellaneous Graph Options, 53
Precision, 31

Channel, 74
Character Subitems, 22
Code

Error, 73, 80

Status, 90
Collection

Date, 21
Time, 21

Comma Separated Values, 80
Comments

System, 22
User, 22

Common Procedures, 6
Conventions, File Naming, 76, 82
Creating

Graphs, 37
Tables, 23

Creating a Graph
with Data Viewed by Frame, 40
with Data Viewed by Item, 37

Creating a Table, 23
Custom File Type, 13, 16
Cutoff Frequency, 22

D

Data
3D, 77
6D, 77
Browsing for a File, 6
Changing Precision of, 31
Editing, 32
Full Raw, 82
Missing, 84
ODAU Raw, 85
ODAU Voltage, 86
Opening Files, 6
Raw, 87
Searching for a File, 15
Transformation, 91
Viewing by Frame, 28
Viewing by Item, 24
Viewing in a Graph, 36
Viewing in a Table, 23

Data File Types
3D, 73, 77
6D, 77
Full Raw, 83
ODAU Raw, 74, 85
ODAU Voltage, 74, 86
Raw, 73, 87
Saving, 34
Transformation, 74, 91



NDI DataView User Guide - Revision 2 99

Index

Data Files
Browsing for, 6
Opening, 6
Saving, 34
Searching for, 15

Data Point
Displaying Statistics for, 62
Selecting, 59

Dataset
Displaying Statistics for, 60

Datasets
Selecting, 42, 45
Showing or Hiding, 53

DataView
Installing, 1
Main Window, 2
Starting, 7

Date, Collection, 21
Default

Install Location, 1
Delimeter, 79
Displaying

Frame Time, 27
Statistics About a Data Point, 62
Statistics About a Dataset, 60

Docking Bar, 80
Double Subitems, 22

E

Edit Menu, 93
Editing

Data, 32
File Header, 21

Error
Code, 73, 80
Root-Mean-Square (RMS), 74, 88

Euler Rotation, 81
Explorer Bar, 2, 82
Exporting Data, 70

F

File Breakdown, 73
File Header, 21, 79, 82
File Menu, 92
File Names, 76, 82
File Naming Conventions, 76, 82
File Separator, 79
File Type Icons, 97
File Types

3D Data, 73, 77
6D Data, 77
ASCII, 78
Custom, 13, 16
Data, 73
Full Raw Data, 83
NDI Floating Point, 85
ODAU Raw Data, 74, 85
ODAU Voltage Data, 74, 86
Raw Data, 73, 87
Transformation Data, 74, 91

Floating Point File Format, 73, 82, 85
Floating Point Subitems, 21
Frame

Viewing Data by, 28
Frame Time

Showing and Hiding, 27
Frames, 21
Frequency

Cutoff, 22
Sample, 22

Full Raw Data, 82
Full Raw Data File, 83

G

Getting Started, 1
Glossary, 77
Graph

Creating, 37, 40
Viewing Data in a, 36

Graph Menu, 95
Graph Settings

Axis, 48
Changing, 47
Line and Point, 49
Miscellaneous, 53
Saving, 55

Graph Statistics
Displaying About a Data Point, 62
Displaying About a Dataset, 60
High, 59
Low, 59
Max Y, 60
Min Y, 60
Setting Range for, 65
Setting Reference Points, 63
Working with, 59
X Diff, 64
Y Diff, 64
Y Range, 60

Graph View, 4, 83



100 NDI DataView User Guide - Revision 2

Index

Graph Window, 4
Graphs

Exporting Data, 70
Graphs Settings

Loading, 57
Grid, 53
Guide

How to Use this, 1
Icon, 96
Menu, 92

H

Header, 21, 79, 82
Help Menu, 95
Hiding

Datasets, 53
Frame Time, 27
Grid, 53
Lines, 53
Statistics Panel, 53
Tabs, 53

High, 59
How to Use this Guide, 1

I

Icon Guide, 96
Icons

File Type, 97
Main Window Toolbar, 96

InfraRed light Emitting Diode (IRED), 83
Install Location, 1
Installing, 1
Integer Subitems, 22
IRED, 83
Item, 74, 76, 84

Viewing Data by, 24
Item Size, 22
Items, 21, 75

L

Legend, 53
Lines

Changing Properties, 49
Showing or Hiding, 53

Link, 84
Loading

a Data File, 8
Data Files, 6, 15
Graph Settings, 57

Low, 59

M

Main Window
Icons, 96

Main Window Sections, 2
Marker, 45, 78, 84
Marker Precision, 31
Max Y, 60
Menu Bar, 2
Menu Guide, 92
Menus

Edit, 93
File, 92
Graph, 95
Help, 95
View, 94
Window, 95

Min Y, 60
Miscellaneous Graph Options, 53
Missing Data, 84

N

Name
Changing Axis, 48

Naming Conventions, 76, 82
NDI DataView

Installing, 1
Main Window, 2
Starting, 7

NDI Floating Point File Format, 73, 85

O

ODAU, 86
ODAU Raw Data, 85
ODAU Raw Data File, 74, 85
ODAU Voltage Data, 86
ODAU Voltage Data File, 74, 86
Opening

a Data File, 8
Data Files, 6, 15
Graph Settings, 57

Options



NDI DataView User Guide - Revision 2 101

Index

Miscellaneous Graph, 53
Optotrak Data Acquisition Unit (ODAU), 86
Orientation

Euler, 81
Quaternion, 87

P

Peak, 73, 86
Point

Reference, 59
Point Properties, 49
Points

Setting Reference, 63
Precision, 31
Procedures

Opening Data Files, 6
Viewing Data in a Graph, 36
Viewing Data in a Table, 23

Properties
Changing Axis, 48
Changing Graph, 47
Changing Point, 49

Q

Q0, Qx, Qy, and Qz, 74
Quaternion Rotation, 87

R

Range
Changing Axis, 48
Limiting Statistics, 65

Raw Data, 87
Raw Data File, 73, 87
Reference Point, 59
Reference Points, Setting, 63
Rigid Body, 87
Root-Mean-Square (RMS) Error, 74, 88
Rotation

Euler, 81
Quaternion, 87

Rotation Matrix, 88
Rx, Ry, and Rz, 74

S

Sample Frequency, 22
Saving

a Data File, 34
Data in ASCII Format, 70
Graph Settings, 55

Scaling
Automatic, 53
Setting Axis, 48

Search Bar, 89
Search Location

Browsing for, 19
Searching

for a Data File, 15
Select Range Section, 45
Selecting

Data Points, 59
Datasets, 42, 45
Reference Points, 63

Separator, 79
Setting Up, 1
Settings

Miscellaneous Graph, 53
Saving Graph, 55

Showing
Datasets, 53
Frame Time, 27
Grid, 53
Legend, 53
Lines, 53
Main Window, 7
Statistics Panel, 53
Tabs, 53

Signal
Strength, 89

Size, Item, 22
Space Separated Values, 89
Starting NDI DataView, 7
Statistics

Displaying About a Data Point, 62
Displaying About a Dataset, 60
High, 59
Limiting Range with Tabs, 65
Low, 59
Max Y, 60
Min Y, 60
Setting Range for, 65
Setting Reference Points, 63
X Diff, 64
Y Diff, 64
Y Range, 60

Statistics Panel, 53



102 NDI DataView User Guide - Revision 2

Index

Status Bar, 2, 89
Status Code, 90
Strength, Signal, 89
Subitem, 76, 90
Subitems

Character, 22
Double, 22
Floating Point, 21
Integer, 22
Types, 75

System Comments, 22

T

Tab Separated Values, 90
Table

Changing Precision in, 31
Viewing Data in a, 23

Table View, 3
Table Window, 3
Tabs

Limiting Statistics Ranges with, 65
Showing or Hiding, 53
Zooming with, 68

Time, Collection, 21
Toolbar, 2, 90
Toolbar Icons, 96
Total

Frames, 21
Items, 21

Transformation Data, 91
Transformation Data File, 74, 91
Tx, Ty, and Tz, 74

U

User Comments, 22

V

Values
Comma Separated, 80

Space Separated, 89
Tab Separated, 90

View Menu, 94
Viewing, 24
Viewing Data

by Frame, 28
by Item, 24
in a Graph, 36
in a Table, 23

Views
Graph, 4
Table, 3
Working with, 5

Voltage, 74

W

Window Menu, 95
Windows

Graph, 4
Main Window, 2
Table, 3

Working with
Graph Statistics, 59
Views, 5

X

X Diff, 64
X, Y, and Z, 73

Y

Y Diff, 64
Y Range, 60

Z

Zooming, 68


	1 Getting Started
	1.1 NDI DataView
	1.2 How to Use this Guide
	1.3 Installing NDI DataView
	1.4 The NDI DataView Main Window

	2 Common Procedures
	2.1 Opening Data Files
	2.2 Viewing Data in a Table
	2.3 Viewing Data in a Graph

	3 File Breakdown
	3.1 Data File Types
	3.2 Items and Subitems
	3.3 File Naming Conventions

	4 Glossary
	5 Appendix A: Menu Guide
	6 Appendix B: Icon Guide
	6.1 Main Window Toolbar Icons
	6.2 File Type Icons


