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About this document

This user manual describes the recording software BrainVision Recorder. This document forms an
integral part of the product. Follow the instructions in this document in order to use the software cor-
rectly and as intended.

Target group of this document

This user manual is intended for users in the psychological and neurophysiological research area
as well as physicians and medical experts.

Structure of this document

This document is divided into the following chapters:

 Chapters 1 to 3: Installation procedure and a high-level overview of Recorder for beginners. 

 Chapter 4: Program modes (Administrator and Standard) and Program preferences.

 Chapter 5: General workspace settings and ways for creating a workspace.

 Chapter 6: Amplifier-specific settings in a workspace for all amplifiers.

 Chapter 7: Settings for your recording, for example Montages etc. 

 Chapter 8: Information about the impedance measurement for active and passive electrodes.

 Chapter 9: Settings when using the actiCAP ControlBox with active electrodes. 

 Chapter 10: Options when viewing the data.

 Chapter 11: Using Video Recorder.

 Chapter 12: OLE automation.

 Chapter 13: RDA settings.
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Conventions in this document

Typographical conventions

Symbols

Revision history

Page . . Status. . . . . . . .Subject

14  . . . . modified  . . . .  Application Suite is now available on USB instead of DVD, the procedure 
has been updated accordingly

79  . . . . modified  . . . .  LiveAmp 8/16/32 was previously listed as LiveAmp

80  . . . . modified  . . . .  Search for last connected LiveAmp option added

112  . . . new . . . . . . . . .  Screenshot updated to reflect changes made to Averging and Baseline Cor-

Bold indicates items on the user interface (menus, buttons, switches, connectors, 
options) and is used for emphases in the text

Italic indicates titles of dialog boxes/tabs, file locations and is used to indicate 
product names

Underscore indicates cross-references and web addresses

Monospaced indicates text or characters to be entered at the keyboard

Caution: This symbol indicates that incorrect use of the product(s) may result in a 
personal injury to the test subject, the user and/or a third-party. Failure to observe 
the information in this document constitutes incorrect use.

!
Notice: This symbol indicates that the incorrect use of the product(s) may bring 
about a risk of damage to property. Failure to observe the information in this docu-
ment constitutes incorrect use.

Note or Tip: This symbol draws your attention to important information relating to the 
current topic and to recommendations on how to use the product(s).

Cross-reference: This symbol indicates a reference to a related chapter, section or 
document.

New: This symbol indicates changes or new content at this point.
NEW
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rection

118  . . . new . . . . . . . . .  Section has been updated to reflect changes made to Averaging and Base-
line Correction

175  . . . modified  . . . .  Format of the EEG files section has been updated.

Reporting errors and support

We would ask you to report without delay any error you find in this document, any fault on the prod-
ucts or any malfunction that you observe when using this product. To do so, please contact your lo-
cal dealer, who will also assist you in general questions about the product.
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About Recorder

BrainVision Recorder is a powerful and flexible recording program. Its particular strengths lie in the
following features:

 The program is structured in such a way that it is possible to use different amplifiers.

 The number of channels is restricted only by the amplifier that is being used. In itself, the inter-
nal structure of Recorder allows you to work with an unlimited number of channels.

 The fact that OLE automation has been implemented allows you to control Recorder remotely
and monitor its internal status using other programs.

 The Remote Data Access (RDA) method allows you to acquire and record the digital signals with
their own programs while the data is being displayed. This method can be used across different
computers. Possible applications for RDA include biofeedback and signal quality analysis.

 Separate software filters that can be freely set on the level of single channels are available to
you for displaying and storing continuous, segmented and averaged data.

 You can significantly reduce the space required to store your files using segmentation based on
event markers.

 The optional video function allows you to record video data synchronously with your EEG data.

 The optional averaging function on the basis of event markers allows evoked potentials to be
displayed during recording.

 The static overlay function allows you to compare current averaged data with, for instance, a pro-
totypical curve that you have recorded previously with Recorder or calculated with Analyzer.

Recorder has an interface to the actiCAP ControlSoftware (as of version 1.2.1.0) to allow impedance
measurement of active electrodes. If you control the actiCAP ControlSoftware using Recorder, you
can automatically save the impedance values in the header file of the EEG data set, which obviates
the need to save them in a separate file.

Recorder allows you to store amplifier-specific parameters (in the Amplifier menu), general config-
uration settings (in the Configuration menu) and the parameters used for impedance measurement
in the workspace and load them automatically with the workspace.

In the same way as with Analyzer, you can select individual channels or multiple channels when
viewing data (monitoring) in Recorder and display these separately.

The virtual amplifier function allows you to create and edit workspaces for your BrainAmp amplifier
without the need to connect it to your computer.
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Product identification

Use together with other products and components

Recorder is permitted by Brain Products to be combined with the following amplifiers and software: 

Beside this general statement about permitted product combinations, the user must check, if all
stipulations of each product (for example regarding its MR compatibility) are fulfilled for the specific
combination and purpose of application (intended use and correct use).

Recorder may be used in combination with specific medical devices, , only if this combination is ap-
proved by the manufacturer of the medical device.

Product designation: BrainVision Recorder

Manufacturer: Brain Products GmbH
Zeppelinstraße 7
D-82205 Gilching (Munich)
Phone: +49 8105 73384 - 0 
Fax: +49 8105 73384 - 33
Web site: http://www.brainproducts.com
Email: techsup@brainproducts.com

Product Manufacturer

BrainAmp family 
(BrainAmp Standard, BrainAmp DC, 
BrainAmp MR, BrainAmp MR plus, Brain-
Amp ExG, BrainAmp ExG MR)

Brain Products GmbH

actiCHamp Brain Products GmbH

FirstAmp Brain Products GmbH

V-Amp Brain Products GmbH

LiveAmp Brain Products GmbH

MOVE Brain Products GmbH

actiCAP ControlSoftware Brain Products GmbH

RecView Brain Products GmbH
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Intended use

As of September 30th, 2013 and software version 1.20.0601 Recorder is not a medical device any-
more and can only be used in the context of non-medical applications in order to carry out funda-
mental or applied research on the basis of neurophysiological methodology and data.

Use of Recorder for diagnosis, therapy, monitoring of vital physiological processes (such as cardio-
vascular functions etc.) or other medical purposes is expressly forbidden.

Recorder is intended to be used for recording neuro-/electrophysiological signals (for example EEG,
EMG, ECG, EOG) and/or signals from other approved sensors. 

The user is solely liable for any risks if this software is not used in accordance with the correct use.
Brain Products provides no guarantee and accepts no liability for the results obtained with Record-
er.

Correct use

Recorder is permitted to be used by users in the psychological and neurophysiological research
area as well as physicians and medical experts.

Recorder is not permitted to be used by

 unqualified persons (for example laymen),

 persons who cannot read (due to visual impairment, for example) or understand (due to a lack
of language skills, for example) the user manual.

Recorder can be used to view and filter neuro-/electrophysiological signals from healthy and sick
adults, children and animals. 

Irrespective of any liability on our part, the specialist staff must observe the relevant national stip-
ulations for operators and other relevant national legislation. 

If you record EEG/ExG1 signals in an MR scanner, the recording computer must always be positioned
and used outside the scanner room. 

All versions of Recorder that have been released into the market as medical products do remain
medical products. Brain Products will continue to treat them as medical products until the end of
their service life (for example by performing post market surveillance).

The user should  be aware that if a former Recorder version that was a medical product is replaced
by a newer version that is not a medical product anymore, the terms and conditions of the new Re-
corder version are effective only from then on.

1. EEG, EOG, ECG, EMG, EDA, etc.
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1 Installing Recorder

Under normal conditions, Recorder does not cause any conflicts with other programs that are al-
ready installed. Brain Products, only guarantees that programs will interact without problems if the
programs concerned have been tested for compatibility. This applies to BrainVision Analyzer, Bra-
inVision RecView and actiCAP ControlSoftware and to the Microsoft operating systems  provided
that no modifications to the configuration of the operating system as delivered have been undertak-
en (including official service packs and updates).

To install Recorder you must be logged on as system administrator. 

1.1 System requirements

The computer should fulfill the following minimum hardware and software requirements: 

Operating
System

Windows® 7 32-bit and 64-bit
Windows® 8 64-bit
Windows® 8.1 64-bit
Windows® 10 64-bit

Processor Intel Pentium III processor 1 GHz or higher

Graphics adapter Min. resolution 1,024 x 768 pixels and 32,768 colors

RAM
Windows® 7: min. 1 GB
Windows® 8 / 8.1: min. 2 GB
Windows® 10: min. 4 GB

Free disk space
Min. 2 GB free hard-disk space
Additional storage requirements depend on the extent of the data to be 
processed.

Monitor
Min. 17"
A 21" monitor is recommended for more than 32 channels.
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1.2 Preparing your computer

Before installing or using Recorder make sure that the performance of your system is not impaired
by background processes or other real-time applications which run with higher priority.

Do the following:

 Uninstall software that you don’t need (for example, promotional software). 

 Stop services that run in the background, for example:

 system services 

 indexing services

 scanning services (anti-virus)

 updating services (Java, web browser, anti-virus, office software, bloatware)

 Run critical real-time applications on a separate computer, for example:

 NIRS acquisition

 eye tracker acquisition

 stimulation software

 voice, video, audio processing

 flash applications

 time tracker

 Change the settings of Windows® processes (see also: Troubleshooting), for example:

 screen saver

 defragmentation

 Windows® update

 power management

Note

Do not use the recording computer to browse the Internet or playback multimedia files. 
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1.3 Install Recorder

1 Insert the Application Suite USB into a USB drive.

Open Windows Explorer or My Computer and browse to the location of the Application Suite
USB. (Browse to the Application Suite USB folder.)

2 Double click to open the folder.

3 Double click Autorun.exe.

The Welcome screen opens.

4 Click Install BrainVision Recorder & Video Recorder.

The BrainVision Recorder screen opens.

5 Click Install BrainVision Recorder. 

Follow the installation routine and use the default settings. 

6 Now install all Recorder updates that may be available.

By default, the installation directory of Recorder is C:\Vision. 

Browse to the Application Suite USB folder

1 On your keyboard, press the Windows key  + R key.

2 In the Run dialog, click on Browse... 

3 Select the USB port and double-click the Autorun.exe.

4 In the Run dialog, click on OK.

The Welcome screen of the Application Suite opens.

Note

Install Recorder on a stand-alone computer. No stimulation, NIRS, eye-tracking or
similar software must run on this computer.

NEW
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1.4 Update Recorder

New versions and updates of Recorder can be downloaded from the web site:  http://www.brain-
products.com/. You need to login in to access the download area.

Small updates might be available on the Application Suite USB. You can install these directly from
the USB, if applicable.

1 Open the Welcome screen of Application Suite USB.

2 Click Install BrainVision Recorder & Video Recorder.

The BrainVision Recorder screen opens.

3 Click on Install New Modules to install minor updates.

The button is only available, if there are new modules.

1.5 Check the license information

After installing Recorder, ensure that the license information is correct.

Pre-requisites: 

- licence dongle connected to computer

1 Start Recorder 

When you start Recorder for the first time, start in Administrator mode. (For details refer to Pro-
gram preferences.

2 Choose Help > About BrainVision Recorder... 

The About dialog opens. 

Figure 1-1. Dongle information

http://www.brainproducts.com
http://www.brainproducts.com


1  Installing Recorder         16
The About dialog contains the following information: 

 dongle information and internal serial number of the dongle

 expiry date of the dongle and 

 add-on licenses1 bound to the dongle

If your dongle is due to expire, for example less than 30 days are left, a warning appears when you
start Recorder. Contact your local dealer for a renewal.

Figure 1-2. Warning before a dongle expires

1. Depending on you dongle technology the add-on licenses may be called sublicenses.

Notes

 For Hardlock and LPT dongles no expiry date is shown.

 If you are using a Hardlock, LPT or HASP HL dongle, please contact your local dealer
or Brain Products sales to replace your dongle with a latest dongle technology. 

 For more information about the dongles, refer to Appendix B.
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2 Basic procedures

When you start a project from scratch you basically follow the steps below: 

1 Connect the amplifier

First connect the amplifier to your computer and switch the amplifier on (if applicable).

2 Start Recorder

3 Select the amplifier in Recorder

Click on Configuration > Select Amplifier... and select your amplifier from the drop-down list.
You must start Recorder in administrator mode.

4 Create or open a workspace 

A workspace saves all amplifier-specific settings and some basic project settings, for example
filters, segmentation and averaging.

5 Start monitoring

To check if the amplifier is working properly click on the button Start Monitoring . If no errors
are encountered, EEG curves appear in Recorder window running from left to right.
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At the end of the channel list there is a scaling bar that helps you to assess the signal size. If a
small number of channels is displayed and there is enough space, a scaling bar is shown in front
of every channel.

6 Measure the impedances

When all channels show a signal, measure the impedances. This is an important step in your
project. 

7 Record the data

From the impedance check you can switch directly to recording the data. 
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3 Your first steps in Recorder

Read this chapter if you are using Recorder for the first time. 

For your first steps you don’t need an amplifier. Recorder has a simulated amplifier with which you
can try out the basic functions. You can use the simulated amplifier whenever you want to try out
functions or see the impact of settings.

3.1 Start Recorder for the first time

When you start Recorder for the first time, you must select an amplifier.

Prepare: 

- license dongle

1 Connect the supplied license dongle to a USB
port of the computer.

2 Start Recorder in administrator mode.

 Right-click on the Recorder icon and choose
Run as administrator.

 Confirm the subsequent dialog.

3 In Recorder, click on Configuration > Select Am-
plifier...

4 Select your amplifiera from the drop down list
and click on OK.

a. Depending on your system, not all amplifiers, as illustrated above, will be displayed
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3.2 Simulate an EEG monitoring

Recorder has a simulated amplifier. You can use it to make yourself familiar with the basic functions
of Recorder. 

Pre-requisites

- Simulated amplifier selected 

1 Choose File > New Workspace... from the menu bar.

The workspace wizard opens.

2 Click on Next in the first dialog page.

3 In the amplifier settings choose: 

 Sinewave

 Number of Channels: 32

 Sampling Rate [Hz]: 500 

4 Click on Next (three times) and then on Finish.

5 Now click on the button Start Monitoring .

The data is displayed but not saved. Each channel has another sine wave. 

To stop the monitoring mode click on the button Stop Monitoring .
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3.3 Understanding the toolbar

Try out the common functions in the toolbar.

Changing the data display

You can change the way the data is displayed by using the toolbar buttons: 

 

Increase the display interval (zoom out).  

Decrease the display interval (zoom in).

Increase the scaling factor.

Decrease the scaling factor.

Decrease the number channels that are displayed on one screen. 

Increase the number of channels that are displayed on one screen.

Switch to the next group of channels.

Switch to the previous group of channels.

Note: The Next Group and Previous Group buttons are only available, if you decrease the
number of displayed channels or if you have more than 64 channels.

Baseline Correction in Display activates or deactivates baseline correction. When activat-
ed, only the baseline of the display is changed, and not the actual data.

For advanced view options, refer to Chapter 10.
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3.4 Record the EEG data

You must save EEG data to analyze them later in Analyzer, for example.

Pre-requisites

- Data monitoring is running

Recording options

1 Click on the button Record .

The Save As dialog opens.

2 Put in a filename and optionally a comment. 

The comment will be stored in the header file (*.VHDR).

After you clicked on Save, the data is recorded. This is shown in the status bar: 

Pause the recording. To continue, click on the button Record . A new segment marker
will be set.

You can stop recording with the button Stop Recording . 

When you click on button Record   you can append the data to the previous EEG file. In
this case, a new segment marker will be set.
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3.5 Insert an annotation

In your project you might want to insert a note text to remember what a test subject did at a certain
point; for example, moving.

Pre-requisites

- Monitoring or recording started

1 Increase the display interval to a maximum. Click the button Increase Interval  until it is dis-
abled. 

This gives you more time to see where the annotation is inserted. Once you know how it works
you don’t need to increase the display interval.

2 Click the button Annotation .

The Annotation dialog opens.

3 Put in a short, meaningful description, for example ‘moving’, and click OK or press Enter.

The annotation ‘moving’ is shown in the list of markers.

Note: Annotations are inserted with a black marker. The red markers come from the
amplifier.
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3.6 Close Recorder

Recorder can’t be closed during recording or data monitoring. You must first stop the data stream
from the amplifier. Do the following:

1 While a recording is progress, click on the button Stop Recording .

2 Then click on the button Stop Monitoring . 

This button is only active if a mode is running (data monitoring, test signal or impedance
check).

You can now close Recorder.
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4 Program preferences

4.1 Starting Recorder

You can start Recorder in administrator mode or in standard mode.

The administrator mode is mainly used for the basic pro-
gram configuration. In the administrator mode you can
change basic settings in the menu Configuration. 

Limits in standard and administrator mode

4.1.1 Start in standard mode

To start Recorder in standard mode, do the following: 

Standard Administrator

Select amplifier No Yes

Select the data storage type No Yes

Change user rights No Yes

1 Double-click on the Recorder icon. 

Recorder starts in standard mode with limited functionality.
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4.1.2 Start in administrator mode

To start Recorder in administrator mode, do the following: 

4.1.3 Set administrator mode as default

If you generally want to start Recorder as administrator, do the following: 

1 Right-click on the Recorder icon and choose Run as adminis-
trator.

Recorder starts this time in administrator mode.

1 Right-click on the Recorder icon and choose Proper-
ties.



4  Program preferences         27
2 Then, click on the Compatibility tab and choose
Run this program as an administrator.

Recorder will always start in administrator mode. You can undo this setting any time.
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4.2 Setting user rights

As administrator you can limit the program functions for other users.

1 Start Recorder in administrator mode.

2 Click on Configuration > Administrator.

The Administrator dialog opens.
 

Allow User Selecting Workspace
When deselected users cannot change the 
workspace. Editing or creating a workspace 
will still be possible.

Allow User Editing/Creating Workspaces

When deselected, users cannot edit or create a 
workspace. Opening another workspace will 
still be possible. 

Tip: Deselect the first and second option, if 
users must not change workspace settings.

Allow User Editing Preferences

This allows users to make changes to the 
global program configuration (Configuration > 
Preferences...). For details refer to Set global 
program preferences.

Allow User Editing Amplifier Specific Settings

When deselected, the options in the menu 
Amplifier are not available (for example, digi-
tal port settings).

Tip: Deselct if the user must not change any 
settings related to triggers, for example

Force 'Save As' Dialog when Monitoring Starts
With this option, the ‘Save As’ dialog opens 
ever time the users clicks on the monitoring 
button. 
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4.3 Set global program preferences

You can configure global program settings for all users. 

1 Start Recorder in administrator mode or as standard user with the corresponding rights.

2 Click on Configuration > Preferences...

The Preferences dialog opens.

View tab

Default Display Interval specifies the time interval shown on the computer screen by default. 

Restore Default
allows you to reset any value that has been changed to the initial 
value.
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Scaling settings tab

Polarity: Positive Down
defines the polarity of the displayed signal. If you 
select this box, the axis for positive signals points 
downwards.

Start with Display Baseline On
activates the button Baseline Correction  is 
active by default.

Default Scaling [μV]
text box contains the scaling value to be used when 
monitoring starts.

Set Individual Scaling Factors... specify the channel for which you want to change 
the display scaling. 
Enter the channel names and a scaling factor. 
integer (e.g. 1, 2) = reduce scaling
fractional number (e.g. 0.1) = increase scaling.
The scaling only affects the display of the data; it 
does not affect the data itself.
It makes sense to display the ECG channels with 
reduced scaling, since otherwise they encroach 
significantly on the curves of the EEG channels.

Set Default Scaling Parameters for Tabs... specifies the scaling of the amplitude and time 
axes for the scientific view. The setting applies to 
all the tabs in the scientific view.
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DC Correction tab

Remote Data Access  tab

Automatic DC Correction

Choose to activate automatic DC offset correction. 
You can specify the threshold (in percent) for the DC offset correc-
tion in the text box  Threshold [%]. 
For further information on DC correction, refer to Toolbar.

Enable Remote Data Access
to enable the RDA server. For further information on using the 
RDA server, refer to Chapter 13.
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Vision Video tab

This tab is only available, If you have installed Video Recorder and if you purchased the correspond-
ing add-on license.

Enable Vision Video
Choose to enable Vision Video.
For using Vision Video refer to Chapter 11.
Information about add-on licenses refer to Appendix B.
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Passive/Active Electrodes tab

For BrainAmp, V-Amp and QuickAmp you must specify whether you are using passive electrodes or
the actiCAP ControlBox with active electrodes. 

Passive Electrodes

Choose if you are using passive electrodes.
Enable Automatic Impedance-Remeasurement of Data Elec-
trodes: Impedance measurement of the data electrodes (not 
reference and ground) is repeated, if the measured values were 
invalid. Invalid impedances are detected, if the measurement 
has not yet started or if  the values are outside the measure-
ment range.
If the impedances are still invalid after the subsequent mea-
surement, a message is shown  where you can allow (Yes) or 
disallow (No) invalid impedances. When you click on No, you 
must improve the impedances before you can continue.

Use actiCAP Control Software

Choose if you use the actiCAP ControlBox with active elec-
trodes. When selected, Recorder interfaces with the actiCAP 
ControlSoftware.

Detect Invalid Impedances
A message is shown where you can allow too high impedances. 

Use actiCAP Test Signal
When selected, the button Test Signal  in the toolbar is dis-
abled, and you use the button Test  on the actiCAP Control-
Box
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5 Workspace

Workspaces save user defined settings, such as file locations, amplifier parameters, cap configura-
tion, electrode positions etcetera. You work with only one workspace at any one time. You can, , set
up multiple workspaces with different settings, and switch between these as you wish. This pro-
vides you with an easy way to access recording parameters that you use frequently.

Whenever you set up or edit a workspace, you are assisted by a wizard that allows you, for example,
to define channel names and the sampling rate for the recording.

Alongside these settings you make in the wizard, the workspace also stores all the settings you
make in the Amplifier and Configuration menus. Also the impedance measurement settings are
stored with the workspace (see Chapter 8).

When you create or edit a workspace the parameter settings are automatically taken from the last
workspace that was opened. As a result, you may need to adapt these settings for use in the current
workspace.

5.1 The workspace at a glance

Workspaces are created with the help of the workspace wizard. It consists of four dialog pages:

 Data File Settings

 Amplifier Settings

 Software Filters

 Averaging / Segmentation

Pre-requisites

- An amplifier is selected 

- The amplifier is connected to the recording computer

Click on  File > New Workspace... or File > Edit Workspace...

The workspace wizard opens.
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Workspace wizard 1: Data File Settings

On the first dialog page, you set all file related options.

Click on Next to open the dialog Amplifier Settings.

Raw File Folder
specifies the destination directory for the EEG data. By 
default this is ‘C:\Vision\Raw Files’.

Automatic Filename Generation

generates automatic file names consisting of a Prefix and 
Counter. The prefix does not change. The counter is incre-
mented each time you save data. You can specify the length 
of the counter by entering a number between 4 and 10

Current Number specifies the start number of the counter.

Next Resulting Filename

shows the name that results from the entries you have 
made.

In the example above the first data set is saved as ‘Brain-
Amp_0001.eeg’. The second data set would, thus, be ‘Brain-
Amp_0002.eeg’. 
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Workspace wizard 2: Amplifier Settings

The second dialog page contains amplifier-specific parameters (1) and the channel table (2).

Click on Next to open the dialog Software Filters.

Each amplifier family has its specific settings. For more details about the workspace
for your amplifier refer to Amplifier-specific settings.

Scan for Amplifiers
before you can setup a workspace, you must scan for an ampli-
fier. This connects the amplifier to Recorder. The detected 
amplifier(s) are shown in the Scanned Amplifier(s) list.

Number of channels
specify the number of channels (including data, ground, refer-
ence and auxiliary channels, if applicable).

Sampling rate
choose a sampling rate from the drop down list. 
Depending on your amplifier, a higher sampling rate can limit 
the number of channels.

Use Electrode Position File Please refer to Using electrode position files.
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Workspace wizard 3: Filter settings

The third page contains the filter settings.

Three filter methods are available:

 Raw Data Saving Filters

Filters are directly applied to the raw data. Use of this filter is not recommended, because this
changes the raw data. When using BrainVision Analyzer you can apply filters to the raw data. 

 Segmentation Filters

When you specify segmentation (subsequent tab of the workspace wizard) you can also set fil-
ters for the segmented data. 

 Display Filters

This filter only has an effect on the display on your screen. When you set the filter, you can switch
it on and off during the data display of the data by clicking on the button Display Filter .
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Click on Next to open the dialog Segmentation / Averaging

Workspace wizard 4: Segmentation / Averaging

The Segmentation / Averaging dialog allows you to make optional settings for segmentation and av-
eraging. You will find a detailed description of the configuration options for segmentation and aver-
aging in Section 7.2.

Workspace wizard 5: Saving

When you click on Finish, the Save As dialog opens allowing you to save the workspace file. 

Give the file a meaningful name and click Save.

Enable Filters

You can also deactivate the paths completely by deselecting the  box
for each path

Because the filters are software filters, you can enter any values.
Nevertheless, you should take care not to set any frequencies with a
value equal to or greater than half the selected sampling rate.

Low Cutoff Filter
High Cutoff Filter

The slope for the low-cutoff filter and the high-cutoff filter  is 12 dB/
octave.

Low-cutoff filter: Filter that reduces the amplitude of low-frequency
digitized signals.

High-cutoff filter: Filter that reduces the amplitude of high-frequency
digitized signals.

Notch filter
This filters the noise of the mains line. You can choose between
50 Hz and 60 Hz. Depending on your region, the mains noise is either
50 Hz (for example, Germany) or 60 Hz (for example, USA).

Use Individual Settings
You can apply this setting to the channels as a group or to individual
channels by selecting or deselecting the box. 

Copy master settings
Copies the settings from above into the channel table. This button is
only active, when you select the check box Use Individual Settings.
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5.2 Create a workspace from scratch

Pre-requisites

- An amplifier is selected 

- The amplifier is connected to the recording computer

5.3 Using electrode position files

Electrode names, electrode topographies and physical channels are assigned in a workspace. New-
ly created workspaces do not yet contain these specifications and they therefore have to be import-
ed. To assist in the import function, there is a special electrode position file (EPF) created by the cap
manufacturer. Alongside the names and positions of the electrodes (phi, theta, radius values), this
also contains the physical channels. 

An EPF can be used equally well for both for proportional (10-20 system incl. extensions) and spher-
ical caps (equidistant) and gives users the opportunity to adapt the electrode position data (for ex-
ample the physical channel). The EPF is written in XML format and is saved as a BVEF file. This can
be opened and edited in a text editor. The file has the following structure (see also the Analyzer
Manual):

1 Click on File > New Workspace... or File > Edit Workspace...

The workspace wizard opens.

2 Configure the data file settings (first dialog page) and click on Next.

3 In the Amplifier Settings dialog, click on Scan for Amplifiers. 

The connected amplifier will be displayed in the field underneath the button.

4 Configure the settings according to your needs (also: Filters and Segmentation/Averaging).

5 When finished click on Finish to save the workspace.

The Save As dialog opens allowing you to save the workspace file.

By default the workspace is stored in C:\Vision\Workfiles.
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Figure 5-1. Example electrode position file

When the electrode position file has been read into Recorder, the data is written to the header file
which acts as the interface between Recorder and Analyzer. This means that the same information
is available in both Recorder and Analyzer. 

5.3.1 Create a workspace using an electrode position file

You can either load the complete electrode position file, which covers the channel table and elec-
trode topography or only load the electrode topography for the electrodes that are already present
in the channel table. 

 Load complete file: Steps 1 - 7

 Load electrode topography: Skip step 6

Pre-requisites: 

- An amplifier is selected 

- The amplifier is connected to the recording computer

1 Click on  File > New Workspace... or 

The workspace wizard opens.

2 Go to the Amplifier Settings dialog (second dialog page).

<?xml version="1.0"?>
<Electrodes>
<Electrode> //opening tag

<Name>Fp1</Name> //Electrode name (here: 10-20 system)
<Phi>-72</Phi> //Phi value
<Theta>-90</Theta> //Theta value
<Radius>1</Radius> //Radius value
<Number>1</Number> //Physical channel

<Electrode> //closing tag
<Electrode>

<Name>Fp2</Name>
<Phi>72</Phi>
<Theta>90</Theta>
<Radius>1</Radius>
<Number>2</Number>

</Electrode>
...
</Electrodes>
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3 Click on Use Electrode Position File.

4 Select the check box Read positions from
Electrode Position File.

5 Click on Browse and locate the electrode po-
sition file (*.BVEF).

If you want to check the file, click on Pre-
view...

6 Click on Import amplifier channel table. 

Recorder takes over the assignment of chan-
nel names and physical channels.

NOTE: Don’t click this button if you edit an
existing workspace and want to keep the
channel assignment.

7 Click on OK to load the electrode positions
(topographies).

The electrode positions and the channel table (if applicable), are loaded into Recorder. The in-
formation is written into the header file.

You can check the result in the impedance measurement window. 
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Electrode positions when using actiCAP Control Software

If you use active electrodes with the actiCAP Control Software as interface then the positions that
are read in are not displayed in the topography during the impedance measurement. The values are
nevertheless written to the header file. 

5.3.2 Remove the electrode position file from the workspace

If you have already imported an electrode position file in the project then Recorder loads this file
again when you open an existing workspace or create a new one. 

You can stop the import as follows:

1 Click on Use Electrode Position File.

2 Deselect the check box Read positions from Electrode Position File. 

3 Click OK.

Possible errors sources

 More channels in electrode position file than in the workspace: 

The exceeding channels are not imported. Change the number of channels in your
workspace.

 Less channels in electrode position file than in the workspace

The remaining channels stay unoccupied. You can remove the unoccupied chan-
nels from workspace, if necessary. 

 You don’t import the channel table and the electrode position file does not contain
data for some electrodes in the workspace:

The missing electrodes are set to zero. In the impedance measurement, these elec-
trodes are  displayed at the edge.

 Any changes to electrode positions during the impedance measurement are not
written to the original electrode position file.
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Figure 5-2. Stop the use of an electrode position file

5.4 Open a standard workspace 

The first time you start Recorder it creates a default workspace. You can find standard workspaces
on the Application Suite USB. Workspaces have the file extension *.RWKSP.

1 To open a workspace click on the menu File > Open Workspace...

2 Locate and open the workspace.

The default location for workspaces is C:\Vision\Workfiles.

5.5 Display information of your workspace 

You can view the parameters of the current workspace at any time – even during recording – by click-
ing the button Show Workspace Info  in the toolbar.

Note

Workspaces of Recorder 1.10 or earlier contain only the parameters that were entered
using the wizard but not the settings from the Configuration and Amplifier menus. If
you open such workspaces then the corresponding parameters are taken over from the
last opened workspace.
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6 Amplifier-specific settings

Compatibility of Windows® and amplifiers

Some amplifiers are not supported by all Windows® operating systems. The following table pro-
vides an overview of the compatibility:
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LiveAmp



6.1 Simulated amplifier       45
6.1 Simulated amplifier

The Simulated Amplifier function allows you to: 

 use the Recorder without having an amplifier connected. 

 display an EEG that has already been recorded.

It simulates the activity of up to 256 channels. 

6.1.1 Simulated workspace at a glance

When you select the simulated amplifier, a ‘simulated’ workspace is created. The parameters for
this workspace are taken from the most recent workspace based on a real amplifier. You can edit
the workspace for the simulated amplifier without overwriting the original workspace based on a
real amplifier. 

If you select a real amplifier after the simulated amplifier, the most recent associated workspace is
loaded without changes (rather than the simulated workspace).

Sinewave Sinewaves will be displayed for all channels.

EEG

Click the Browse button   to open a saved EEG data set. If you then
switch the Recorder to monitoring mode, the EEG data set is displayed.
The EEG data is displayed in the same way as with a real amplifier. The
EEG data set is repeated in a loop.
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Number of Channels You can select up to 256 channels.

Sampling Rate [Hz] Select a sampling rate.

Note

The menu bar does not contain the Amplifier item if you are using the Simulated Am-
plifier function.

Don’t modify the file properties of the simulated workspace.
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6.2 BrainAmp amplifiers

6.2.1 BrainAmp workspace at a glance

To access the workspace you must first create or edit a workspace.

1 Choose File > New Workspace... from the menu. 

2 If you have connected an amplifier click on Scan for Amplifiers... 

If you don’t have an amplifier or Select Virtual Amplifier(s)... and select an amplifier.

3 The workspace wizard opens. Skip the first dialog page.

On the Amplifier Settings dialog page, the settings for your amplifier are in the upper section. 

Number of Channels Enter the number of channels.

Sampling Rate [Hz] Choose the sampling rate from the drop-down list.

Resolution [μV] Choose an amplitude resolution from the drop-down list. 

Range [+/- mV]
The mV range shows the range across which the amplifier sends data to 
Recorder. 

 Low Cutoff [s]
 High Cutoff [Hz]

Specify the low and high-cutoff filters for the hardware.

Use PolyBox
If you are using a PolyBox select this check box to enable it.  
Refer to Use PolyBox.

Use ExG AUX
If you are using the AUX Box select this check box to enable it.
Refer to Use ExG AUX.
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Use Individual
Settings

This allows you to make the relevant settings separately for each chan-
nel in a table. 

Low Impedance
(10 MOhm) for DC/

MRplus

Allows you to switch the input impedance of more than 10 GOhm to 10 
MOhm if you are using a BrainAmp DC or BrainAmp MR plus in conjunc-
tion with a BrainAmp Standard or BrainAmp MR. This sets the input 
impedance of all amplifiers to a common value (10 MOhm).

Copy Master Set-
tings

The Copy Master Settings button allows you to copy the parameters you 
have entered into the channel table so that you only have to edit those 
channels for which the settings are different.

Ground Series
Resistor [kOhm]

Reference Series
Resistor [kOhm]

To specify the values for the protective resistors fitted in the electrode 
cables of the ground electrode and reference electrode, select the 
Ground Series Resistor [kOhm] and/or Reference Series Resistor 
[kOhm] box and assign the relevant values in the associated text boxes.

Note: These details are only required for BrainAmp MR amplifiers or if 
you are using an electrode cap for acquisition that is fitted with resis-
tors in the electrodes (for example, BrainCap MR or bipolar electrodes 
used in MR scanners). The resistance values for these protective resis-
tors are stored in the workspace and are subtracted from the measured 
impedances during impedance measurement, so that only the imped-
ance between the skin and the electrodes is shown in the Impedance 
Check View and saved in the header file.
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Editing the channel table

The channel table is in the lower section on the Amplifier Settings dialog page. 

Name
You can change the name of the ‘logical channel’ by double-clicking.
If you enter the same name twice, an error message is shown when you 
want to proceed to the next workspace page.  

Type
Indicates the channel type (EEG, REF, BIP or AUX). The channel type is auto-
matically assigned.

 Phys. Chn.
Each channel name must have one physical channel. You can assign physi-
cal channels to the logical channels in the first column.

Resolution [μV]
Enter the signal resolution. 
(You must first select the check box Use Individual Settings.)

Range [+/- mV] Indicates the range across which the amplifier sends data to Recorder.

Low Cutoff [s]
Enter a value for the low-cutoff filter. 
(You must first select the check box Use Individual Settings.)

High Cutoff [Hz]
Enter a value for the high-cutoff filter.
(You must first select the check box Use Individual Settings.)

Series Resist.
[KOhms]

Enter the resistance of the protective resistors installed in the electrode 
cables. 
Note: These details are only required for BrainAmp MR amplifiers or if you 
are using an electrode cap for acquisition that is fitted with resistors in the 
electrodes (for example, BrainCap MR or bipolar electrodes used in MR 
scanners). The resistance values for these protective resistors are stored in 
the workspace and are subtracted from the measured impedances during 
impedance measurement, so that only the impedance between the skin 
and the electrodes is shown in the Impedance Check View and saved in the 
header file.
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Add and remove channels

Click with the right mouse button in the channel table, where you want to insert or remove a chan-
nel. 

A context menu opens.

Diff. Unit

These are settings for auxiliary channels. For details refer to Use ExG AUX or
Use PolyBox.

Unit

Gradient

Offset

Insert Channel Inserts a channel above the selected row.

Remove Channel...
Removes the channel. You must confirm this action. 
If the table contains only one channel, this com-
mand is not available.

Insert / Remove Channel and
Update All Following Physical Channels

Choose this option, to update the names and num-
bers of the subsequent channels. The physical chan-
nel index of the subsequent channels is 
incremented or decremented automatically. The 
focus is set to the empty channel name and the 
remaining cells are filled with default values. The 
channel type is filled in automatically on the basis of 
the physical channel index.
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6.2.2 Using virtual amplifiers

The option virtual amplifier allows you to setup your workspace without connecting an amplifier.
You can choose any amplifier of the BrainAmp family and try out different amplifier combinations
within the BrainAmp family.

You can’t monitor data. The option virtual amplifier is only used to setup your workspace. 

1 Click on the button Select Virtual Amplifier(s)... 

2 In the  dialog select an amplifier from the list on the left and click on the arrow button . 

To remove an amplifier select the amplifier from the list on the right and click the on .

3 Set the order of the amplifiers with the up  and down  buttons.

Note: BrainAmp ExG amplifiers must be the last amplifier in the list.

4 Click OK. 

The workspace is automatically updated.
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6.2.3 Using a BrainAmp ExG

The BrainAmp ExG only works with passive electrodes. 

You can combine a BrainAmp with active electrodes and a BrainAmp ExG with passive electrodes.

If you are using more than one amplifier (a BrainAmp MR together with the BrainAmp ExG MR, for
example), you must connect the amplifiers in such a way that the BrainAmp ExG MR is displayed as
the last amplifier in the list. Otherwise, a warning message is shown.

Measuring impedances

If you are using a BrainAmp ExG (passive electrodes) in addition to a BrainAmp (active electrodes)
and you click the button Impedance Check  in the toolbar, the following message is shown:

The active electrodes (BrainAmp) are always measured first, followed by the passive electrodes of
the BrainAmp ExG in a second pass.

 Click the button Impedance Check  in the toolbar again after the active electrodes have been
measured in order to continue measuring the passive electrodes.

 If measurement of the passive electrodes has been completed and you click on the button Im-
pedance Check again, the active electrodes are measured again.

The active electrodes which have already been measured are shown in gray on the second pass. The
passive electrodes that are now to be measured are shown on the top right edge of the screen and
color-coded. 



6.2 BrainAmp amplifiers       53
6.2.4 Use ExG AUX

The ExG AUX Box allows you to connect single electrodes and polygraph sensors (such as the GSR-
MR module) to the BrainAmp ExG and the BrainAmp ExG MR in order to record bipolar signals.

In the workspace click on Use ExG AUX.

AUX channels will be automatically added to the end of the channel table (see Note below).

Note: If installation has been carried out correctly, the AUX channels are always the last eight phys-
ical channels. If you are using a BrainAmp ExG or BrainAmp ExG MR, these are physical channels 9
through 16. If you are using a BrainAmp and a BrainAmp ExG, these are the physical channels 41
through 48. If you are using two BrainAmps and a BrainAmp ExG, these are the channels 73 through
80, etc. If you are only using two BrainAmp ExGs, these are the channels 9 through 16 and 25
through 32, etc.

Diff. Unit If you select Diff. Unit, you can use a different unit such as ‘C’ for Celsius.

Unit Enter the required unit in the Unit column.

Gradient
Enter the gradient in mV/unit. Example: For the unit C use mV/C. This will describe 
the voltage difference in mV at a temperature change of one degree Celsius. The 
value can also be negative.

Offset Defines the zero point. In our temperature example, this is the voltage in mV that 
the sensor returns at a temperature of 0 degrees Celsius.
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6.2.5 Use PolyBox

When used in conjunction with the BUA64 and one or two BrainAmp amplifiers, the PolyBox permits
the additional, simultaneous recording of up to eight polygraph signals captured by sensors for the
display of status changes.

1 If you are using a PolyBox select the check box Use PolyBox.

2 In Number of Channels you can add up to eight channels.

 The corresponding number of AUX channels is added at the end of the channel table.

Diff. Unit If you select Diff. Unit, you can use a different unit such as ‘C’ for Celsius.

Unit Enter the required unit in the Unit column.

Gradient
Enter the gradient in mV/unit. Example: For the unit C use mV/C. This will describe 
the voltage difference in mV at a temperature change of one degree Celsius. The 
value can also be negative.
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6.2.6 Configuring the digital port 

The BrainAmp USB adapter (BUA) has a Trigger input (26-pin socket)  for recording events synchro-
nous with the EEG such as stimuli or test subject responses. The socket contains sixteen 1-bit digi-
tal inputs that can be programmed separately from each other. The designations D00 through D15
relate to the bit number, with the first bit being designated with 0.

To change the settings of the digital port click on Amplifier > Digital Port Settings...

The Digital Port Settings dialog opens.

Offset
Defines the zero point. In our temperature example, this is the voltage in mV that 
the sensor returns at a temperature of 0 degrees Celsius.

Notes

 Simultaneous use of the PolyBox and the ExG AUX Box is not supported. 

 The PolyBox is not available if you are using a virtual amplifier.

High Active
In the recording a marker is set on the rising edge and in the hardware a 
pull-down resistor with 4.9 kOhm is activated. This resistor is switched to 
ground.
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Low Active
In the recording a marker is set on the falling edge and in the hardware pull-
up resistor with 4.9 kOhm is activated. This resistor is switched to the 
5 Volt power supply.

You can set High Active or Low Active for each group (bit 0-7 and 8-15). This 
setting specifies when a marker is recorded. It also specifies the default 
configuration of the hardware:

Bit overview
table

Enabled
Select to enable the bit and deselect to disable the bit.

Type
Specify the name for each bit. You can assign the same type to several bits.
Recorder and Analyzer use color coding for ‘Stimulus’ and ‘Response’ 
types. Thus it is recommended to choose ‘Stimulus’ and ‘Response’ for 
stimulus and response inputs respectively.

Both active
Select Both Active to record the length (or duration) of the generated trig-
ger. This option is only available for one bit line at any time. 
When you use this option, you must choose a unique name for the marker 
type to be able to identify the  corresponding bit line.
Both pull-down (high-active signal) and pull-up (low-active signal) resis-
tances are taken into account on the generation of the trigger signal. Two 
markers, which indicate the start and end of the trigger signal, are written 
for each of these. For example, one marker may be written at the time at 
which a transmission error between the MOVE receiver and transmitter is 
detected and another marker at the time when data transmission between 
transmitter and receiver functions correctly again.
Note that this function is not available for the ‘DC Correction’ marker type.

Current state

Check your setup with the help of 
this field. The black and red bullets 
indicate the state of your trigger 
sources. Activate a trigger to check if 
the state of the bullet changes and that a marker will be set. If the bullet 
does not change, then adapt the Low Active and High Active settings.

Enable
Debouncing in

Millisecond
(5..50 ms)

If you select this option, repetition of a marker of the same type and same 
description is ignored for a period of 5 to 50 ms.
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6.2.7 Show connected amplifiers

Choose Amplifier > Connected Amplifiers... from the menu

The Connected Amplifiers dialog opens. It lists all amplifiers that are currently connected to your
computer and are ready for operation.

Notes

Trigger signals must be present at least for the extent of a sampling point. This means,
for instance, that at a sampling rate of 1,000 Hz, the minimum length of the trigger sig-
nal is 1 ms and that at 500 Hz the minimum length is 2 ms, etc.

The digital port of the BrainAmp USB Adapter is designed only to receive triggers. Do
not connect the adapter to the trigger input of stimulation devices.

Note for using the TriggerBox

To use all of the 16 bits of the TriggerBox and TriggerBox Extension together with Brain-
Amp, take note of the following. 

If you connect a high-active source to the bits 8-15:

 set the used bits to High Active, and

 disable the unused bits of the group 8-15.

If you connect a low-active trigger source to the bits 8-15, then select Low Active. 
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Figure 6-1. List of connected BrainAmp amplifiers

6.2.8 Using the test signal

To display and record a test signal, attach the supplied signal tester to the BrainAmp amplifier via
the electrode input socket. 

In the toolbar, click the button Test Signal  . 

A signal with an amplitude of 50 μVpp (square) or 100 μVpp (sine) is shown. 

You can change the signal shape (square or sine) by choosing
Amplifier > Test Signal Values... 

The Frequency [Hz] text box allows you to specify the frequency
of the signal in a range 1 Hz through 50 Hz.
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6.2.9 Measuring the impedances

With the BrainAmp, we distinguish between three groups of electrodes that are measured separate-
ly: EEG electrodes, the reference electrode and the ground electrode. The electrode groups are not
entirely independent of each other.

Proceed as follows to measure impedances:

1 Prepare the electrodes.

2 Measure the EEG electrodes. 

Start with the largest range. If all electrodes are in a high-impedance state, check that the refer-
ence and ground electrodes are connected firmly. 

3 If the EEG electrodes show impedances that are roughly correct, measure the reference elec-
trode. 

4 Finally measure the ground electrode.

Note

If a channel is open (for example an electrode is incorrectly prepared or damaged), it
will impact the subsequent channel. This means that although the subsequent chan-
nel actually has a lower impedance, a higher impedance value will be displayed for it.
You can only rectify the situation by correcting the bad value caused by the open chan-
nel. This is done by preparing the relevant electrode correctly or replacing the dam-
aged electrode.

You will find information on impedance measurement in Chapter 8.
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6.2.10 Using the SyncBox

The SyncBox is mainly used in MR environment with BrainAmp MR,  BrainAmp ExG MR and BrainAmp
MR plus. It synchronizes the sampling rate of the amplifier with the clock rate of the MR scanner to
ensure the stability of EEG recording during MR acquisition. 

Choose Amplifier > SyncBox Settings… 

The SyncBox Settings dialog opens.

Use SyncBox

When selected the SyncBox icon appears in the status bar in
both monitoring mode and save mode. A change to the syn-
chronization status is indicated by markers and stored in save
mode. The markers indicate the synchronization status by ‘in
sync’ or ‘of sync’. 

 Green: synchronization is on
 Red: synchronization is off

Scanner Frequency [kHz] 

The specified frequency must divisible by 5 kHz (for example
10,000 kHz).

This is the frequency of the signal on the gradient board of the
MR system that the SyncBox Scanner Interface is connected to.
Note that this value is specified in kilohertz (kHz). So, if you put
in 10,000 the input signal at the SyncBox is 10 MHz

Disable Sync Marker When selected no synchronization markers are written during
synchronization.

Update Interval Sync Status
Marker [s]

Specify the frequency with which the markers are written.
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6.2.11 DC-offset correction 

DC offset correction is available for the DC-coupled amplifiers BrainAmp DC, BrainAmp MR plus,
BrainAmp ExG and BrainAmp ExG MR.

The DC offset correction is based on the average of the EEG signals. If this average is equal to 0,
there is no DC offset. If analysis is negatively affected by too high a DC offset, it may be necessary
to activate DC offset correction.

DC offset correction directly impacts the data. We therefore recommend that you try to avoid DC off-
set correction in important sections of the EEG.

Automatic DC offset correction

You can configure Recorder to perform automatic DC offset correction as soon as a channel value
exceeds a critical threshold. 

The channel names are shown on the far left of the window. The percentages for each channel
only appear if a DC amplifier is connected in DC recording mode. In this event, the values corre-
spond to the DC offset of the signal. An offset of 100% corresponds to saturation at the positive
end of the recording level range. An offset of -100% corresponds to saturation at the negative
end of the recording level range.

1 Click on Configuration > Preferences... 

The Preferences dialog opens.

2 Open the tab DC Correction. 

3 Select the check box Automatic DC Correc-
tion and enter a threshold value in percent. 

4 Click on the button DC Correction  to ac-
tivate the DC offset correction.
Recorder sets a corresponding marker to flag
the DC offset correction in the data. 
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Trigger-controlled DC offset correction

You can use the  marker type ‘DC Correction’ for carrying out a DC measurement. 

The description of the markers is encoded automatically. The following procedure is used: The first
occurrence of the type in the table is weighted with value 1, the second occurrence with value 2, the
third with value 4 etc. For every data point, all set bits of a type are added together according to this
pattern. The resultant number is combined with the initial letter of the type, resulting in the descrip-
tion.

Example 

Bit 8 through bit 15 are of the type ‘Response’. If bits 11 and 13 are set, this results in a marker of
the type ‘Response’ with the description ‘R 40’. Bit 11 has a value of 8 and bit 13 a value of 32. The
total is 40. The consequence of this logic is that only markers of different types can be detected at
any one time. If you want to record different responses simultaneously, you can do so by decoding
the number values subsequently in the analysis, by assigning a separate marker type to every bit.
Alternatively, you can assign a separate type to every bit in the table.

  

1 Click on Amplifier > Digital Port Settings...

The Digital Port Settings dialog opens.

2 Choose a marker and type in ‘DC Correction’. You can
define this at any bit position. 

Note that Both Active is not available for the ‘DC Correc-
tion’ marker.

DC offset correction is automatically performed when this trigger is received. If several markers
of the type ‘DC Correction’ are set simultaneously, correction is only performed once. This ap-
plies to both USB and PCI ports.
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6.3 actiCHamp amplifier

For actiCHamp amplifiers your computer must fulfill the following system requirements:

- Windows experience index:  min. 5.0

- Processor: Intel® Core™ 2 Quad processor, 2.4 GHz or higher

- Graphics adapter: 1280 x 1024 pixel resolution, min. 512 MB memory

- RAM: 4 GB

6.3.1 actiCHamp workspace at a glance

To access the workspace you must first create or edit a workspace.

Pre-requisites:

- actiCHamp connected to the computer

1 Choose File > New Workspace... from the menu. 

2 Click on Scan for Amplifiers. The connected amplifier and available number of channels is
shown.

3 The workspace wizard opens. Skip the first dialog page.

On the Amplifier Settings dialog page, the settings for your amplifier are in the upper section. 
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Number of Channels Enter the number of channels.

Reference Channel

Enter the physical channel number of the reference channel. 
You can use any EEG channel as the reference channel; by 
default, the program uses the second channel. The channel 
selected as the reference channel is grayed in the display.

 Sampling Rate [Hz]

Choose the sampling rate from the drop-down list.
The minimum sampling rate is 100 Hz. The maximum sampling 
rate depends on the number of channels used.
 32 EEG + 8 AUX: 100 kHz
 64 EEG + 8 AUX: 50 kHz
 160 EEG + 8 AUX: 25 kHz

Enable Active Shielding

Active shielding mode is used to reduce environmental influenc-
es such as noise, electrical interference or cable movement, that
would otherwise have an effect on the electrodes. 

When the check box is selected the active shielding information 
window will display. 
 Select OK to enable active shielding or 
 select Cancel to close the window and leave active shielding

unchecked. 
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6.3.2 Configuring the AUX inputs

If you wish to use external sensors to measure temperature, skin conductivity etc. you can carry out
the appropriate adaptations at this point. The AUX channels are always the last eight channels in
the channel table.

6.3.3 Configuring the digital port

actiCHamp has trigger connectors on the rear labeled Trigger In and Trigger Out.  The trigger connec-
tions have eight trigger lines and therefore eight bits each.

To change the settings of the digital port click on Amplifier > Digital Port Settings...

The Digital Port Settings dialog opens. 

You encode inbound triggers in the left section and the outbound triggers in the right section of
this dialog.

Diff. Unit If you select Diff. Unit, you can use a different unit such as ‘C’ for Celsius.

Unit Enter the required unit in the Unit column.

Gradient
Enter the gradient in mV/unit. Example: For the unit C use mV/C. This will describe 
the voltage difference in mV at a temperature change of one degree Celsius. The 
value can also be negative.

Offset
Defines the zero point. In our temperature example, this is the voltage in mV that 
the sensor returns at a temperature of 0 degrees Celsius.
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Set up the trigger input

Use the inbound triggers for recording events that are synchronous with the EEG such as stimuli or
test subject responses.

Set up the trigger output

To change the settings of the digital port click on Amplifier > Digital Port Settings...

High Active /  Low Active

You can choose whether the signals are interpreted as high-
active (5 V = active) or low-active (0 V = active). 
 High Active: trigger is generated on a rising edge:
 Low Active: trigger is generated on a falling edge.

Enabled select to enable the bit

Type
specify what time marker type each bit represents (for exam-
ple Stimulus, Response). You can assign the same name to 
several different bits.

Current State  view the current status of the bit lines (active or inactive).

Enable Debouncing in Millisec-
ond (5..50 ms)

Repetition of a marker of the same type and same description 
is ignored for a period of 5 through 50 ms.

Restore Default
To reset changed settings to their initial configuration, click 
Restore Default in the lower part of the dialog box.
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The Digital Port Settings dialog opens. You encode outbound triggers in the right-hand section
of this dialog.

Minimum trigger length

Please take note of the recommended minimum length of the trigger signal for various sampling
rates in the table below. Shorter signal lengths can result in faulty markers.

 Enable Sending Trigger
Dialogbox

Select to send triggers from the trigger port

Send Click the button to  encode and send the trigger to the output.

 Click and Send

Select this check box, to send triggers manually during record-
ing. 
When selected the trigger that is encoded here is sent directly to 
the trigger output when you select (bits 1 to 8) High or Low. If you 
do not use this function then you can only send triggers to the 
trigger output by clicking the Send button.

Sampling rate Minimum length of trigger signal

100 Hz 20 ms

200 Hz 10 ms

250 Hz 8 ms

500 Hz 4 ms

1000 Hz 2 ms

2500 Hz 0.8 ms

5000 Hz 0.4 ms

10000 Hz 0.2 ms

25000 Hz 0.08 ms

50000 Hz 0.04 ms
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Initial configuration of the digital port

To reset the digital port settings to their initial configuration, click Restore Default in the lower part
of the dialog box. The default settings are listed in the table below:

6.3.4 Measuring the impedances

actiCHamp works with active electrodes for which you don’t need the actiCAP ControlBox.

Pre-requisites

- workspace configured and amplifier connected

- electrodes connected and prepared

100000 Hz 0.02 ms

Parameters Default setting

Bits are High Active

Enabled All boxes are selected.

Type Bit 0 through 3: Stimulus, 4 through 7: Response

Enable Debouncing in Millisecond Not selected

Enable Sending Trigger Dialogbox Not selected

Bits (Pins) Low All bits are selected

Bits (Pins) High No bits are selected

Click and Send Not selected

Note

The trigger input and output are designed only for TTL signals (0 to +5 V, maximum
10 mA).

For the pinout of the digital port please refer to the actiCHamp operating instructions.

1 Click on the button Impedance Check .

Sampling rate Minimum length of trigger signal
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6.3.5 The actiCHamp window

The actiCHamp window is displayed in all operating modes.

2 The Impedance Check View and the actiCHamp window open.

3 Set the threshold levels for the impedance in the actiCHamp window and click on Update. 

The values will be updated in the Impedance Check View. At the same time the LEDs in the elec-
trode may change as well as the electrodes in the Impedance Check View.

To restore the default values click on the button Reset.

Note: If the actiCHamp window does not open, it might be mini-
mized. Look in the task bar.
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The button Hide/Show Details  allows you to hide or expand the window. If you want to minimize
the window to the task bar, click Minimize Window.

The upper part of the window displays the function currently being executed as a result of pressing
the MY-Button. If you select the Enable Beep Sound for MY-Button box, then either a short beep
(move on to the next function) or long beep (move back to the previous function) sounds when you
press the MY-Button.

Memo tab

On the Memo tab, you can see the functions you have assigned to the MY-Button. At the most, the
previous, current and next steps in a function sequence are displayed.

Active Electrodes Settings tab

On the Active Electrodes Settings tab, you can modify the range of values for the LEDs of the active
electrodes. The functions available on this tab can be accessed as soon as you switch the Recorder
to impedance mode. 

To modify the display, enter the required values in the Good level kOhm and Bad level kOhm text
boxes: The LEDs indicate impedance values below the ‘Good level’ in green, values between the
‘Good level’ and ‘Bad level’ in yellow and values above the ‘Bad level’ in red. Click Update to apply
the modified values. You can use Reset to restore the values from the initial configuration.
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Test Trigger Out Port tab

The Test Trigger Out Port tab allows you to send triggers to the actiCHamp's trigger output. This func-
tion is only used to check that the trigger output is working properly. 
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6.3.6 Show information about your actiCHamp

Driver versions

To call driver version information, choose Amplifier > Version Information... from the menu.

Figure 6-2. Driver versions

Connected amplifiers

Choose Amplifier > Connected Amplifiers... from the menu to determine which actiCHamp amplifi-
ers are currently connected to your computer and are ready for operation.

Figure 6-3. List of connected BrainAmp amplifiers



6.3 actiCHamp amplifier       73
6.3.7 MY-Button

On the front of the actiCHamp, there is a control button labeled MY-Button to which you can assign
your own individual functions. The MY-Button provides you with many different ways of configuring
functions for a wide range of tasks. However, its use requires the user to display a high level of per-
sonal responsibility and safety awareness.

These functions are stored in a separate configuration file (extension: .MyBtn) in the Workfiles fold-
er and will be called again in the predefined sequence.

1 Settings for the MY-Button.

2 Information about the selected task and parameter.

3 Important hints for the selected task.



6.3 actiCHamp amplifier       74
Configure the MY-Button

To configure the MY-Button do the following:

1 Choose Amplifier > Configurable MY-Button Settings...

The MY-Button Settings dialog opens

2 Select the check box Use Configurable MY-Button.

3 Click on the button New... to create a predefined tasks. 

If you want to edit an existing set of tasks, click on the  button
Open... or just edit the displayed task table.

4 Choose a task.

Click in the task field and choose a task from the drop-down list.

Note: For some tasks you must specify parameters (please refer to
Specify Parameters for the Tasks).

5 Choose a LED state.

This defines the LED state of the MY-Button. 

Click in the task field and choose a task from the drop-down list.

6 To change the order of the tasks select a task click on the buttons
Up or Down. 

7 To remove a task select the task in the list and click on the button
Remove.

8 When finished click on the button Save As...

When you press the MY-Button on the actiCHamp, all the functions
in the sequence are executed. 
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Execute the predefined tasks

Do the following, to execute the predefined tasks:

 Press the MY-Button on actiCHamp briefly once to call a function. The next time you press the
button, the next task is called. 

A marker is inserted and recorded when you call a task.

You can see the state of the sequence in the actiCHamp window.

 To jump back a task and run it again, press and hold the MY-Button for at least  one second (> 1
s).

 When you reach the end of the task list (e.g. marked as ‘End of Sequence’), the sequence does
not start from the beginning. 
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Specify Parameters for the Tasks

For some Tasks you must specify Parameters. Do the following: 

1 Double-click in the Parameter column. 

A dialog box is shown. 

2 Enter your settings and click on OK. 

Task Parameters

Start Monitoring --

Start Impedance --

Start Testsignal --

Start Recording Specify the name and storage location of the file.

Pause Recording --

Resume Recording --

Stop Recording --

Arbitrary Annotation Enter a text of your choice. 
Don’t use special characters like $%-@/\|;,:. 

The text will be displayed and recorded as a marker.

Start Application You can select an application via the Windows® Explorer.

Notes: The real-time performance of Recorder may be impaired if you
run an application. This may result in a loss of data. 

If you use stimulation software, you must not connect stimulation de-
vices to the parallel port of the computer on which Recorder is run-
ning.

Press Keys Define a keyboard shortcut. For available shortcuts refer to Keyboard 
shortcuts for MY-Button (actiCHamp).

Note: Before including any given keyboard shortcut in your experi-
ment, make sure that this does not impair your experimental para-
digm or the recording of the data.

Send Trigger Enter a value in the range 0 to 255.

The defined trigger will be sent to the trigger output.

End of Sequence --
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Keyboard shortcuts for MY-Button (actiCHamp)

You can use the following keyboard shortcuts for the MY-Button. The input values must be between
curly brackets {}:

Input Key

BACKSPACE, BS or BKSP Backspace

BREAK Break

CAPSLOCK Caps Lock

DELETE or DEL Del

DOWN Down arrow

END End

ENTER or ~ Enter

ESC Esc

HELP Help

HOME Home

INS Ins

LEFT Left arrow

NUMLOCK Num Lock

PGDN Page down

PGUP Page up

RIGHT Right arrow

SCROLL Scroll Lock

TAB Tabulator

UP Up arrow

F1 to F12 F1 to F12

ADD Numeric keypad: Plus

SUBTRACT Numeric keypad: Minus

MULTIPLY Numeric keypad: Multiply

DIVIDE Numeric keypad: Divide

PLUS +

AT @

CARET ^

TILDE ~

LEFTBRACE RIGHTBRACE { }

LEFTPAREN RIGHTPAREN ( )

WIN or @ Windows key
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Restrict user privileges for the MY-Button

As administrator set the user privileges, so that standard users cannot make changes to the MY-But-
ton settings. 

Pre-requisites

- Start Recorder in administrator mode

  

+ Shift

^ Ctrl

% Alt

APPACTIVATE WindowTitle Set focus to window by entering window title

1 Click on Configuration > Administrator...

2 In the dialog, deselect the check box Allow User Editing Amplifier Specific Settings.

If the Use Configurable MY-Button box is selected (MY-Button settings) the user can use the
predefined task sequence, but cannot modify or load another sequence. 

All other amplifier-specific settings will also be disabled for standard users.

Input Key
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6.4 LiveAmp amplifier

LiveAmp is a wireless amplifier that allows you to record data to a memory card in LiveAmp, a com-
puter or both. LiveAmp is available in three versions, 32 channel, 16 channel and 8 channel. Also
available is the LiveAmp 64 which allows you to connect two LiveAmp 32’s to record 64 channels.   

6.4.1 Select your LiveAmp

1 Turn on your LiveAmp/s by pressing and holding the power button for five seconds.

2 Refer to Section 4.1.2 Start in administrator mode. 

3 Click Configuration > Select Amplifier, the Select Amplifier dialog is shown. 

4 Select either LiveAmp 8/16/32 or LiveAmp64 and click OK. 

       The LiveAmp Console is shown.

Refer to the LiveAmp Operating Instructions for detailed information on the LiveAmp
amplifier.

You can identify which version of LiveAmp you
have by referring to the reference number (REF)
on the type plate at the bottom of your LiveAmp. 

 BP-200-3000 - LiveAmp 32 Channel

 BP-200-3010 - LiveAmp 16 Channel

 BP-200-3020 - LiveAmp 8 Channel

Note: 

 Ensure your LiveAmp amplifier is running the latest firmware. Refer to the LiveAmp
Operating Instructions for details on how to update the firmware. 

 If switching between LiveAmp 32 and LiveAmp 64 ensure the LiveAmp is restarted
each time. 

 Support for LiveAmp 8 channel and LiveAmp 16 channel is available in Recorder
software version 1.21.0201 or later.

 Support for LiveAmp 64 is available in Recorder software version 1.21.0303 or lat-
er. 

or

NEW
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Search for amplifier
Click to search for all LiveAmps within reach. Select your LiveAmp 
and connect it with recorder.

Disconnect Disconnects LiveAmp from Recorder.

Search for the last con-
nected LiveAmp

Select to search for the last connected LiveAmp only. No other Live-
Amps will be included in the search. If no LiveAmp is found the 
search will be extended. 

Record (Start / Stop)

Starts and stops the recording to the memory card.
Note: By clicking on Start, a part of the memory card is prepared for 
the recording. Preparation takes several seconds and is indicated by 
a progress bar. During that time the memory card is not accessible.

File Name
Name of the EEG file that is stored on the memory card. The EEG file 
is automatically generated.

Free Space Remaining free space on the memory card. 

File Size Size of the current EEG file.

Lead-Off Detection
(Show)

Click on Show to check if an EEG lead has dropped off during the 
acquisition. This option is only available for passive electrodes.

Impedance Settings
(Good Level/Bad Level)

For active and dry electrodes you can set the levels for the imped-
ance measurement.

Reset Click on Reset to restore the default values.

Status bar The status bar shows if data is recorded to the LiveAmp memory and 
information about.

The colors of the bullet show the quality of the wireless connection 
(green = good, amber = weak, red = bad).

NEW
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6.4.2 Connect LiveAmp 8, 16 or 32 with Recorder 

To use LiveAmp you must connect LiveAmp with the recording computer through the wireless adapt-
er.

Prerequisites:

- LiveAmp is selected in Recorder (LiveAmp Console is open)

- LiveAmp is switched on

6.4.3 Identify your LiveAmp 8, 16 or 32

You identify the LiveAmps by their serial numbers. The serial number starts with ‘LA-’.

1 In the LiveAmp Console click on Search for Live-
Amp...

2 The LiveAmps within Range window opens.

If no LiveAmp was found, ‘Simulation’ is shown.

3 Choose a LiveAmp and then click on Connect. 

Alternatively, double-click on the LiveAmp icon.

The wireless LED (blue) on LiveAmp starts blink-
ing. Your LiveAmp is now connected with the re-
cording computer.

!
The LiveAmps within Range window lists all Live-
Amp amplifiers with their serial numbers that
were detected during the scan. 
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6.4.4 Connect LiveAmp 64 with Recorder

To record data, LiveAmp 64 must be connected wirelessly with Recorder. Use the supplied wireless
adapters to make the connection. 

Prepare

- 2 x USB extension cable

- 2 x Wireless adapter

- LiveAmp 64 (with memory cards if required)

- Computer with Recorder 1.21.0303 or higher

You can find the serial number (SN) on the type
plate at the bottom of your LiveAmp.

To read the serial number, you can disconnect
the electrode connector without turning off Live-
Amp.

1 Connect the wireless adapters with the USB ex-
tension cable to your computer. 
To ensure reliable data transmission keep the
wireless adapters at least 50cm apart.

2 Position the wireless adapters within line-of-
sight of LiveAmp.

3 Start Recorder (in administrator mode) and
choose LiveAmp64 from the menu Configuration
> Select amplifier...

The LiveAmp Console opens.

4 Switch on each LiveAmp by pressing and holding
the power button for five seconds.



6.4 LiveAmp amplifier       83
6.4.5 Identify your LiveAmp 64

You identify the LiveAmp 64 using the last four digits of master LiveAmp amplifier’s serial number. 

5 In the LiveAmp Console click on Search for Live-
Amp...

6 Select the LiveAmp 64 and click on Connect. 
(See also Identify your LiveAmp 64.)

The blue LED of both the wireless adapter is ON
and the wireless LED on both LiveAmps are blink-
ing. LiveAmp is now connected with Recorder.

! The LiveAmps within Range window lists any
LiveAmp 64 amplifiers that were detected during
the scan. 

The LiveAmp 64 is listed with the last four digits
of the master LiveAmp amplifier’s serial number.

You can find the serial number on the type plate 
at the bottom of your master LiveAmp.

CH 1 - 32 = master LiveAmp
CH 33 - 64 = slave LiveAmp

To read the serial number turn off the LiveAmp
amplifier and disconnect it from the adapter.
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6.4.6 Use the internal wireless adapter 

By default, Recorder uses the wireless adapter UBT21. To use the internal adapter of your computer
instead, do the following: 

6.4.7 LiveAmp workspace at a glance

In the workspace you specify the number of channels, sampling rate, and other hardware-related
settings. 

Note: We recommend you use the provided wireless adapters (UBT21) to ensure reli-
able data transmission. When using LiveAmp 64 one wireless adapter (UBT21) should
remain connected. 

1 Start Recorder (no amplifier connected).

2 Click on Amplifier > Wireless Settings...

3 The Wireless Settings window opens.

4 Select the check box and click OK.

You now use the internal adapter of your computer. 

Note: For the following procedure a LiveAmp 32 channel was used. Different settings
will be available when using a LiveAmp 8 channel, LiveAmp 16 channel or LiveAmp 64. 

 LiveAmp 8 can record up to 8 EEG channels and/or bipolar channels.

 LiveAmp 16 can record up to 16 EEG channels with a maximum of 8 bipolar chan-
nels.

 LiveAmp 32 can record either 32 referential EEG channels or 24 referential and 8
bipolar channels. 

 LiveAmp 64 can record either 64 unipolar channels or 56 unipolar and 8 bipolar
channels.

 ACC channels are always available.

 AUX channels are always available when a LiveAmp sensor & trigger extension is
connected.
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Pre-requisites

- LiveAmp is connected with Recorder (Connect LiveAmp 8, 16 or 32 with Recorder or Connect
LiveAmp 64 with Recorder)

- The Workspace editor is open 

- You clicked on Scan for Amplifier.

In the workspace window, you can make the following settings:

Figure 6-4. LiveAmp workspace

Sampling Rate [Hz]

Select between 250 Hz, 500 Hz and 1,000 Hz. 

Note: Maximum wireless bandwidth cannot always be guaran-
teed due to external interference. 

Sampling Rate EEG/ExG channels

1000Hz
Up to 32 channels 

(this incl. AUX and acceleration)

500Hz
32 channels or more 

(this incl. AUX and acceleration)
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6.4.8 Using sensors

When you connect sensors to LiveAmp using the Sensor and trigger extension, you must select the
Sensor and trigger extension in the workspace.

Use active/dry Electrodes Select this option when you use active or dry electrodes.

Number of Channels Select the type and specify the number of channels. 

Use sensor and trigger
extension

If you use sensors, choose this option. Specify the number of 
channels you are using (max. 8). 

Accelerometer

LiveAmp has a built-in accelerometer with three axes (x, y, z). 
You can select and deselect each axis individually. The axes 
always occupy the last three channels and are not shown in the 
channel table. 
The unit of the accelerometer is ‘g’ (=gravitational constant).

Recording to
LiveAmp Memory

If you record to the memory card of LiveAmp, select the maxi-
mum expected recording time.
Note: This setting defines how much space is prepared on the 
memory card. If your recording exceeds this setting, another part 
of the memory card is automatically prepared. Preparation takes 
several seconds. During this time no data can be written to the 
memory card. 

Channel Settings

Type: Indicates the channel type (EEG, REF, BIP or AUX). The 
channel type is automatically assigned based on the physical 
channel. For example: LiveAmp channels 1 to 24 are always ref-
erential. Channels 25 to 32 can be either referential or bipolar, 
they cannot be both. 

Name: Click to edit the name of the ‘logical channel’. If you enter 
the same name twice, an error message is shown when you want 
to proceed to the next workspace page.

Phys. Chn. : Each channel name must have one physical chan-
nel. You can assign physical channels to the logical channels in 
the first column. The physical channels do not have to be 
assigned in consecutive order.

Use Electrode Position Please refer to Using electrode position files .

Always disconnect LiveAmp from Recorder before connecting or disconnecting the
sensor and trigger extension.
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Pre-requisites

- LiveAmp is connected with Recorder

- Sensor and trigger extension is connected to LiveAmp

- Workspace editor is open

Setting the units for sensors

6.4.9 Configuring the digital port LiveAmp 8, 16 or 32

You can use up to nine trigger bits with LiveAmp 8, 16 and 32. For details refer to the LiveAmp Op-
erating instructions, chapter 7.

1 Select the check box Use sensor and trigger extension.

2 Specify the number of auxiliary channels, that you want to use
(maximum eight).

3 The channel table is updated.

The auxiliary channels are the last eight physical channels.

In the channel table, you can move a channel by drag-and-drop.

You can now rename the auxiliary channels and set different units,
gradients and offsets for the sensors.

Diff. Unit
Select Diff. Unit to you can use a different unit such as ‘C’ for Cel-
sius.

Unit Enter the required unit in the Unit column.

Gradient
Enter the gradient in mV/unit. Example: For the unit C use mV/C. 
This will describe the voltage difference in mV at a temperature 
change of one degree Celsius. The value can also be negative.

Offset
Defines the zero point. In our temperature example, this is the 
voltage in mV that the sensor returns at a temperature of 0 
degrees Celsius.
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Pre-requisites

- LiveAmp connected with Recorder (Connect LiveAmp 8, 16 or 32 with Recorder)

Optional accessories

- Trigger source connected to the trigger input of LiveAmp (1 bit) 

- Sensor and trigger extension connected to the AUX input of LiveAmp (8 bit) 

Click on Amplifier > Digital Port Settings... to open the Digital Port Settings... dialog:

Figure 6-5. LiveAmp digital port settings
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Trigger In Port

Trigger Out Port

Minimum trigger length

Please take note of the recommended minimum length of the trigger signal for various sampling
rates in the table below. Shorter signal lengths can result in faulty markers.

High Active / Low Active
 High Active: a marker is set on the rising edge. 
 Low Active: a marker is set on the falling edge. 

Type
You can change the name of the type. This name will display as 
marker in your recording.

Enable Debouncing in Milli-
second (5..50 ms)

Select this option to ignore the repetition of a marker of the same 
type and same description for a period of 5 to 50 ms.

Enable Trigger Out Port
Select to activate the Trigger Out connector on the Sensor and 
trigger extension.

Mirror Trigger In
Select this option, to make the triggers from the input available 
on the output connector (1:1).

Sync Out
Select to send a trigger at a predefined frequency. When a trigger 
is sent, a marker (SyncOut) is added to the EEG stream. 

High Active / Low Active

Select High Active or Low Active as required; you should use a 
similar logic to the type of device being synchronized. 
 High Active: a SyncOut marker is set on the rising edge. 
 Low Active: a SyncOut marker is set on the falling edge. 

Select Output (1...8) Select the required output bit from 1 to 8.

Select Sync Frequency [Hz] Select the required sync frequency from 0.1, 1, 5, 10 to 25 Hz.

Note: A trigger pulse may be generated, when you connect the trigger cable to Live-
Amp.

Sampling rate Minimum length of trigger signal

1000 Hz 2 ms

500 Hz 4 ms

250 Hz 8 ms
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6.4.10 Configuring the digital port LiveAmp 64

You can use up to ten trigger bits with LiveAmp 64. For details refer to the LiveAmp Operating in-
structions, chapter 7.

Pre-requisites

- LiveAmp 64 or simulation connected with Recorder (Connect LiveAmp 64 with Recorder)

Optional accessories

- Sensor and trigger extension connected to the AUX input of either the master or slave LiveAmp

- Trigger source connected to the trigger input of either or both LiveAmp amplifiers

Click on Amplifier > Digital Port Settings... to open the Digital Port Settings... dialog:

Figure 6-6. LiveAmp 64 digital port settings
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Trigger In Port

Trigger Out Port

Minimum trigger length

Please take note of the recommended minimum length of the trigger signal for various sampling

High Active / Low Active
 High Active: a marker is set on the rising edge. 
 Low Active: a marker is set on the falling edge. 

LiveAmp Master
Select the Bit 0 check box to enable the master LiveAmp (CH 1 - 
32) trigger

LiveAmp Slave
Select the Bit 1 check box to enable the slave LiveAmp (CH 33 - 
64) trigger

Type
You can change the name of the type. This name will display as 
marker in your recording.

Enable Debouncing in Milli-
second (5..50 ms)

Select this option to ignore the repetition of a marker of the same 
type and same description for a period of 5 to 50 ms.

Enable Trigger Out Port
Select to activate the Trigger Out connector on the Sensor and 
trigger extension.

Mirror Trigger In

Select this option, to make the triggers from the input available 
on the output connector (1:1). 
- Only triggers from the sensor trigger box will be mirrored.

- For LiveAmp 64 Trigger bit 2 is output to trigger bit 0 of trigger
out port.

Sync Out
Select to send a trigger at a predefined frequency. When a trigger 
is sent, a marker (SyncOut) is added to the EEG stream. 

High Active / Low Active

Select High Active or Low Active as required; you should use a 
similar logic to the type of device being synchronized. 
 High Active: a SyncOut marker is set on the rising edge. 
 Low Active: a SyncOut marker is set on the falling edge. 

Select Output (1...8) Select the required output bit from 1 to 8.

Select Sync Frequency [Hz] Select the required sync frequency from 0.1, 1, 5, 10 to 25 Hz.

Note: A trigger pulse may be generated, when you connect the trigger cable to Live-
Amp.
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rates in the table below. Shorter signal lengths can result in faulty markers.

6.4.11 Measure the impedances

Observe the following guidance when measuring the impedances.

Prerequisites:

- LiveAmp is connected with Recorder (Connect LiveAmp 8, 16 or 32 with Recorder or Connect
LiveAmp 64 with Recorder)

1 Prepare the cap and switch Recorder into the impedance mode. 

2 Select the impedance threshold values.

 Active/dry electrodes: in the LiveAmp console.

 Passive electrodes: in the Impedance window.

Initially, Recorder is set to the default values.

3 Minimize the impedances of the reference, ground and one data electrode.

4 Then minimize the impedances of all other electrodes.

5 To save the impedance values start recording the EEG signals ( ).

Sampling rate Minimum length of trigger signal

1000 Hz 2 ms

500 Hz 4 ms

250 Hz 8 ms

Example 1:Saving battery power

To save battery power, first prepare the electrode cap and then switch on LiveAmp.
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6.4.12 Recording procedures with LiveAmp

LiveAmp allows you to write data to different locations. Try out the procedures before you actually
record real data.

General prerequisites:

- memory card inserted

- LiveAmp connected with Recorder

- workspace created

Record to computer

1 Click on Monitor .

2 Click on Start Recording .

To stop recording, click on Stop Recording .

Record to LiveAmp

1 Click on Monitor .

2 In the LiveAmp console, click on Start .

Data is recorded to the memory card, when the battery/recording LED blinks fast.

To stop recording, click on Stop  in the LiveAmp console.

After recording, the files of the memory card must be converted with the LiveAmp File Converter. 

EEG data is written to the recording computer only. During the re-
cording LiveAmp must stay in the range of the wireless connection.
If you move LiveAmp out of the wireless range, samples will be lost.

EEG data is displayed on the recording computer and written to the
memory card of LiveAmp. If you move LiveAmp out of the wireless
range, writing the data will continue, but no data will be displayed
on the recording computer.
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Record to computer and LiveAmp

1 Click on the button Monitor .

2 In the Recorder main window, click on Start Recording .

3 In the LiveAmp console, click on Start .

Data is recorded to the memory card, when the battery/recording LED blinks fast.

To stop recording do the following:

a In the LiveAmp console, click on Stop .

b In the main window, click on Stop Recording .

After recording, the files of the memory card must be converted with the LiveAmp File Converter. 

Record to LiveAmp as holter

1 Click on Monitor .

2 In the LiveAmp console, click on Start .

Data is recorded to the memory card, when the battery/recording LED blinks fast.

3 In the main window, click on Stop Monitoring .

4 In the LiveAmp console, click on Disconnect.

The wireless LED on LiveAmp goes off after approximately 2 minutes.

To stop recording do the following:

a Switch on the wireless module by pressing the I/O button on LiveAmp for one second.

b In the LiveAmp console, click on Search for LiveAmp... and connect to the LiveAmp.

c Then click on Stop .

After recording, the files of the memory card must be converted with the LiveAmp File Converter. 

EEG data is written to the computer and the memory card of Live-
Amp. If you move LiveAmp out of the wireless range, writing data to
LiveAmp will continue. 

EEG data is written to LiveAmp, while LiveAmp is disconnected
from the recording computer. This is called the holter function of
LiveAmp.
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6.4.13 Convert the LiveAmp data

After the data acquisition, use the LiveAmp File Converter to convert the data from memory card. 

LiveAmp 8, 16 and 32

LiveAmp 8, 16 and 32 saves the EEG data and the settings of the Recorder workspace on the memory
card. These files have following names and extensions:

 Workspace: TEMP.WSP

 EEG, bipolar and trigger data: LA000001.DAT (the digit is automatically incremented)

LiveAmp 64

LiveAmp 64 saves the EEG data and the settings of the Recorder workspace on the memory card’s
of each LiveAmp 32. When using the LiveAmp 64 you will have to copy the files from the memory
card of both LiveAmps to the same folder as both files are required for compilation by File Converter. 

These files have following names and extensions:

 Workspace: TEMP.WSP

 Master LiveAmp - EEG and trigger data: LA000001.DAM (the digit is automatically incremented)

 Slave LiveAmp - EEG, bipolar and trigger data: LA000001.DAS (the digit is automatically incre-
mented)

Prepare

- Computer with BrainVision LiveAmp File Converter

Notes

- The status bars in the main window and LiveAmp console show, if data is recorded. 

- Recording Annotations, Video and pausing a recording only works for recording to
the HDD, but not the memory card.
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- Memory card inserted into recording computer

 When using the LiveAmp 64 you will have to copy the files from the memory cards of
both LiveAmps (.DAS and .MAS) to the same folder as both files are required for com-
pilation by File Converter. 

 The TEMP.WSP file does not have to be copied for any version of LiveAmp.

1 Open the LiveAmp File Converter. 
Windows start button > All Programs >  Brain-
Vision > BrainVision LiveAmp File Converter.

2 Load the EEG files.

In the line ‘LiveAmp File’, click on Select and
locate the EEG data. 
Search for the folder with your EEG data.
When using LiveAmp 64 it is essential that
files from both LiveAmps are copied to the
same folder.

3 Select the *.DAT file if using LiveAmp 8, 16 or
32 or select the *.DAM file if using LiveAmp
64 and then OK. 

4 Specify the target file. 

a In the line ‘BrainVision File’, click Select. 

b Select the target folder.

c If required, rename the file and click OK.

5 Finally, click Convert.

6 Check the conversion. 

Open the target folder and make sure that
there is the EEG file (*.EEG), header file
(*.VHDR) and marker file (*.VMRK). 
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6.4.14 Use the simulation 

If you do not have an amplifier, but want to prepare a workspace, for example, you can use the sim-
ulated amplifier. 

Prepare

- LiveAmp or LiveAmp 64 is selected in Recorder

- All LiveAmps switched off (no LiveAmp within range)

The converted EEG files can now be used in
Analyzer.

1 In the LiveAmp console, click on Search for
LiveAmps...

2 Select the Simulation amplifier.

3 Create a workspace to your needs.

You can use a workspace, created with the simulated amplifier, with a real LiveAmp amplifier.



6.4 LiveAmp amplifier       98
6.4.15 Check the functionality of LiveAmp (test signal)

The test signal mode injects a sine wave signal in all EEG channels and a square signal in the accel-
eration channels. You can also test the transmission range of LiveAmp with the test signal mode. 

Prerequisites

- LiveAmp connected with Recorder

- Workspace created

- No electrode cap connected

1 In the Recorder main window, click on the
button Test Signal.

The test signal is injected in the EEG chan-
nels (sine wave) and in the acceleration
channels (square wave). Additionally, a stim-
ulation marker is set every three seconds.

If a channel shows a flat line it is not working
correctly. Contact your local dealer for reme-
dy.
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6.4.16 Show connected amplifier 

When you need support, you can find helpful information in Recorder and the log files. 

Version information

Pre-requisites

- LiveAmp connected with Recorder

Log information

The log files might be required by your dealer or the support team for troubleshooting. You can find
log files for LiveAmp and general log files on your local drive. By default they are stored under: 
C:\Vision\Recorder\Log. 

1 In Recorder, click on Amplifier > Version in-
formation...

The Version Information window shows for
example the serial number (SN), Product re-
vision and firmware version.

Provide these information to the support
team or your local dealer.
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6.5 V-Amp and FirstAmp amplifiers

Both administrator mode and user mode are supported for the V-Amp and FirstAmp.

6.5.1 V-Amp workspace at a glance

Choose File > New Workspace... from the menu. 

Figure 6-7. Editing a workspace for the V-Amp/FirstAmp 

1 Click Scan for Amplifier. The amplifier connected to your computer is displayed.

2 If you select the Highspeed Mode (max. 20 kHz) box, you can select a value of 5, 10 or 20 kHz
for the sampling rate. This option is only available for four channels. If you do not select the box,
the maximum sampling rate is 2 kHz.

3 Enter the number of channels in the Number of Channels text box. 

4 Choose the sampling rate in the Sampling Rate [Hz] text box.
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5 Invert AUX Channel Polarity in Display and Raw Data File allows you to invert the display of AUX
channels. The AUX inputs are used to connect external sensors to measure temperature, skin
conductivity, etc.

Figure 6-8. AUX 1 channel not inverted (box not selected)

Figure 6-9. AUX 1 channel inverted (box selected)

You can also make the following settings:
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Figure 6-10. V-Amp, AUX channels

Additional data entry columns are available for the AUX channels in the channel table:

 If you select the box under Diff. Unit, you can use a different unit such as ‘C’ for Celsius.

 Enter the required unit in the Unit column.

 Enter the gradient in mV/unit in the Gradient column – for the unit C, for example, use mV/C. In
this example, you describe the voltage difference in mV at a temperature change of one degree
Celsius. This value can also be negative.

 The Offset defines the zero point. In our temperature example, this is the voltage in mV that the
sensor returns at a temperature of 0 degrees Celsius.

6.5.2 Configuring the digital port (marker port)

Use the trigger input connectors of the V-Amp/FirstAmp for recording events that are synchronous
with the EEG such as stimuli or test subject responses. Nine digital bit inputs and hence nine bits
are available. The first bit is numbered 0 and is located on the Trigger 2 port (jack) of the amplifier.
All the remaining bits are located on the Trigger 1 port.

You make the settings for the digital port by choosing Amplifier > Digital Port Settings...
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Figure 6-11. Configuring the digital port for the V-Amp/FirstAmp

You can choose whether the signals are interpreted as high-active (5 V = active) or low-active (0 V
= active).

In the Enabled column of the table, you can specify whether the associated bit is to be evaluated or
not. In the Type column, you can specify what time marker type each bit represents. It is also possi-
ble to assign the same type to several different bits.

In principle, you can freely select the name of the type. You should, however, note that Recorder and
Analyzer use color coding for certain types. For this reason, it is advisable to choose ‘Stimulus’ and
‘Response’ for stimulus and response inputs respectively.

The description of the markers is encoded automatically. The following procedure is used: The first
occurrence of the type in the table is weighted with value 1, the second occurrence with value 2, the
third with value 4 etc. For every data point, all set bits of a type are added together according to this
pattern. The resultant number is combined with the initial letter of the type, resulting in the descrip-
tion.

Example

Bit 4 through bit 7 are of the type ‘Response’. If bits 5 and 7 are set, this results in a marker of the 
type ‘Response’ with the description ‘R 10’. Bit 5 has a value of 2 and bit 7 a value of 8. The total is 
10. The consequence of this logic is that only markers of different types can be detected at any one 
time. If you want to record different responses simultaneously, you can do so by decoding the num-
ber values subsequently in the analysis, by assigning a separate marker to every bit. Alternatively, 
you can assign a separate type to every bit in the table.
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Note that a suitable ratio between the length of the trigger signal and the sampling rate is required
to ensure that the TTL trigger signals are recorded without errors. You make the appropriate settings
when you set up the workspace.

Please take note of the recommended minimum length of the trigger signal for various sampling
rates in the table below. Shorter signal lengths can result in errored markers.

You can view the current state of the digital port for test purposes in the Current State box.

Another option available in the Digital Port Settings dialog box is debouncing. If you select the En-
able Debouncing in Millisecond (5..50 ms) box, repetition of a marker of the same type and same
description is ignored for a period of 5 through 50 ms.

 

Sampling rate Minimum length of trigger signal

100 Hz 25.0 ms

250 Hz 10.0 ms

500 Hz 5.0 ms

1000 Hz 2.5 ms

2000 Hz 2.5 ms

5000 Hz 0.5 ms

10000 Hz 0.5 ms

20000 Hz 0.5 ms
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6.6 QuickAmp

If you use a QuickAmp amplifier with the Windows® 7 64-bit operating system you need to install
the driver separately. 

6.6.1 QuickAmp workspace at a glance

Choose File > New Workspace... from the menu. 

Click Scan for Amplifiers. The QuickAmp amplifiers connected to your computer are shown under
Connected Amplifier(s).

Enter the number of channels in the Number of Channels text box. Choose the sampling rate in the
Sampling Rate [Hz] text box.
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Adjusting the sensors for the AUX inputs

If you wish to use external sensors to measure temperature, skin conductivity etc. you can carry out
the appropriate adaptations at this point. The AUX channels are always the last four channels of the
amplifier. This means that for a QuickAmp40, you use the physical channels 37 through 40, for a
QuickAmp72 channels 69 through 72 and for a QuickAmp128 channels 125 through 128.

Figure 6-12. QuickAmp, AUX channels

Additional data entry columns are available for the AUX channels in the channel table:

 If you select the box under Diff. Unit, you can use a different unit such as ‘C’ for Celsius.

 Enter the required unit in the Unit column.

 Enter the gradient in mV/unit in the Gradient column – for the unit C, for example, use mV/C. In
this example, you describe the voltage difference in mV at a temperature change of one degree
Celsius. This value can also be negative.

 The Offset defines the zero point. In our temperature example, this is the voltage in mV that the
sensor returns at a temperature of 0 degrees Celsius.
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6.6.2 Using the test signal

To display and record click on the Test Signal  button. A square wave signal is generated and dis-
played.

To configure the test signal for the QuickAmp, choose Amplifier > Test Signal Values... from the
menu.

Figure 6-13. Selecting a test signal for the QuickAmp

6.6.3 Configuring the digital port

Use the digital ports DIO0 through DIO7 for recording events that are synchronous with the EEG such
as stimuli or test subject responses. The designations DIO0 through DIO7 relate to the bit number,
with the first bit being designated with 0.

You make the settings for the digital port by choosing Amplifier > Digital Port Settings... from the
menu.

Note that the contents of the dialog box differ in respect of the debouncing parameters with the
QuickAmp PCI and QuickAmp USB.

Note

The test signal is not calibrated. It is only an approximate value.
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Figure 6-14. Configuring the digital port for the QuickAmp PCI

Figure 6-15. Configuring the digital port for the QuickAmp USB

You can choose whether the signals are interpreted as high-active (5 V = active) or low-active (0 V
= active).

In the Enabled column of the table, you can specify whether the associated bit is to be evaluated or
not. In the Type column, you can specify what time marker type each bit represents. It is also possi-
ble to assign the same type to several different bits.

In principle, you can freely select the name of the type. You should, however, note that the Recorder
and Analyzer use color coding for certain types. For this reason, it is advisable to choose ‘Stimulus’
and ‘Response’ for stimulus and response inputs respectively.

The description of the markers is encoded automatically. The following procedure is used: The first
occurrence of the type in the table is weighted with value 1, the second occurrence with value 2, the
third with value 4 etc. For every data point, all set bits of a type are added together according to this
pattern. The resultant number is combined with the initial letter of the type, resulting in the descrip-
tion.
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Example

Bit 4 through bit 7 are of the type ‘Response’. If bits 5 and 7 are set, this results in a marker of the 
type ‘Response’ with the description ‘R 10’. Bit 5 has a value of 2 and bit 7 a value of 8. The total is 
10. The consequence of this logic is that only markers of different types can be detected at any one 
time. If you want to record different responses simultaneously, you can do so by decoding the num-
ber values subsequently in the analysis, by assigning a separate marker to every bit. Alternatively, 
you can assign a separate type to every bit in the table.

You can view the current state of the digital port for test purposes in the Current State box.

Another option available in the Digital Port Settings dialog box is debouncing.

 QuickAmp PCI. If you select the Enable Debouncing (suppresses repetition for 50 ms) box, rep-
etition of a marker of the same type and same description is ignored for a period of 50 ms.

 QuickAmp USB. If you select the Enable Debouncing in Millisecond (5..50 ms) box, repetition of
a marker of the same type and same description is ignored for a period of 5 through 50 ms.

   

Note 

Trigger signals must be present at least for the extent of a sampling point. This means,
for instance, that at a sampling rate of 1,000 Hz, the minimum length of the trigger sig-
nal is 1 ms and that at 500 Hz the minimum length is 2 ms, etc.
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7 General settings

7.1 Filters

Click on File > New Workspace... or File > Edit Workspace... to open the workspace wizard. 
In the wizard click on Next until you reach the dialog Software Filters.

Three filter methods are available:

 Raw Data Saving Filters

Filters are directly applied to the raw data. Use of this filter is not recommended, because this
changes the raw data. When using BrainVision Analyzer you can apply filters to the raw data. 

 Segmentation Filters

When you specify segmentation (subsequent tab of the workspace wizard) you can also set fil-
ters for the segmented data. 
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 Display Filters

This filter only has an effect on the display on your screen. When you set the filter, you can switch
it on and off during the data display of the data by clicking on the button Display Filter .

Enable Filters

You can also deactivate the paths completely by deselecting the  box
for each path

Because the filters are software filters, you can enter any values.
Nevertheless, you should take care not to set any frequencies with a
value equal to or greater than half the selected sampling rate.

Low Cutoff Filter
High Cutoff Filter

The slope for the low-cutoff filter and the high-cutoff filter  is 12 dB/
octave.

Low-cutoff filter: Filter that reduces the amplitude of low-frequency
digitized signals.

High-cutoff filter: Filter that reduces the amplitude of high-frequency
digitized signals.

Notch filter
This filters the noise of the mains line. You can choose between
50 Hz and 60 Hz. Depending on your region, the mains noise is either
50 Hz (for example, Germany) or 60 Hz (for example, USA).

Use Individual Settings
You can apply this setting to the channels as a group or to individual
channels by selecting or deselecting the box. 

Copy master settings
Copies the settings from above into the channel table. This button is
only active, when you select the check box Use Individual Settings.
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7.2 Segmentation and averaging

Recorder can segment or average your data based on time markers such as stimulus markers or re-
action markers. Segmentation is always a preliminary step in averaging. Both procedures will there-
fore be presented together in this section. You can save the segmented or averaged data in parallel
with the raw data. You can also use segmentation and averaging to ascertain whether a visible
evoked potential is formed. In this case you do not store the segments or the average. It is also pos-
sible to save segmented data or the averaged data only, and to dispense with raw data.

Segmentation / Averaging dialog at a glance

Click on File > New Workspace... or File > Edit Workspace... to open the workspace wizard. 
In the wizard click on Next until you reach the dialog Segmentation/Averaging.

1 Enables segmentation/averaging and manage segmentation groups.

2 Specify the parameters for the corresponding group.

NEW
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7.2.1 Setup segmentation / averaging

Enable segmentation/averaging

Create a segmentation/averaging group

A segmentation group contains the parameters for one or more markers. You can define up to 16
groups with different parameters. During recording each group will be displayed in a separate win-
dow and you can save separate files. Initially the Segment./Avg. Groups box is empty. 

 Select the check box Enable Segmentation / Averaging.

 Choose Save Raw Data to save the raw data together with the segmented data.

Note: This option is recommended, because it allows you to change the averaging parameters
later.

Next, create a segmentation group.

1 Click New... to create a new group. 

2 Enter a meaningful name of the group and click on OK.

The group name will be part of the file name.

Next, select the markers.
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Select the segmentation/averaging markers

In the Markers group you select the markers that describe the relevant segments for the current
group. The box is initially empty.

You can use all makers (click Use All Markers) or select individual markers.

1 To use individual markers, click Select...

2 In the Select Segmentation Markers dialog, do the following: 

 choose a marker type from the list Type on the left. 

 Select the marker(s) from the list Descriptions.

 Click on the Add>> button.

 When finished click on OK.

 To remove a marker from this list, select the marker and click Remove. 

Next specify the interval (optional).

Note on the markers

The number of available markers is retrieved from the digital port settings (Configuration
> Digital Port settings...).

In the digital port settings dialog you specify the trigger bits. Each bit has two states - on
or off. Recorder combines all bits of the same type which results in 2n markers. The state
in which all bits are ‘off’ is ignored. Thus, if you select three stimulus bits in the digital port
settings dialog there will be seven stimulus markers (23 - 1 = 7). 
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Specify the interval

An Interval specifies the time before and after the occurrence of a marker.

You can set the relative positions of the segment interval based on time or based on data points.

1 Choose the desired method (Based on Time or Based on Data
Points).

2 Specify the Start and End of the interval. 

 Alternatively, you can specify the Duration of the interval,
which will change the end of the interval.

Next set the artifact rejection. 

Note

Do not specify a too large interval. Each interval only contains one marker by default.
Subsequent markers are ignored. If the interval is too large a second marker could oc-
cur which is then ignored.



7.2 Segmentation and averaging       116
Reject segments with artifacts

The Artifact Rejection group box allows you to examine the individual
segments for various artifacts, or to carry out a quality select.

You can specify the artifact rejection criteria, so that the segments are
rejected automatically, or you can reject artifacts manually. 

When you choose the manual option Allow Manual Rejection with
Space Bar (Applies to all Groups), you can reject any segment by
pressing the space bar, until the next segment is shown. 

If you work with several segmentation/averaging groups, the rejection criteria are applied to the
segments in the active window. The segments in the inactive windows that overlap the rejected seg-
ment are also rejected. However, only the most recently accepted segment in a group is checked.

To set artifact rejection criteria, click Change... The Artifact Rejection Criteria dialog opens.

Gradient Criterion
Select and specify the maximum permitted difference in microvolt 
between two neighboring sampling points. If this value is exceeded, 
the segment is rejected. 

Difference Criterion
Select and specify the maximum permitted difference in voltage 
between the lowest and highest value within the region to be tested.

Amplitude Criterion
Select and specify the minimum and maximum permitted amplitude in 
microvolt.
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Low Activity Criterion

Selected to check if a minimum amount of activity has occurred within 
a defined time period. 
Enter the minimum activity in microvolt and the length of the interval 
within which the activity must not fall below the specified value.
Example: If you specify a period of five milliseconds, the program 
checks whether there is no change of voltage of the selected magni-
tude over a period of five milliseconds within the test interval. 

Test Whole Segment
Select to check the entire segment for artifacts. Alternatively, specify 
the length of the segment to be checked.

 Untested Channels Specify the channels that must not be tested. Click Select... and 
choose the channels that should be ignored during artifact checking.

Notes

 All segments that are detected as having artifacts are excluded from segmenta-
tion/averaging.

 It is particularly advisable to exclude ECG channels from artifact identification. 

 In Recorder, unlike in the Analyzer, you must select the channels that are not to be
tested.
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Baseline Correction and Averaging

Baseline correction when enabled adjusts the baseline of the segment on prestimulus (Based on
Prestimulus radio button) or on the whole segment (Based on the whole Segment radio button). 

Figure 7-1. Enable Baseline Correction

Averaging allows you to specify whether the data is to be averaged (Enable Averaging check box
selected) or not. 

 If Averaging is enabled then Baseline Correction is applied to the averaged data. 

 If Averaging is disabled then Baseline Correction is applied to the single segment. 

Figure 7-2. Enable Averaging

NEW
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Other settings

 Limited Number of Segments allows you to limit the number of segments that you want to 
record during segmentation or include in averaging.

Frame Color
allows you to select a frame color for the group in order to iden-
tify the associated data window.
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Saving options

Save Data
By selecting this option the data is saved when you click the button
Record  in the toolbar

File Name Prefix

Enter a file name in the  text box. The group name and a file exten-
sion are added to the name that you enter here. 

Insert ‘$n’ as a placeholder for the raw data file name. 

Resulting File Name The name that is formed is shown under .

 Use Separate Data Folder
If you do not select the box, the previously defined raw data folder
is used. Otherwise, select a folder for the group.
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Using a static overlay

A static overlay is an average that has already been recorded with Recorder or that has been export-
ed from Analyzer using the Generic Data Export component.

1 Select the box Static Overlay.
You must assign the static overlay to a segmentation/averaging group.

2 Choose a saved overlay using Browsing File Name...

Static overlay is applied to the data.

Note

 The sampling rate and segmentation length (prestimulus and poststimulus inter-
vals) must match the setting in the Recorder workspace.
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7.2.2 Viewing segmented/averaged data

Click the button Monitor .

The monitoring window opens.

About the data display

The left-hand pane (monitoring window) contains the recorded raw EEG data or shows a dynamic
display of the raw data. The right-hand pane contains the segmentation or averaging groups. Tabs
allow you to switch between the individual groups. You can change the ratio between the monitor-
ing window and the segmentation windows with the mouse.

Figure 7-3. Switching between groups using tabs

You can do the following

 In the segmentation tab the curves are shown in red if the segment does not match the artifact
criteria. This enables you to check the criteria easily prior to recording data.
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 If you have specified the manual artifact rejection, you can now use the space bar during record-
ing to subsequently reject segments which have not automatically been identified as having ar-
tifacts.

 There are tabs beneath the group windows. These enable you to quickly bring a group window
into the foreground.

 Right-clicking in a data window and selecting a montage type from the context menu allows you
to select a new montage for this window.

 You can arrange the group windows in different ways with the toolbar buttons below:

 Cascade Windows cascades all the open windows one after another.

 Tile Windows arranges the windows next to each other.

 Tile Windows arranges the windows one above the other.
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7.2.3 Recording segmented/averaged data

Click the button Record  in the toolbar. 

The Save Data dialog opens. This allows you to check and change the parameters originally
specified for the raw data and for every group.

After clicking on Save:

The sections of the status bar in the individual groups now show the number of segments (Total
Segs.) and the number of accepted segments (Accepted Segs.) in addition to the group status
and the current montage. In addition, the EEG file name is shown and the remaining storage
space in hours, minutes and seconds is shown under Free Space. Note that this refers to the ca-
pacity that would be available if only the relevant group were stored.

 

Comment Enter a comment. The comment is saved in the EEG file. 

 Base File Name
Enter a base name for the raw file. You can also use the $n placeholder. Wher-
ever this placeholder occurs, it is replaced by the name of the raw file. Then
click Save. Recorder switches to save mode.

File table

A file name is proposed which you can either accept or change. You can also
specify whether the raw data and the various groups are to be saved (Save
check box), what folder the data is to be saved in (Browse button), and the file
name (File name column).
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7.3 Montages

Montages enable channels to be reconnected on a software basis or new voltage reference points
to be assigned to the channels.

Montages allow you to optimize the display of data by, for example, grouping together frontal elec-
trodes in one montage and occipital electrodes in another. When one of these montages is selected,
only those channels that have been assigned to it are displayed. The sequence of channels can also
be changed in a montage so that channels which were originally apart can be shown next to each
other. A channel can also occur more than once in a montage.

Montages are used for visualization purposes only, i.e. the resulting data only exists temporarily
and the original data is not changed.

7.3.1 Create a montage

1 To create a new montage, choose Display Montage > New... from
the menu. 

The New Montage dialog box opens. 

2 Select the type of reference to be used in the new montage.

 Original: No new reference is calculated. The original reference
is only used to group channels or optimize the way they are pre-
sented. To begin with, we recommend that you choose this ref-
erence type.

 Average: The average reference is calculated by averaging all
selected channels.

 Bipolar: The differences between different channels are calcu-
lated for a bipolar connection.

3 Click OK when you have selected a reference type. 

This opens the Edit dialog box. 
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After you have edited the montage, the system prompts you to enter a name under which you
wish to save the montage. You can also enter a new name and thus derive a new montage from
an existing one.

Chn (+)  -  Chn (-)

Chn (+) contains the channels and Chn (-) the reference channels. 
The column Chn (-) can only be modified if you have selected the 
Bipolar montage. Otherwise the column Chn (-) is filled in automati-
cally.
You can enter the channel names manually or select a channel from 
the drop-down list. 

Insert Line
inserts a new line above the current line. This button is enabled as 
soon as you have entered text in the first box of the first channel.

Remove Line removes the current line provided that it is not the last line.

Insert Current Channels

copies all the channels of the current setup into the montage in their 
original sequence. This allows you, for instance, to construct the 
montage you require much more quickly by removing and inserting 
individual channels. This button is enabled if the montage list is 
empty.

Remove All
removes the entire contents of a montage. You are prompted to con-
firm whether you wish this to be done. This button is enabled as 
soon as you have completed an entry.

Arrange for Grid
Views...

opens a dialog box in which you can arrange the channels for grid 
views. 
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7.3.2 Arranging the montages in the grid view

Grid views are used when representing segmented or averaged data. In the grid view the channels
are arranged in a grid. A preset pattern is used for the default montage. For other montages, you can
use the Arrange for Grid Views... function to freely define the pattern. You can specify the desired
number of rows and columns in the channel grid. Click the Refresh button to update the grid pattern
that is shown. You can use the mouse to freely arrange the channels and the spaces between them.

Figure 7-4. Creating a grid view

7.3.3 Calling a montage

To call a newly created montage, switch Recorder to monitoring mode. Open the Display Montage
menu. This menu has now been extended to include the name of your new montage (Figure 7-4).
Choose the new montage. The EEG is displayed using the montage. To display the default montage
again, simply call it from the Display Montage menu.

Figure 7-5. Calling a montage
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If you have created a montage that does not contain any channels of the current setup, you cannot
call this montage during monitoring.

7.3.4 Switching between montages

You can assign specific keyboard shortcuts to montages to allow you
to switch between them quickly. Pressing these keyboard shortcuts
activates the montages. You can choose Display Montages > Options
to assign the keyboard shortcuts Ctrl-2 to Ctrl-0 to the existing mon-
tages as you wish. Ctrl-1 is reserved for the default montage.

If you have defined one or more segmentation or averaging groups,
you can use the keyboard shortcuts Ctrl-Shift-1 through Ctrl-Shift-0 to
select the montage for the current group window in the same way. Al-
ternatively, you can call a new montage by right-clicking in a data win-
dow.
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7.4 Annotations

You have the option of adding comments to the recorded EEG. These are displayed as markers in
the lower marker area during recording (marker type: ‘Comment’). You can enter your comments as
freely-definable text or as predefined text.

7.4.1 Enter free text

You enter freely-definable text by clicking the button An-
notation  in the toolbar. You can also use the keyboard
shortcut Ctrl-A. The Annotation dialog box opens and a
marker with three question marks is added to the marker
area (below the EEG curves). Enter your text in the dialog
box. This then replaces the question marks.

7.4.2 Define Annotations

You can specify annotations and insert these by pressing a key on your keyboard. This is a fast way
of inserting annotations. 

Pre-requisites:

- Administrator privileges or corresponding user rights

Close monitoring mode and choose Configuration > Predefined Annotations...

The dialog Predefined Annotations opens.

You can enter up to ten predefined annotations. You in-
sert these annotations in the EEG data stream by pressing
the corresponding keys 1 to 0 on your keyboard.
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8 Impedance measurement

8.1 Using passive electrodes

Pre-requisites

- You have selected Passive Electrodes in Configuration > Preferences... (see 4.3 Set global pro-
gram preferences).

Click the button Impedance Check  in the toolbar.

The Impedance Check View window opens. 

Note: Always prepare all channels before acquiring data and only then switch Recorder
to impedance mode to check the impedances of the channels. 
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Impedance
Check View

Schematic view of a head with the electrodes. 

 Color of electrodes: indicates the impedance value. By hovering the
mouse over an electrode, the value is shown.

 Position of electrodes: 

 The electrodes are shown on their correct positions, if the electrodes are
named according to the 10-10 or 10-20 system or if you have loaded an elec-
trode position file (*.BVEF). 

 The electrodes are shown in the top right corner, if the electrodes are not
named our if you didn’t load an electrode position file.

 The impedance view can show up to 256 standard positions.

You can change the position of the electrodes with drag-and-drop (left-click on the
electrode, hold the mouse button and move the electrode with the mouse). Click on
Reset Positions... to reset the electrodes to their initial positions.

Settings
panel

You can select an electrode group for the impedance view.  The
available groups depend on the amplifier you are using. 

You can choose different impedance ranges (measurement
ranges). The electrodes in the Impedance Check View indicate
the impedance by the color , according to the selected range.

You can specify the measurement ranges by clicking on the
button Settings (if available).

If you are using a large number of electrodes, you can use the
slider control to select the region of the head to be shown. 

A red square shows the zoom region. You can move the square
with the mouse. 

Note: The font size is not automatically adjusted in zoom
mode.

Settings
button

You can set the preferences for the Impedance Check View by
clicking on settings. (Refer to Set preferences for the imped-
ance check view.)
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8.1.1 Set preferences for the impedance check view 

Click on the button Settings button

The Impedance Check Settings dialog opens. 

Ranges
For each electrode group, you can select up to ten measurement
ranges.

Impedance Color Coding

You can choose a continuous gradient in which the impedances
from minimum to maximum are shown. 

Discrete Color Steps: Instead of the gradient you can specify steps
for showing the color-coded impedance values. Enter a value in
the text box.

Electrode Label

You can edit the electrode label as it is shown in the Impedance
Check View. 

You can change the font by clicking on the button Select Font...

By selecting Display Physical Channel Number the
numbers of the physical channels are shown in addi-
tion to the position.
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Background Image

You can replace the default background (representation of a head)
by any bitmap image. To load the bitmap file, select the Use Bit-
map box. If the bitmap file you have selected does not exist or if it
has an invalid format, the standard background is used automati-
cally.

Note that you can move the electrode positions on the horizontal
plane, because the default background uses an ‘isotropic’ repre-
sentation. This means that any changes to the ratio between the
height and width of the display window are ignored and the head
remains round. In contrast to this, the bitmap always fills the en-
tire window and the electrodes retain their relative positions on
the bitmap.
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8.2 Using active electrodes with the actiCAP ControlBox

Note: This section refers to users of BrainAmp, V-Amp and QuickAmp. 

Pre-requisites 

- actiCAP Control Software is installed

- You have selected Use actiCAP Control Software in Configuration > Preferences... (see 4.3 Set
global program preferences)

- Electrodes are connected and prepared

Click the button Impedance Check   in the toolbar. 

The Impedance Check View opens. 
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Settings panel

Good level: Impedance values below this level are good.
Bad level: Impedance values above this level are bad.
Values between these ‘threshold’ levels are acceptable. 
Timeout specify the time during which impedance measurement is active
(default: five minutes). After this period the actiCAP ControlBox automati-
cally switches back to acquisition mode. 

Next electrodes block button is available, if you are using more than two ac-
tiCAP electrode branches or more than 64 electrodes. You measure the elec-
trodes in blocks of 32 electrodes. To measure the impedances of the next
electrode group click Next electrodes block.

Use Scaling: A color scale is used to display the impedances. The color
scale consists of three areas: The topmost area displays the bad level and
the bottom area the good level. The middle area of the color scale rep-
resents the transition between good level and bad level.
The reference electrode and the ground electrode are displayed separately.
The color used to display these two electrodes is also based on the color
scale.

Reset Posi-
tions...

You can change the position of the electrodes with drag-and-drop (left-click
on the electrode, hold the mouse button and move the electrode with the
mouse). Click on Reset Positions... to reset the electrodes to their initial po-
sitions.

Impedance
Check View

Schematic view of a head with the electrodes. 

 The color of the electrodes indicates the impedance val-
ue. By hovering the mouse over an electrode, the value
is shown.

 If your electrodes are numbered according to the 10-10
or 10-20 system, they are shown on the correct position. 

 If the electrodes are not numbered, they are shown at the top right of the
window.

 The impedance view can show up to 256 standard positions.
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8.3 Saving the impedance values

The impedances are saved together with your EEG data. 

Pre-requisites

- Impedance measurement is ongoing

- Impedances are measured

Do one of the following to save the impedances:

 Start Recording immediately

 During impedance measurement click on the button Record . 

This starts the EEG recording, for which a header file, EEG file and marker file is created. The
impedance values are written into the header file (*.VHDR).

 Start Recording after a break

 During impedance measurement click on the button Stop Monitoring . 

This stops the impedance measurement. You can now, for example, move the test subject into
another room. , don’t close Recorder or change the workspace.

 When the subject is in its final position click on the  button Record . 

This starts the EEG recording, for which a header file, EEG file and marker file is created. The
impedance values are written into the header file (*.VHDR).

If you have changed the positions of the electrodes, the program prompts you to save these
changes. The electrode positions are assigned to the current workspace.

Note: If you close Recorder or edit the workspace the impedance values are lost. 
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9 Using actiCAP ControlBox

A special interface might be required to connect active electrodes to your amplifier. Below you will
find a list of the required interfaces between the active electrodes and the amplifier.

Interface between amplifier and active electrodes

Note: When your amplifier requires the actiCAP ControlBox (including the actiCAP Con-
trolSoftware), you must change settings in Recorder. 

Amplifier Interface

BrainAmp actiCAP ControlBox  and actiCAP ControlSoftware (1.2.1.0 or 
later)

QuickAmp USB actiCAP ControlBox and actiCAP ControlSoftware (1.2.1.0 or 
later)

V-Amp  without multi-way plug actiCAP ControlBox and actiCAP ControlSoftware (1.2.1.0 or 
later)

V-Amp with multi-way plug ImpBox for impedance measurement

actiCHamp None 

LiveAmp None
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9.1 Select the active electrodes

For amplifiers that require the actiCAP ControlBox, you must change the general preferences in Re-
corder first. 

1 Start Recorder in administrator mode or with the corresponding user rights.

2 Choose Configuration > Preferences... 

The Preferences dialog opens. Click on the tab Passive/Active Electrodes.

9.2 Use the actiCAP ControlBox

Pre-requisites

- amplifier selected

- electrodes connected to actiCAP ControlBox

- actiCAP ControlBox connected to amplifier

Use actiCAP Control Software Select if you use active electrodes with the actiCAP ControlBox. 

Detect Invalid Impedances
A message is shown where you can allow too high impedance 
values.

Use actiCAP Test Signal
When selected, the button Test Signal in the Recorder toolbar 
is disabled, and you use the Test button on the actiCAP Con-
trolBox. 

Note: If you are using a USB hub, do not use the actiCAP active electrode system and
the amplifier on the same USB hub. Use a separate USB hub for the amplifier and the
actiCAP.
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- Workspace created

1 Connect the actiCAP ControlBox to a USB port of your computer. 

2 Start Recorder in monitoring mode. 

3 Press a button on the actiCAP ControlBox to switch the mode, for example Impedance. 

Recorder also switches to the corresponding mode. Similarly, when you switch Recorder to a par-
ticular mode, the corresponding control button on the actiCAP ControlBox lights up.

Markers are set in the EEG, for example in order to indicate changes of mode.

Understanding the markers

The following markers can be set:

no USB Connection to actiCAP
This marker is set, if you have selected Use actiCAP Control
Software in the Preferences dialog, but use the actiCAP Con-
trolBox with rechargeable batteries.

actiCAP USB Power On

When you press the button Power  of the actiCAP Control-
Box. This marker indicates that the actiCAP ControlBox is in
acquisition mode and is sending data to the Recorder.

actiCAP Active Shield On

actiCAP Active Shield Off

You can switch the active shielding mode on and off by press-
ing the button Active Shield  on the actiCAP ControlBox.
The marker shows the time when the Active Shield mode was
activated or deactivated. 

actiCAP Test On

If you have selected the Use actiCAP Test Signal box in the
Preferences dialog, the marker is set when you press the but-
ton Test  on the actiCAP ControlBox.
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9.3 Testing the active electrodes

You can check if  the active electrodes are working properly.

Test On

Test Off

If you did not select Use actiCAP Test Signal and press the
button Test  on the actiCAP ControlBox while Recorder is in
monitoring mode or test mode, the actiCAP ControlBox briefly
switches to test mode. Recorder automatically switches it
back to acquisition mode. The two markers are written in
quick succession.

actiCAP Data On

If you start the test signal mode in the Recorder, and you have
not selected the Use actiCAP Test Signal box (which means
you are using the amplifier's test signal), the ‘actiCAP Data
On’ marker is set.

actiCAP USB Power Off

When you press the button Power  of the actiCAP Control-
Box to switch it off, the ‘actiCAP USB Power Off’ marker is set.

1 Click on Configuration > Preferences...

2 Open the tab Passive/Active Electrodes.

3 Select Use actiCAP ControlSoftware.
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4 Select the check box Use actiCAP Test Signal. 

Otherwise, the test signal is supplied by the amplifier when you run a function test.

If you are using the test signal of the actiCAP active electrode system, the button Test Signal
 in the toolbar of the Recorder and the menu item Amplifier > Test Signal Values… are dis-

abled.

Note

If you are using a QuickAmp with the actiCAP active
electrode system, you cannot obtain the actiCAP
test signal.
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10 View options

10.4 Switch off a channel

To block a channel and thus suppress the signal received, right-click the required channel name.
This opens a context menu. Choose Switch Off Channel <XXX> from this menu. The channel is
blocked and the channel name and EEG curve are highlighted in red.

To reactivate the channel, repeat the process and choose Switch On Channel <XXX> from the menu.

10.5 Display a single channel

To select a channel, simply click the channel name. A selected channel is highlighted in blue. If you
click a channel again, the channel is deselected. You can select one or more channels of the EEG
and then zoom the display into these channels, for instance.

If you click the Next Group  or Previous Group  button to show different channels of the EEG,
your selection is retained. If you click the Decrease Channels  or Increase Channels  button to
change the number of channels shown, your selection is also retained. 

By double-clicking a channel name you can display the corresponding channel separately.
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10.6 Display selected channels

To display multiple channels separately, click once on each required channel name in sequence.
Then double-click the last of the required channels. If you double-click a channel name again, the
display returns to how it was before.

The selection results in the following channel display:



10  View options         144
10.7 Display channels in scientific view

In the scientific view, the channels are displayed in a coordinate system with time and amplitude
axes.  The view is opened in a tab to the left of the main view. 

To open the scientific view, switch to the standard montage in monitoring mode. Only in this mode
are you able to specify the default settings for your project. Proceed as follows to open the scientific
view:

1 Select and open the channel (not available during re-
cording).

Right-click the required channel name (for example Fp2)
and then choose Display this channel in new tab from
the context menu. This opens a new tab at the right-
hand edge of the Recorder window with the selected
channel displayed.

 You can rename the tab

Right-click on the tab label and choose Edit tab label. 

Enter a name in the Edit Tab Name dialog and click OK.

 You can also display several different channels in a sin-
gle tab. To do this, first left-click the individual channels.
Then, right-click one of them and choose Display these
channels in new tab.

You can adjust the scaling of the axes. 
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10.7.1 Change the scaling and display

You can change the scaling for the tabs as follows:

 Click on the buttons on the right to change the scaling, amplitudes and the layout of the tabs: 

 If you want to scale the active tab more precisely, you can enter the values manually. To do this,
proceed as follows:

 Set the scaling preferences. Alongside individual settings for the tabs, you can set display pref-
erences for the scientific view. Do the following:

a Right-click and select Tab Settings.
The Tab Settings dialog opens.

b Change the settings of amplitude
and time axes.

c Click on Apply to apply the settings.

If the input is invalid, a message with the permitted values appears.

1 Open the Configuration > Preferences...

2 Click on Set Default Scaling Parameters for Tabs... to define the scaling for the amplitude and
time axes globally for the scientific view. The same values are then used for all the tabs.

The Set and Restore Default buttons are inactive because they are only required for individual
axis scaling.

These settings only apply to new tabs. The settings for open tabs will not be modified.
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10.7.2 Saving the view

You prepare your project in monitoring mode. This is where you can save the way channels are dis-
played in tabs and the settings for the time and amplitude axes. 

To save the appearance of the display, you simply have to stop monitoring mode and, if necessary,
the standard montage (1). Recorder then asks whether you want to save the settings (2).

Figure 10-1. Saving the tab layout
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10.7.3 Closing tabs

Proceed as follows to close the tabs in the scientific view:

a Click on X in the menu bar. 

b Right-click on the tab and select Remove this tab.

Figure 10-2. Closing tabs

Note

If you click on Remove this tab of an inactive tab then the active tab is closed!
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11 Video Recorder

The BrainVision Video Recorder allows you to record video data concurrently with your EEG record-
ing.

Video Recorder can only be used if you have already purchased a Video sublicense that you must
install in addition to Recorder. 

You will find details on installing sublicenses in Appendix B.

If you purchased sublicenses at the same time as you purchased Recorder, the sublicense file is in-
cluded on a USB data carrier supplied with the software. Sublicenses that are purchased subse-
quently can be downloaded from the Brain Products website. You will find details on downloading
sublicenses in Appendix B.

To check whether you have a USB dongle with Video option, choose Help > About BrainVision Re-
corder... from the Recorder menu. If you have a USB dongle with Video option, the line Vision Video
appears under Sublicenses.

Figure 11-1. Dongle with sublicense for the Video Recorder
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11.1 Installing the Video Recorder and codec

Pre-requisites

- computer with FireWire port

1 Insert the Application Suite USB (for details please refer to Chapter 1).

2 Click on Install BrainVision Recorder & Video Recorder in the welcome screen.

3 Click on the Install Video Recorder button in the bottom right corner.

4 On the following screen, click on Install BrainVision Video Recorder and follow the instructions
of the installation wizard.

After installing Video Recorder, install the codec supplied. The codec is used to compress the
video data. 

5 Click on Go to video codec. This opens a folder containing the installation program for the video
codec.

6 Run the program file ‘LEADMCMPCodec.exe’ to start the installation and follow the instructions
of the installation wizard.

Note: You will find the serial number in your product documentation.

7 To use the video codec in the Video Recorder, you must select the codec in the Recorder's pro-
gram settings. These settings are described in Section 11.2.

In the video settings, select the entry for LEAD Video for Windows (VFW) Codec from the Select
Video Codec drop-down list. Depending on your system configuration, this will be displayed as
either ‘LEAD MCMP/MJPEG Codec (2.0) (VFW)’ or ‘LEAD MCMP/MJPEG Codec (VFW)’. Any other
LEAD codecs that may be present in the list are not suitable for the operation of the Video Re-
corder.

8 Connect the video camera to the computer and switch it on.

Note: Some video cameras with a video tape inserted switch over to standby mode after a set
time. Since we store the data directly in the computer, no video tape is required.
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11.2 Configuring the Video Recorder

To configure Video Recorder, open Recorder and choose Configuration > Preferences... With the in-
stallation of Video Recorder the tab Vision Video is added to the Preferences dialog. You enable syn-
chronous video recording by selecting the Enable Vision Video box.

Figure 11-2. Video settings and codec selection

Video settings

Click the Vision Video Recorder Settings... button, for the following settings:

Select Video Device: choose the installed video camera from a drop-down list. 

By clicking on Select Video Device you can change the camera properties.

Figure 11-3. Video settings and codec selection
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Video Size sets the resolution of the video data. The resolution depends on the video camera used.
If you click the  button, Recorder opens an interface to DirectX® (Figure 11-4) that allows you
to configure the video format. (This button is not available if your camera does not support different
resolutions.)

Figure 11-4. Configuring the video format

You can select a codec by clicking Select Video Codec. 

Select the entry for LEAD Video for Windows (VFW) Codec from the Select Video Codec drop-down
list in order to enable the supplied LEAD codec. Depending on your system configuration, this will
be displayed as either ‘LEAD MCMP/MJPEG Codec (2.0) (VFW)’ or ‘LEAD MCMP/MJPEG Codec (VFW)’
in the list. Any other LEAD codecs that may be present in the list are not suitable for the operation
of the Video Recorder. The procedure for installing the supplied LEAD codec is explained in
Section 11.1.

The entry for the supplied LEAD codec in the Select Video Codec list is not updated by the LEAD Co-
dec Installer if you are updating an older existing installation of the codec. If you have run the cur-
rent LEAD Codec Installer then version 2.0 of the codec is active in your system even if the older
codec designation is still displayed in the list. You can see that version 2.0 is active by selecting this
codec and then clicking the Video Codec Settings... button to open the settings dialog box for the
codec. Version number 2.0 is displayed in the title bar.

You can use Video Codec Settings... to set the optimum balance between image quality and video
file size. Experiment with different settings by recording part of an EEG in conjunction with the Video

Note: Recorder only supports changes to the output size. None of the other parameters
in the dialog box are currently supported.

Note: Most of codecs offered are not suitable for real time recording. You should there-
fore choose the supplied codec or one that you know meets the requirements.
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Recorder and looking at the resulting quality and file size. For debugging purposes, choose the co-
dec <None>. In this case the video data is not compressed.

You should, however, select this option for test purposes only.

Show Time On Video shows the date and time on the video. If you select the Disable Preview Scale
box, you cannot change the size of the video window.

Audio settings

Select the Capture Audio box if you also wish to record audio information.

Select Audio Device is used to select the audio recording device.

If you have connected analog audio devices, Select Audio Input allows you to select between differ-
ent input options (such as line-in, microphone, phone). However, we recommend that you use dig-
ital audio equipment.

11.3 Combined EEG/video recording

After you have selected a suitable codec, switch Recorder to monitoring mode. A video window
opens in addition to the data display in Recorder. This shows the current video data.

Figure 11-5. Combined EEG/video recording
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You can move and resize the video window.

Now record part of an EEG, for example 10 seconds. Make sure that the video image does not dis-
appear. If you pan with the camera, this should also be visible after a short delay of less than a sec-
ond. If not, the codec used is not suitable.

An offset of the displayed video data to the EEG data of less than a second is, however, normal. For
a recording of eight hours you can expect an offset of maximum 0.5 seconds. 

The video data is saved in the current raw data folder. The file with the extension *.videoconfig and
the base name of the EEG file contains detailed information about the video (names of video files,
time, length etc.). The actual video data is saved to a file with the extension *.VisionVideo. A new
video file is created after every pause in recording. It is therefore possible for one EEG file to be as-
sociated with several video files.

You should always check the size of the video files generated. A value of 150 to 300 kilobytes per
second is possible while maintaining good quality. If, however, your video files have a size of sev-
eral megabytes per second, either a codec that is unsuitable for this task or no codec is selected.

Note: If the video camera is not ready, the video window will show the message ‘Cam-
era Not Connected!’. If the display is black, the most likely cause is an incompatible
codec. In this case, select a different codec.
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12 Object Linking and Embedding (OLE) automation

Recorder can be controlled remotely by other programs using OLE automation methods.

The program ID (ProgID) for external access to Recorder is ‘VisionRecorder.Application’. Recorder
contains a registered type library that is stored in the Recorder.exe. The registry entry for the type
library is Vision Recorder x.x Type Library where x.x stands for the current version.

Under Windows® XP, Windows® Vista and Windows® 7/8, Recorder can also be controlled, for ex-
ample, via a Visual Basic (VB) script batch file, as shown below:

' TestRecorder

' Create recorder object

Set Rec = CreateObject(“VisionRecorder.Application“)

Rec.Acquisition.ViewData()

Rec.Acquisition.StartRecording

(Rec.CurrentWorkspace.RawFileFolder & “\TestData.eeg”)

WScript.Sleep 5000 ' Analyzer Macro: use Wait 5

Rec.Acquisition.StopRecording()

Rec.Acquisition.StopViewing()

Rec.Quit

In this example, Recorder is started, data is displayed and an EEG file named TestData.EEG with a
length of 5 seconds (5,000 milliseconds) is stored. If you are using Analyzer, you can also control
Recorder by means of an Analyzer macro. The macro looks like this:

' TestRecorder

Sub Main

' Create recorder object

Set Rec = CreateObject(“VisionRecorder.Application”)

Rec.Acquisition.ViewData()

Rec.Acquisition.StartRecording

Rec.CurrentWorkspace.RawFileFolder & “\TestData.eeg”)

Wait 5

Rec.Acquisition.StopRecording()

Rec.Acquisition.StopViewing()

Rec.Quit

End Sub

This chapter will not deal with programming in depth but will just outline the Recorder's object mod-
el.
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Figure 12-1. Object hierarchy of the Recorder

In the following sections the objects are described in Visual Basic notation.

Application

CurrentWorkspace

Acquisition

Menu
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12.1 Application

Description

The Application object represents the program as a whole. It is the default object, which means 
that the methods and properties of this object can be addressed directly, for example ‘Version’ 
corresponds to ‘Application.Version’.

Methods

Sub Quit()

Terminates the program

Properties

Acquisition As Acquisition

Write-protected
The Acquisition object.

CurrentWorkspace As CurrentWorkspace

Write-protected
The current workspace.

Menu As Menu

Write-protected
The Menu object.

State As VisionRecorderState

Write-protected
The program status, see below for enumerator types.

SubLicenses As Licenses

Write-protected
Lists the registered sublicenses.

Version as double

Write-protected
Specifies the current program version.

DisableThreadBlockingMode as Bool

Disables thread-blocking call of the Recorder functions: ViewData, ViewImpedance, and oth-
ers.
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12.2 Acquisition

Description

This object controls recording.

Methods

Sub Continue()

This resumes interrupted recording.

Sub DCCorrection()

This performs a DC offset correction.

Sub Pause()

This interrupts recording.

Sub StartRecording(FileName As String, [sComment As String]))

This starts recording to ‘FileName’.
An optional comment can be specified.

Sub StopRecording()

This stops recording.

Sub StopViewing()

This stops the viewing of data, test signals or impedance measurements.

Sub ViewData()

This displays data, or starts monitoring.

Sub ViewTestSignal()

This displays test signals.

Sub ViewImpedance()

This displays impedance measurements.

Sub SelectMontage (Montage As String)

This selects a montage that has already been defined.

Sub SetMarker (Description As String, [MarkerType As String])

This inserts a marker in the EEG. Description = Description of the marker. 
MarkerType is optional. The default value is ‘Comments’, other types are ‘Stimulus’, 
‘Response’, etc.
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Properties

GetAcquisitionState as Integer

Write protected
Returns current state of the acquisition:
STOPPED = 0;
RUNNING = 1;
WARNING = 2;
ERROR = 3;

GetLastAcquisitionError as String

Write protected
Returns a message in case of error state in the Acquisition module. 
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12.3 CurrentWorkspace

12.4 License

Description

This object represents the current workspace.

Methods

Sub Load(FileName As String)

Loads the specified workspace file ‘FileName’.

Properties

FullName As String

Write-protected
Name of the workspace file including full path.

Name As String

Write-protected
Base name of the workspace file without folder and file name extension.

RawFileFolder

Write-protected
Folder for raw data.

Description

This object describes a license/sublicense (for example a video sublicense).

Methods

./.

Properties

ID As Long

Write-protected
Unique ID of the license.

Description As String
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Write-protected
Description of the license.
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12.5 Licenses

12.6 Menu

Description

This object comprises a list of ‘License’ objects.

Methods

./.

Properties

Count As Long

Write-protected
Number of licenses in the list.

Item(Index As Long) As License

Default element, write-protected
On specifying the index (1-...), returns a ‘License’ object.

Description

This object allows manipulation of the menu.

Methods

Sub DisableMenuItem(MenuItem As VisionRecorderMenuItem)

This disables a menu option; the option to be disabled is specified in ‘MenuItem’ (see ‘Enu-
merator types’).

Sub EnableMenuItem(MenuItem As VisionRecorderMenuItem)

This enables a menu option; the option to be enabled is specified in ‘MenuItem’ (see ‘Enu-
merator types’).

Sub Reset()

This resets all manipulated menu options.
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12.7 Enumerator types

The following sections describe the various enumerator types.

12.7.1 VisionRecorderMenuItem

Constants for the various menu items that can be addressed with the ‘Menu’ object:

Enum VisionRecorderMenuItem

vrMiMonitoring = 32777,

vrMiImpedanceCheck = 32778,

vrMiTestsignal = 32779,

vrMiStartRecording = 32791,

vrMiPauseRecording = 32792,

vrMiStopRecording = 32793,

vrMiStop = 32780,

End Enum

12.7.2 VisionRecorderState

Constants for the various states of the program:

Enum VisionRecorderState

vrStateOff = 0 ' Idle state

vrStateMonitoring = 1 ' Viewing EEGs

vrStateTestsignal = 2 ' Test signal

vrStateImpedanceCheck = 3 ' Impedance measurement

vrStateSaving = 4 ' Saving data

vrStateSavingTestsignal = 5 ' Saving test signals

vrStatePause = 6 ' Data saving paused

vrStatePauseTestsignal = 7 ' Data saving paused 
' displaying test signal

vrStatePauseImpedanceCheck = 8 ' Data saving paused, ' display-
ing impedance

End Enum
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13 Remote Data Access (RDA)

While it is being displayed, the EEG data can be passed to other programs on the local computer
and to computers in a network via TCP/IP. This is referred to as remote data access (RDA). In this
process, the Recorder acts as the server, and the program receiving the data acts as a client. Up to
ten clients can be logged in to the RDA server at the same time.

This chapter describes the interface that enables you to implement your own Online analysis pro-
grams or bio-feedback methods. In principle, you can use different programming languages to do
this. You can also develop and run a client program under Linux or other operating systems.

13.1 Example

RDAClient is a program that was developed with Microsoft Visual C++ Version 6.0 under Windows®.
You can find the example project on the Application Suite USB in the \Software\Recorder\RDA_Cli-
ent directory. RDAClient establishes the connection to the server, and then waits for data in a loop.
When data arrives, it is stored in BrainVision-compatible EEG files. The name of the computer on
which Recorder is running is passed to the program as an argument. If this argument is not speci-
fied, the local computer is examined.

There is a 16-bit and 32-bit version of the RDAClient. The 16-bit version works with amplifiers and
A/D converters with an A/D range of a maximum of 16 bits. The 32-bit version covers an A/D range
of up to 25 bits.

Before the RDA server can run, it must have been enabled in the Recorder. To do this, choose Con-
figuration > Preferences..., select the Remote Data Access tab and select the Enable Remote Data
Access box.
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Figure 13-1. Enabling the RDA server

One key term in programming involving TCP/IP is ‘socket’. A socket is the combination of a TCP/IP
address and a port number. This combination describes a specific service on a computer. One well-
known, implicitly used service is, for example, the HTTP protocol on a Web server. This uses port
number 80 by default. The Recorder's RDA server uses two port numbers: 

 port 51234 for 16-bit data;

 port 51244 for 32-bit data.

The first task of the client program is to establish a connection to the server's RDA service using the
port number. This is done using standard socket programming that we will not explain here. You will
find an example of this in the file RDAClient.cpp or RdaClient32.cpp located in an zip-archive on the
Application Suite USB (\Software\Recorder\RDA_Clients). Then the client waits for data or messages
to be sent from the server. The client itself never sends data to the server.

Every data block received contains a header of the type RDA_MessageHeader. You can find the
declaration of this header and all other structures and constants in the file RecorderRDA.h (Applica-
tion Suite USB). The header consists of three parts:

 guid is a 128-bit constant for unique identification.

 nSize describes the total length of the block.

 nType describes the type of this message. Four message types are in use at present:

Message type Meaning

1 start of message (RDA_MessageStart)

2 data block (RDA_MessageData) for clients on port 51234

3 end of message (RDA_MessageStop)

4 data block (RDA_MessageData32) for clients on port 51244
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The messages in detail:.

RDA_MessageStart (nType = 1)

This message is sent by the server (1) when it switches to monitoring mode and (2) after a
client has logged in during monitoring.

In addition to the header, data is sent on the number of channels (nChannels), the sam-
pling interval in μS (dSamplingInterval), the sensitivity of the channels in μV sepa-
rately for each channel (dResolutions) and the channel names (sChannelNames). The
size of the dResolutions field is flexible and depends on the value of nChannels.
sChannelNames contains all channel names in one string. The individual channel names
are null-terminated.

The WriteHeaderFile(RDA_MessageStart* pMsg) routine in the file
RDAClient.cpp shows how the fields can be exploded.

RDA_MessageData (nType = 2)

This message is only received by clients that have logged in via port number 51234. This
message is used to transfer 16-bit data. It consists of the following elements:

 nBlock specifies the current block number since the start of monitoring. The number
can be used to identify whether a block has not been processed fast enough, thus
causing a data overflow. An example of this is given in the file RDAClient.cpp (BrainVi-
sion program USB).

 nPoints specifies the number of data or sampling points in this block.

 nMarkers defines the number of markers in this data block.

 nData[] is the actual data in the form of 16-bit signed integers. The number of values
is derived from nPoints and RDA_MessageStart.nChannels.

 Markers is a data field with markers of the RDA_Marker type. The individual ele-
ments of this field can have different lengths.

A marker of the RDA_Marker type consists of the following:

 nSize specifies the size of the marker in bytes.

 nPosition specifies the relative position in the data block in sampling points (0 -...).

 nPoints specifies the number of points covered by this marker (mostly 1).

 nChannel specifies the channel number to which this marker has been assigned (at
present only -1 = all markers).

 sTypeDesc specifies the type and description of the marker as null-terminated text.

You will find examples of how to handle data and markers in RDAClient.cpp (Application
Suite USB) in the routines WriteDataBlock(RDA_MessageData* pMsg) and
WriteMarkers(RDA_MessageData* pMsg, ULONG nOffset, ULONG

nExistingMarkers).
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RDA_MessageStop (nType = 3)

This message consists of the header only, and indicates the end of monitoring.

RDA_MessageData32 (nType = 4)

This message is only received by clients that have logged in via port number 51244. Its
structure is identical to that of RDA_MessageData with the exception of the fData[]
field, which replaces the nData[] field.

fData[] is the current data in the 32-bit IEEE floating point format. The number of values 
is derived from nPoints and RDA_MessageStart.nChannels.

You will find detailed information on RDA clients in the examples (C++, Python,
MATLAB®) on the Application Suite USB in the directory \Software\Recorder\RDA_Cli-
ent.
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Appendix A The Graphical User Interface (GUI) 

The menu bar and the toolbar are located at the top of Recorder window.

Figure 14-1. User interface: (1) menu bar, (2) toolbar, (3) status bar
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1 Menu bar

2 Toolbar

You use the toolbar mainly to control the operating modes and display options of Recorder.

Note: When you position the mouse pointer over an element, a tool tip will appear. (The status bar
at the bottom of the workspace contains additional brief information on the elements.)

File open, edit or create a workspace

View show and hide the status bar

Display Montage  display and edit the montages

Amplifier

contains amplifier-specific settings and settings for the test signal.
The available options depend on your amplifier. The Amplifier menu
does not show if you have selected the Simulated Amplifier. 

As administrator you can limit the access to the amplifier settings
for standard users. 

Configuration

 select the default settings for the locations used to archive and
store the work files and the data 

 configure user rights and user settings

 select the amplifier

Window arrange the data windows

Help
open program information and the installed components and to
open this user manual

Monitor starts the data view (monitoring).

Impedance Check starts impedance measurement.

Test Signal: If the connected amplifier permits, you can click this button to display the
test signal and save the test signal in the current EEG file.
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Start/Resume Recording starts recording or resumes it after a pause. A dialog box opens
in which you can enter a comment. This comment is saved in the EEG file. A file name is
proposed which you can either accept or change.

Pause Recording pauses the recording. While Recorder is in pause mode, you can mea-
sure the impedance without closing the EEG file.

Stop Recording stops the recording. You can continue recording by clicking the Start/Re-
sume Recording  button.

Stop Monitoring closes monitoring mode. Note that you can only close the program when
you have explicitly stopped the recording and then closed monitoring mode by clicking
the Stop Monitoring button.

Increase Interval increases the time interval displayed (alternatively use the keyboard
shortcut Ctrl + Num(–)).

Decrease Interval decreases the time interval displayed (alternatively use the keyboard
shortcut Ctrl + Num(+)).

Scale Up increases the scale (alternatively use the keyboard shortcut Ctrl + arrow up).

You can assign different scaling factors to each channel, for example the ECG channels.

Scale Down decreases the scale (alternatively use the keyboard shortcut Ctrl + arrow
down).

Decrease Channels decreases the number of channels displayed. Alternatively, you can
select individual channels to view them separately (see View options).

Increase Channels increases the number of channels displayed.

Next Group switches to the next channel group.

Previous Group switches to the previous channel group.

The Next Group and Previous Group functions are enabled if you have previously reduced
the number of channels or if you are working with more than 64 channels, in which case
it is not possible to show all channels together.

 Baseline Correction in Display activates or deactivates baseline correction. When activat-
ed, only the baseline of the representation is changed, and not the actual data.

Annotation allows you to enter a free text (alternatively use the keyboard shortcut <Ctrl-
A>).

You will find information on entering comments in Annotations. 
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DC Correction activates or deactivates DC offset correction for the DC amplifier (alterna-
tively use the keyboard shortcut <Ctrl-D>). DC offset correction acts directly on the data.
This button only appears in the toolbar if you are using a BrainAmp DC, BrainAmp MR plus
or BrainAmp ExG.

You will find information on DC offset correction in DC-offset correction.

Display Filter activates or deactivates the filters. You can toggle this button during moni-
toring or recording. The preset value for this function can be found in the New Workspace/
Edit Workspace dialog box > Software Filters page > Display Filters tab > Enable Filters
check box (see also Workspace wizard 3: Filter settings). This setting (filter on/off) is re-
tained even if you pause and restart monitoring and recording. The workspace file is not
changed. If you close Recorder, the old workspace with the setting made there is loaded
when the program is restarted.

Show Workspace Info shows the configuration of the current workspace. The information
contains all the settings made when editing the workspace except for the settings made
on the first page of the dialog box Edit Workspace – Data Files Settings.

Cascade Windows cascades all the open segmentation and averaging windows one after
another.

The three functions only arrange the segmentation and averaging windows. If you are not
performing any segmentation/averaging, the icons are disabled.

Tile Windows arranges the windows next to each other.

Tile Windows arranges the windows one above the other.

About contains version information and information on the connected dongle.
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3 Status bar

Program status (or operating mode). There are the following modes: 

 monitoring

 impedance check 

 test signal 

 saving 

 pause.

The second section shows the type of montage used.

For further information on montages, refer to Montages.

The third section shows the name of the currently open EEG file.

The fourth section shows the elapsed recording time of the currently open
EEG file.

The fifth section shows the amount of free hard disk space in hours. This
information is only available when an EEG file is open.

The sixth section shows the utilization of the internal cache as a percent-
age.

The  seventh section shows a battery symbol indicating the battery volt-
age (for some amplifiers). The charge level of the battery is indicated by a
color (green, yellow, red). 

 Green: good battery charge

 Yellow: replace or recharge the battery.

 Red: operation will automatically stop after a few minutes, to prevent
the battery from completely discharging and to ensure that no artifacts
occur in the recorded data due to an insufficient power supply.

The final section of the status bar contains the name of the current work-
space.
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Appendix B Dongle information and licenses 

1 Identify your dongle

Your license dongle has an external dongle label and a key ID. 

Prepare

- License dongle

- Recorder

1 The external dongle label is an ID that is printed on your license
dongle. Take note of this number.

 Unnnnn: Analyzer local license

 Nnnnnn: Analyzer network license

 Rnnnnn or URnnnnn: Recorder professional license

 URnnnnn: Recorder license for LiveAmp

 URnnnnn: Recorder license for actiCHamp

 URnnnnn: Recorder license for BrainAmp

 VURnnnnn: Recorder license for V-Amp

 URAnnn: Analyzer/Recorder license

 VURAnnnnn: combined Analyzer/Recorder license for V-Amp

 UCnnnnn: CapTrak license

2 Plug the dongle into the recording computer. 

3 The key ID is a nine-digit number. To find it, open Recorder and
click on Help > About BrainVision Recorder...

You can register your product on http://www.brainproducts.com.

http://www.brainproducts.com
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2 About the licenses

Some optional components of Recorder only run when you purchase an add-on license. Depending
on your dongle generation an add-on license is installed on the recording computer and associated
with your dongle or it is installed directly on the dongle. You can run both generations at the same
time and you can install add-on licenses for different dongles on one computer.

When you purchase an add-on license together with Recorder, it will be installed on the license don-
gle. If you purchase an add-on license later, you can download it from the Brain Products website

3 Amplifier specific licenses 

Amplifier specific licenses can be purchased for LiveAmp, actiCHamp, BrainAmp and V-Amp. An am-
plifier specific license can only be used with the type of amplifier for which it was purchased, for
example a Recorder license for LiveAmp cannot be used with BrainAmp.   

 To identify the license type select Help > Show Installed components...  

A workspace created using an amplifier specific license can also be used with a Recorder profes-
sional license and vice versa. 

4 Installing add-on licenses

You must install add-on licenses that are purchased later.

Pre-requisites

- Internet access 

alternatively: USB stick with license file (start with step 3)
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- Administrator rights

- License dongle connected

1 Register your dongle.

 Open http://www.brainproducts.com and choose Downloads & Support > Product Regis-
tration.

 Follow the instructions on the screen.

2 Download the license file.

 Go to http://www.brainproducts.com and choose Downloads & Support > Downloads.

 To log in use the username and password from the confirmation mail. 

 Select the License File for Analyzer 1 and/or Recorder.

3 Install the add-on license.

 Open the folder to which you have downloaded the file. Alternatively, open the USB stick.

 Double-click on the file and follow the installation routine. 

4 Check if the add-on licenses were installed. 

 Open Recorder and choose Help > About BrainVision Recorder...

If the add-on licenses were not installed correctly, run the license file as administrator.

Note for administrators

The installed add-on license is stored in the directory C:\Windows\SysWOW64 or
C:\Windows\System32 (architecture dependent) with the extension *.BPLCS. The file
is in signed text format.

Don’t change this file, otherwise the add-on license will become invalid.
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Appendix C Format of the EEG files

The current version of the Recorder supports the BrainVision Data Exchange Core Format 1.0 only.
This format is described in this appendix.

An EEG recording consists of three files: the header file, the marker file and the data file. All three
files are stored in the raw file folder. 

1 Header file

The header file... 

 describes the EEG data file. 

 is a text file with the extension .vhdr. 

 has the same base name as the raw data EEG file. 

Here is an extract from a header file as an example:

Brain Vision Data Exchange Header File Version 1.0

; Data created by the Vision Recorder

[Common Infos]

Codepage=UTF-8

DataFile=000007.eeg

MarkerFile=000007.vmrk

DataFormat=BINARY

; Data orientation: MULTIPLEXED=ch1,pt1, ch2,pt1 ...

DataOrientation=MULTIPLEXED

NumberOfChannels=48

; Sampling interval in microseconds

SamplingInterval=5000

[Binary Infos]

BinaryFormat=INT_16

NEW
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[Channel Infos]

; Each entry: Ch<Channel number>=<Name>,<Reference channel name>,

; <Resolution in “Unit”>,<Unit>, Future extensions..

; Fields are delimited by commas, some fields might be omitted (empty).

; Commas in channel names are coded as “\1”.

Ch1=1,,0.1,µV

Ch2=2,,0.1,µV

...

Ch41=41,,0.1526,C

Ch42=42,,0.0763,mm

Ch43=43,,0.1526,mm

Ch44=44,,152.6,µV

...

[Comment]

A m p l i f i e r  S e t u p

============================

Number of channels: 48

Sampling Rate [Hz]: 200

Sampling Interval [µS]: 5000

Channels

--------

S o f t w a r e  F i l t e r s

==============================

# Low Cutoff [s] High Cutoff [Hz] Notch [Hz]

1 0.0006366 Off Off

2 0.0006366  Off Off

...

41 0.0006366 Off Off

42 0.0006366  Off Off

# Name Phys. 
Chn

Resolu-
tion/Unit

Low 
Cut-
off 
[s]

High 
Cut-
off 
[Hz]

Notch 
[Hz]

Series 
Res.
[kOhm]

Gradient Offset

1 1 1 0.1 µV DC 250 Off 0

2 2 2 0.1 µV DC 250 Off 0

...

41 41 41 0.1526 C DC 250 Off 0 1[mV/C] 0.02[mV] = 0[C]

42 42 42 0.0763 mm DC 250 Off 0 2[mV/mm] 0[mV] = 0[mm]

43 43 43 0.1526 mm DC 250 Off 0 1[mV/mm] 1[mV] = 0[mm]

44 44 44 152.6 µV DC 250 Off 0

...
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43 0.0006366 Off Off

44 0.0006366  Off Off

...

Impedance [kOhm] at 12:10:43:

1: Out of Range!

2: Out of Range!

...

41: Out of Range!

42: Out of Range!

43: Out of Range!

44: Out of Range!

...

Ref: Out of Range!

Gnd: Out of Range!

The following first line identifies the header file, states its version and is mandatory. 

Brain Vision Data Exchange Header File Version 1.0

Neither white spaces nor comments must be added before this line!

A semicolon at the beginning of a line identifies a free-text comment. This line is ignored. Blank
lines are also ignored. 

The format of the header file is similar to a Windows® INI file. It consists of various named sections
containing keywords/values. A section is identified by a line with a heading enclosed in square
brackets. The header extract above, for example, contains a Common Infos section. A header file can
contain an unlimited number of sections.

The subsequent lines contain some keywords for this section and the values that have been as-
signed to them. A keyword can only occur once in a section. Its meaning depends on the section in
which it occurs. There must not be a space before or after the equals sign. Most predefined key-
words have a default value which is used by the Brain Products’ Generic Data Reader if a keyword is
not found.

The various predefined sections with keywords, their meanings and default values are listed below.

The amplifier setup parameters are listed in the Amplifier-Setup starting at
Chapter 6.1.
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 needs to
ile is read.

t available
re File For-

ue is man-

 is a man-

ssible val-
 Core file

LTI-
l entry, i.e.
lt value is

AIN is an
if missing
ssumed.
‘Common Infos’ section of the header file 

Keyword Meaning Default Value Comment

Codepage

Character encoding defined by Codepage. Possible
value: UTF-8

Character encoding is done according to UTF-8.

ANSI

In fact, the encoding
be known before the f

The value ANSI is no
in the BrainVision Co
mat 1.0.

DataFile

Name of the EEG data file. It is assumed that the
header file, the optional marker file and EEG data file
are in the same folder. The placeholder $b can be
used in the file name. It is replaced by the base name
of the header file when the file is read in. 

Example
If the name of the header file is Test.vhdr, the entry
Data-File=$b-EEG.dat is interpreted as Data-
File=Test-EEG.dat.

None
The keyword with val
datory.

MarkerFile

Name of optional marker file. If exists the marker file
contains a list of markers assigned to the EEG. It is
assumed that the marker file is in the same folder as
the header file. For the format of the marker file refer
to Marker file section below. The placeholder $b can
be used in the file name (see example above).

None

DataFormat Data format. Possible value: BINARY ASCII

DataFormat=BINARY
datory entry.

BINARY is the only po
ue in the BrainVision
format.

DataOrienta-

tion

Data orientation. Possible value: MULTIPLEXED

All the channels come one after the other for every
data point. In other words, the data structure is mul-
tiplexed

MULTIPLEXED

DataOrientation=MU
PLEXED is an optiona
if missing the defau
assumed. 

DataType
Data type. Possible value: TIMEDOMAIN

The data is in the time domain.
TIMEDOMAIN

DataType=TIMEDOM
optional entry, i.e. 
the default value is a
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er.

er

ntry, i.e. if
alue is as-

rresponds
D=NO.

er.

rresponds
D=NO.

er.

rresponds
D=NO.
NumberOf-

Channels
Number of channels in the EEG file. None

Mandatory entry.
Value is of type integ

SamplingIn-

terval

Sampling interval. The interval is specified in μs in
the time domain.

None
Mandatory entry.
Value is of type integ

Averaged

This indicates whether the data set to be read in has
been averaged. Possible values are: 

YES

Yes, the data set represents data that has been aver-
aged. 

NO

No, the data set represents data that has not been
averaged.

NO
This is an optional e
missing the default v
sumed.

 Averaged
Segements

This value is only evaluated if AVERAGED=YES. In
this case the value states the number of segments
included in the average.

0

The default value co
to the case AVERAGE

Value is of type integ

 SegmentData-
Points

This value is only evaluated if AVERAGED=YES. In
this case the value states the number of data points
in each segment, i.e. each segment has the same
length.

0

The default value co
to the case AVERAGE

Value is of type integ

 Segmentation-
Type

Possible values are: 
NOTSEGMENTED
The data set has not been segmented. 

MARKERBASED
The data set has been segmented on the basis of one
or more marker positions. This value is only evaluat-
ed if AVERAGED=YES.

NOTSEGMENTED
The default value co
to the case AVERAGE

Keyword Meaning Default Value Comment
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is of type

l name> is

nit"> is of

ring

_16 is an
if missing
ssumed.
‘Channel Infos’ section of the header file 

‘Binary Infos’ section of the header file

This section contains general information on the EEG file. 

Keyword Meaning Default Value Comment

Ch<x>

<x> stands

for the chan-

nel number.

In other

words, the

keyword for

the first

channel is

Ch1, for the

second chan-

nel Ch2, etc.

Individual properties for the channel are specified
separated by commas:

<channel name>,<reference channel name>, <resolu-
tion in "unit">[, <unit>]

Example
Ch1=Fp1,,0.1,μV

The first channel has the channel name "Fp1". The
common reference channel is taken as the reference
channel because no entry has been made. The reso-
lution is 0.1 μV. The resolution is the value by which
the value of the data point is multiplied to convert it
to the channel unit (i.e. μV or the selected unit).

<channel num-
ber>,
,1.0,μV

 <channel name> 
string

 <reference channe
of type string

 <resolution in "u
type float

 <unit> is of type st

Keyword Meaning Default Value Comment

BinaryFormat

Binary format. Possible values:
IEEE_FLOAT_32
IEEE floating-point format, single precision, 4 bytes
per value

INT_16
16-bit signed integer

INT_16
BINARYFORMAT=INT
optional entry, i.e. 
the default value is a
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 float

loat

at

itional in-

not inter-
ion unam-
‘Coordinates’ section of the header file 

‘Comment’ section of the header file 

Keyword Meaning Default Value Comment

Ch<x>

<x> stands

for the chan-

nel number.

In other

words, the

keyword for

the first

channel is

Ch1, for the

second chan-

nel Ch2, etc.

Coordinates of an individual channel in the form:

<Radius>, <Theta>, <Phi>

Example

Ch1=1,-92,-72

The electrode coordinate system is described in
Section D on page 184.

-

 <Radius> is of type

 <Theta> is of type f

 <Phi> is of type flo

Keyword Meaning Default Value Comment

- Arbitrary content -

 To be used for add
formation only. 

 Data readers can
pret this informat
biguously.

Lines starting with a “;” are interpreted as comments and are ignored, except the
“Comment” section where “;” has no special meaning.
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s to be
 is read.

t available
re File For-
2 Marker file

The marker file is based on the same principle of sections and keywords as the header file. The fol-
lowing first line identifies the marker file, as follows: 

Brain Vision Data Exchange Marker File Version 1.0 

Neither white spaces nor comments must be added before this line!

The various predefined sections with keywords, their meanings and default values are listed below.

‘Common Infos’ section of the marker file

Keyword Meaning Default Value Comment

Codepage

Character encoding defined by Codepage. Possible
value: UTF-8

Character encoding is done according to UTF-8.

ANSI

The encoding need
known before the file

The value ANSI is no
in the BrainVision Co
mat 1.0.

DataFile

Name of the EEG data file. 

It is assumed that the header file, marker file and
EEG data file are in the same folder.

None -
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of type

type un-

 unsigned

 is of type

n “mean-

Segment”
formation
‘Marker Infos’ section of the marker file

Marker information. The individual markers and their properties are listed in this section.

Keyword Meaning Default Value Comment

Mk<x>

<x> stands for the
marker number.
In other words,
the keyword for
the first marker is
Mk1, for the sec-
ond marker Mk2,
etc.

Individual properties for the marker are specified
separated by commas: <type>, <description>, <posi-
tion>, <points>, <channel number>[, <date>]

Example

Mk1=Time 0,,26,1,0

The first marker in this example has the type "Time
0", no description, its position is at data point 26, its
length is 1 data point, and the channel number is 0,
which means that this marker applies to all chan-
nels.

The date is optional. It is only evaluated if the marker
type is "New Segment".

The date has the following format:
4 digits = year
2 digits = month
2 digits = day
2 digits = hour (24-hour system)
2 digits = minute
2 digits = second
6 digits = microsecond

The result is a time resolution of a microsecond.

Example

19990311140312003012
means 11 March 1999, 14:03:12.003012

None

 <description> is 
string

 <position> is of 
signed integer

 <points> is of type
integer

 <channel number>
integer

 <date> see colum
ing”

 In case of “New 
marker the date in
is provided.
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Appendix D Electrode coordinate system

Electrode coordinates are required whenever analytical procedures make use of channel positions
or when topographies have to be output in 2D or 3D.

Spherical coordinates are used to specify a point on the surface of the head. A set of coordinates
consists of the three variables r, θ and ϕ (radius, theta and phi).

The radius r specifies the distance (in millimeters) between point P and the origin of the coordinate
system. The only exceptions are r = 0 and r = 1. r = 0 signifies an invalid position, for instance when
the position of an electrode is not known. When realistic electrode coordinates are used, r can have
a different value for each channel. In other cases, the value of r should be the same for all the chan-
nels if a spherical head model is used. For instance, in the Analyzer's standard coordinate system,
r = 1.

ϕ specifies the angle between the x-axis and the projection of the line connecting the point P and
the origin of the coordinate system on the xy plane. In the case of the front right and back left quad-
rants, ϕ > 0; for the back right and front left quadrants, ϕ < 0.

θ is the angle between the z-axis and the line connecting the point P and the origin of the coordinate
system. In the right hemisphere, θ > 0. In the left hemisphere, θ < 0.

The figure below illustrates the coordinate system used by Analyzer. The x-axis extends from chan-
nel T7 on the left side of the head (negative values) to channel T8 on the right side of the head (pos-
itive values). The y-axis runs from the back to the front of the head via channel Fpz (positive values).
The z-axis runs from the bottom of the head toward the crown via channel Cz (positive values).
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Figure D-1. Coordinate system for electrodes
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Appendix E Troubleshooting

1 Where is my add-on license?

If your add-on license does not work, try the procedure below.

Prepare:

- License dongle

1 Identify your dongle.

2 Connect the dongle to the recording computer.

3 Start Recorder.

4 Click on Help > About.

5 Check the first line in the text field: 

 HASP-HL: add-on information is installed on
the computer and not on the dongle.

If you use the dongle on another or new com-
puter install the add-on again. 

 SRM: add-on information is installed on the
dongle. You can use the dongle on any Record-
ing computer without installing the add-on li-
cense anew.
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2 Buffer overflow messages

Buffer overflow messages can be caused by insufficient resources of your computer.  Software that
runs in the background, like certain Windows® features, consume a lot of your system’s resources.
Switch the features off and stop programs that run in the background:

 Internet browser (for example, Microsoft Edge, Internet Explorer, Firefox, Chrome, Opera)

 sleep mode

 Windows® Update

 Windows® Defender

 Disk Defragmenter

 USB selective suspend setting

Finding the programs

To find a program use the Search function. This works across all Windows® platforms.

1 Type in the name of the program.

For example DEFENDER.

2 Click on the program you are looking for. 

This will open the dialog, for example Windows® Defender.
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Close unused programs

Deactivate Windows® Defender

Windows® Defender can block certain programs on your computer. 

1 Open the dialog Windows Defender (search for DEFENDER).

2 In the menu bar of the Windows Defender dialog click on Tools.

3 Then click on Options.

4 To deactivate Windows Defender across the entire system: 

 choose the Administrator option,

 deselect the check box Use this program,

 click on Save.

Deactivate the sleep mode

When activated, your computer could go into the standby mode, in which all programs stop working.
Therefore, deactivate the sleep mode.

1 Open the dialog Change when the computer sleeps (search for SLEEP MODE).

2 Specify that the computer is never put to sleep and save this setting.

Deactivate Windows® Update

1 Open the Windows Task Manager (search for TASK MANAGER). 

2 End the programs (tasks) that you
don’t need during the recording. 

Make sure that all Internet browsers
are closed during the recording.
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Windows® Update can consume a lot of your system and network resources, causing your computer
to slow down.

1 Open the dialog Windows Update (search for UPDATE).

2 Click Change settings in the side panel.

3 Under Important updates, choose Never check for updates and click on OK.

Deactivate the Disk Defragmenter

The Disk Defragmenter is a background process, that can consume your system resources.

1 Open the dialog Disk Defragmenter (search for DEFRAGMENTER).

2 Then click on the button Configure schedule.

3 In the Disk Defragmenter Modify Schedule dialog: 

 deselect the check box Run on a schedule,

 click on OK.

Deactivate USB selective suspend setting

To save power, Windows® switches off the USB ports, when not in use. This also applies to the USB
port, to which the license dongle is connected. If this port is switched off, Recorder may not function
correctly anymore. This usually happens during long recordings (for example, over night).

1 Open the dialog Power Options (search for POWER OPTIONS).

2 Next to the selected power plan, click on Change settings. 

3 Then click on Change advanced power settings. 

4 Scroll to the USB settings 

 and select Disabled from the drop-down list.

 Click on OK .
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List of abbreviations

RDA . . . . . . . .Remote Data Access

EEG . . . . . . . .Electroencephalogram

EMG. . . . . . . .Electromyogram

ECG . . . . . . . .Electrocardiogram

EOG . . . . . . . .Electrooculogram

LPT. . . . . . . . .Line printing terminal ("parallel port")

EPF  . . . . . . . .Electrode position file

MR . . . . . . . . .Magnetic resonance

MR . . . . . . . . .Magnetic resonance

GSR . . . . . . . .Galvanic skin response

BUA . . . . . . . .BrainVision USB2 Adapter

AUX . . . . . . . .Auxiliary

TTL. . . . . . . . .Transistor-transistor logic

TCP/IP . . . . . .Transmission Control Protocol/Internet Protocol

DC . . . . . . . . .Direct current



       191
Glossary

A
A/D conversion: Conversion of analog measure-
ments into digital form so that they can be saved to
hard disk and further processed using software.

actiCAP active electrode system: Electrode sys-
tem (including control software) from Brain Prod-
ucts featuring active electrodes which is used for
acquiring EEG signals and can be combined with all
amplifiers available from Brain Products.

actiCAP ControlSoftware: Software from Brain
Products that allows the actiCAP active electrode
system to be controlled and configured. The acti-
CAP ControlSoftware can also be controlled from
Recorder.

Active electrode: Electrode with integrated circuits
(impedance converters) which makes it possible to
perform recordings at high transition resistances.

Active Shielding: Recording mode that allows am-
bient noise, interference due to electrical effects
and artifacts due to cable movement to be mini-
mized.

Add-on license: Depending on the Recorder ver-
sion licenses for additional modules are called
’sublicenses’ or add-on licenses.

Amplitude: Maximum deflection of the EEG curve
in μV measured from peak to trough.

Analyzer: Software from Brain Products for analyz-
ing EEGs and other physiological signals and which
is able to read and evaluate different file formats
from various vendors.

Artifact: All potential shifts in the EEG recording
that do not have their source in the cortex. Artifacts
can be subdivided into those related to the test
subject (physiological artifacts) and technical inter-
ference. Technical artifacts can be caused by faulty
electrodes, defects in the apparatus or technical in-
terference.

AUX channel: Abbreviation for "auxiliary channel".
Supplementary channel for simultaneously record-

ing polygraph signals such as breathing, ECG, eye
movement, oxygen saturation, etc.

Average reference: Montage type in which the av-
erage of all the selected channels is used as the ref-
erence (see also Montage).

Average: Formation of arithmetic mean using seg-
mentation (total value of the points divided by the
number of segments). This is performed separately
for each EEG channel.

Averaging group: Identifies an averaging opera-
tion defined in the Recorder workspace by specify-
ing one or more markers (q.v.).

B
Baseline: An assumed horizontal line marking the
vertical zero point in the EEG (voltage = 0).

Bipolar connection: Montage type in which the
differences between two channels are calculated
(see also Montage).

BrainAmp family: Amplifiers from Brain Products
with 32 channels each (can be extended) that can
be used in different fields (laboratory acquisition,
combined EEG-fMRI measurements, EEG-TMS mea-
surements, etc.).

Buffer: Memory area for internally buffering record-
ing data.

C
Calibration: Method for checking the response of
an EEG unit when a particular voltage difference is
applied to the amplifier inputs.
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D
DC offset: The average of the EEG signals. If this av-
erage is equal to 0, there is no DC offset. If analysis
is negatively affected by too high a DC offset, it may
be necessary to perform DC offset correction.

Digital port: Parallel interface over which data can
be transferred between a computer and peripheral
devices.

E
Export component: Module of the BrainVision An-
alyzer that can be used to export data sets to files
so that they can be further processed using other
programs.

G
Generic Data Reader: Reader component in Ana-
lyzer that reads data in the formats used by Brain
Products.

Grid view: Representation of the EEG channels in a
grid pattern.; Used for segmentation or montages,
for instance.

H
Header file: File containing general information on
the recording, such as the number and names of
the channels, the electrode coordinates, the sam-
pling rate, the number of data points, etc. Recorder
writes different formats depending on the Recorder
license. Possible extensions: .vhdr, .bhdr, .ahdr,
.lhdr.

High-cutoff filter: Filter that reduces the ampli-
tude of high-frequency digitized signals.

I
Impedance Check View: Display mode of Record-
er, designed to assist the person running the exper-
iment by allowing simple testing of the impedance
values of the individual electrodes.

Impedance measurement: Recorder operating
mode for measuring the resistance of the elec-
trodes.

Impedance: Resistance between the electrode and
the head skin.

Interval: A section of the EEG signal defined by its
starting point and length or by its starting point and
end point within the signal.

Isotropic representation: A representation of the
positions of the electrodes on the head (top view)
in which the head retains its round form because
the horizontal and vertical directions are scaled to
the same degree.

L
Low-cutoff filter: Filter that reduces the amplitude
of low-frequency digitized signals.

M
Marker file: File listing all the markers present in
the data set together with their position, type, de-
scription etc. Recorder writes different formats de-
pending on the Recorder license. Possible
extensions: .vmrk, .bmrk, .amrk, .lmrk.

Marker: Markers mark a point in time or a period
within the EEG. A marker can be an item of stimulus
information that is used to ascertain evoked poten-
tial, but it can also mark a new segment or indicate
that a DC offset correction was carried out at a cer-
tain time. Markers are used for orientation during
segmentation.

Montage: Reconnection of the channels in the
software whereby new voltage references are as-
signed to the channels.

MOVE: Wireless transmission system from Brain
Products consisting of a transmitter and a receiver
which can be used for the wireless transmission of
EEG data between the cap and the amplifier.
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O
OLE automation: Method of controlling Recorder
by means of external programs.

Original reference: Montage type in which no new
reference is calculated, but which instead serves
only to group channels in order to display them op-
timally (see also Montage).

Overlay: The result of overlaying EEG channels of
the same name or data sets with the same sam-
pling rate and the same duration with the aim of
carrying out a direct visual comparison of the data.

P
Physical channel: Hardware-related assignment
of a channel on the basis of its position in an EEG
system.

Polarity: The polarity setting determines whether
the axis for positive measurements points up or
down on EEG curves.

PolyBox: Hardware accessory from Brain Products
for BrainAmp amplifiers that allows up to eight
polygraph signals acquired by sensors to be re-
corded concurrently with the EEG.

Polygraph recording: Simultaneous recording of
different physiological signals such as EEG, breath-
ing, ECG, eye movement, oxygen saturation, etc.

Potential: Frequently used as a synonym for "EEG
wave".

Protective resistor: A resistor fitted in the elec-
trode cables that restricts the power supply in the
event of a fault.

R
Raw file: The EEG file obtained directly during re-
cording without any modifications.

RDA (Remote Data Access): Remote access to Re-
corder or the transfer of data from Recorder to other
programs located on the local computer or on com-
puters in the network. In this process, Recorder
acts as the server, and the program receiving the
data acts as a client.

Resolution: Specifies the granularity with which
the value range of the EEG signal is subdivided
during digital acquisition. A higher resolution
means finer granularity and more accurate acquisi-
tion of the original signal. Unit: μV.

S
Sampling rate: Number of data points measured
per second when acquiring an EEG digitally.

Scaling: In the context of displaying the EEG sig-
nal, scaling is the assignment of an amplitude val-
ue in μV to an interval.

Segment: A section of the EEG resulting from seg-
mentation (q.v.).

Segmentation group: Identifies a segmentation
operation defined in the Recorder workspace by
specifying one or more markers (q.v.).

Segmentation: Subdivision of the EEG into differ-
ent segments (epochs). Segmentation can be
based on a number of different criteria. On the one
hand, segmentation is understood to be a prelimi-
nary stage in the analysis of evoked potentials. Ep-
ochs of the same length are generated relative to a
reference marker (a stimulus, for example). This re-
sults in a data set consisting of a sequence of seg-
ments or epochs. On the other hand, segmentation
is understood to be the preparation of separate
processing steps for different sections of an EEG,
for example for the analysis of different stages be-
fore and after medication.

Sublicense: File associated with the dongle and
which can be used to enable optional functions.

SyncBox: Hardware accessory from Brain Products
for the BrainAmp (ExG) MR/BrainAmp MR plus
which makes it possible to synchronize the sam-
pling rate of the amplifier with the clock rate of the
scanner system.
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T
Ten-ten system (10-10 system): One additional
electrode is positioned between each of the elec-
trodes of the 10-20 system (q.v.).

Ten-twenty system (10-20 system): Internation-
ally recognized, standardized method for position-
ing electrodes on the head. The skull is measured
from defined anatomical points. The distance be-
tween neighboring electrodes is either 10% or 20%
of the measured distances.

Time marker: see Marker.

Trigger: Pulse generated by a device or software
program and which initiates an operation. A pre-
sentation software package can, for example, gen-
erate a trigger each time an image appears. The
trigger can be sent to the amplifier via the parallel
port of the computer and recorded by Recorder as a
marker simultaneously with the EEG. EEG activity
(e.g. an EEG signal of sufficient amplitude or
length) can also be used to generate a trigger pulse
that starts a process (e.g. control of a program).

V
View: Method of representing the EEG, such as the
grid view, the head view, and the mapping view. A
view determines how the channels are arranged in
the window, for example.

W
Workfile: A file containing information on work-
spaces (*.rwksp), montages (*.mont) and other
user-defined settings.

Workspace: Configuration file containing user-de-
fined recording parameters, amplifier settings and
other information. File name extension: .rwksp.
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select __________________________ 33

Amplifier-specific settings
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QuickAmp __________________105–109

Averaging ______________________112–124

C

Connect LiveAmp 8, 16, 32 or 64 with Recorder 
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D

DC correction
activate ________________________ 170
set automatic correction ___________ 31

E

Electrode position files _____________ 39–43
about __________________________ 39
use in workspace _________________ 40

F

Filters _________________________110–111

P

Passive electrodes
select __________________________ 33

R

Remote Data Access (RDA) _______ 163–166
enable _____________________ 31, 163

S

Segmentation __________________ 112–124

Select amplifier ___________________19, 25

Status bar __________________________ 171

T

Toolbar _______________________ 168–170

U

User rights
administrator mode _______________ 25
standard mode ___________________ 25
set user rights ____________________ 28

V

Vision Video
enable __________________________ 32

W

Workspace _______________________34–43
create a workspace _______________ 39
open existing workspace ___________ 43
show workspace settings __________ 43
use electrode position file __________ 40

Workspace for
actiCHamp ___________________63–78
BrainAmp ____________________47–62
LiveAmp _____________________79–99
QuickAmp _________________ 105–109
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Simulated amplifier ____________ 45–46
V-Amp _____________________100–104
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